View Issue Details

IDProjectCategoryView StatusLast Update
0015756MediaMonkey 5Main Panelpublic2019-11-06 19:17
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015756: 'Manage views' functionality seems broken / incomplete
DescriptionI configured another order for columns in "My view" :
https://www.dropbox.com/s/kz9kycq9uza0415/Screenshot%202019-06-17%2021.52.10.png?dl=0

1) the columns order is unchanged when I switched from 'List view' to 'My view'

2) I cannot define which sub-views should be enabled for "My view"\

Edits by Rusty:
1)b) Column chooser is difficult to use because it's a modal dialog and many of the columns aren't visible. Perhaps change the orientation to vertical OR at least display the columns as compactly as possible
1)c) Sorting should be implemented by a 'Sort by:' option (since the current sorting mechanism is non-intuitive)
1)d) Is there a reason why List views don't have a Group by: option (i.e. it's unclear why there's a special view for 'Albums & tracks'--why can't it just be a List view with a 'Group by' option?)

3) 'Browser' view should have options for what displays within (besides the 'Collection grid'). e.g.:
a) Suggested Artists
b) Suggested Albums
c) Pinned items

4)a) For any Grid view or subview that contains images (e.g. Artist suggestions), image size should be a configurable option
b) Ideally, there should be a 'default' image size configured in e.g. Library>Appearance so that users can configure default image size _once_. That way users can leave the 'default' setting in most cases, and only change the setting for specific views.

5) Options > Media Tree should allow the user to configure the views associated with root nodes of the media tree along with the views associated with the Child nodes. This implies:
a) If the user configures Collection options for 'Music', there should be an additional tab for Views (immediately following the 'Criteria' tab). It would contain the same content as 'Manage views' for the Music node.
b) Change 'Tree nodes' --> 'Sub-nodes & Views'
c) It should be possible to edit the Views associated with 'Sub-nodes' by:
. . i) clicking an 'Edit' button
. . ii) double-clicking the subnode
In either case, the 'Manage views...' dialog associated with the subnode should open.
d) Change Media Tree --> Collections & Views
e) Edit Media Tree --> Edit and configure nodes to display
f) Media Tree Item --> Content to display

6) Unless I'm misunderstanding how this is supposed to work, there seems to be a conflict between the Collection config and the Views config--they each respectively give the user the ability to choose what columns to display within a Collection / View, and yet Views are configured independently of Collections. Is this an issue?

NOTE: Once 'Manage views...' is correctly implemented, we should probably eliminate the current context-menu based approach as it is quite messy (especially if we add view configuration options that are missing from the context menu).

TBD (yet to be evaluated):
Other collection-level nodes: Classical, Podcasts, Audiobooks, Music Video, Video, TV, Playlists, Devices & Services, Folders, Pinned
Other top level nodes: Years, Publishers, Rating, Classification, Location, Files to Edit
Lower level nodes: AlbumName, ArtistName, GenreName, etc.
TagsNo tags attached.
Fixed in build2212

Relationships

related to 0015926 feedbackLudek Improvements to navigation of Playlist/Folder hierarchy 
parent of 0015584 closedpetr Views: Subviews should persist on a per-view basis 
related to 0015112 resolvedmichal Missing features in some views 
related to 0015712 resolvedrusty "Art View", "Browser View", "Grid View" - why different names for the same view 
related to 0015801 resolvedrusty Playlists: Grid View is not available 
related to 0014086 closedmichal Add 'Column browser'/Filter to more views 
related to 0016070 closedmichal Choose columns dialog crashes when changing columns visibility - regression. 

Activities

petr

2019-10-22 08:47

developer   ~0055070

Last edited: 2019-10-22 10:23

View 3 revisions

re 1d) i've rather removed Group By option (as there were always just one option). Reason we have 'List' and 'List (by album)' is because this list refrects viewAs options in view handler
re 2) based on 0014132 item 5 sub-views are not configurable

petr

2019-11-06 19:17

developer   ~0055235

Fixed