View Issue Details

IDProjectCategoryView StatusLast Update
0016515MediaMonkey (current)DB/FileMonitorpublic2020-04-14 14:29
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.27 
Target Version4.1.28Fixed in Version4.1.28 
Summary0016515: CPU Utilization always at 25% when Autolookup is enabled
DescriptionIn builds 1902/1903, CPU utilization is always at 25%.

I'm not sure which build this was introduced in, but 4.1.27.1897 (release) doesn't exhibit this issue.
Steps To ReproduceThis is from user PC steps to get 20% CPU Usage and to replicate Rusty behavior:
0. Make sure that Auto lookup AA and Lyrics + Auto save tags disabled
1. Start MM (IDLE is around 0-1%)
2. Enable Auto lookup AA and Lyrics + Auto save tags (IDLE should be still low 2-5%)
2. Restart MM
3. MM CPU usage in IDLE 17-20%
4. Disable Auto Lookup
5. Restart MM
6. MM IDLE Usage back to 0-1%

Additional InformationReported at: MCD-669-75717 and IJD-386-90632
https://www.mediamonkey.com/forum/viewtopic.php?f=1&t=96144&e=1&view=unread#p466923
TagsNo tags attached.
Fixed in build1904

Relationships

related to 0016345 closedmichal Artwork and lyrics lookup issues/regressions 

Activities

rusty

2020-04-13 15:35

administrator  

cpu_25_build1903.7z (24,392 bytes)

rusty

2020-04-13 16:25

administrator   ~0057587

Note: on further testing, it's related to the fact that I have a tab open containing a playlist. i.e. the bug only occurs upon clicking a playlist node (not an AutoPl0aylist node).

rusty

2020-04-13 17:22

administrator   ~0057588

On further testing, the bug _does_ occur in build 1897 as well upon selecting the Now Playing node or a Playlist!

rusty

2020-04-13 17:46

administrator   ~0057589

Last edited: 2020-04-13 18:09

View 3 revisions

On further testing, the issue seems to occur when specific tracks are included in either a Playlist or the Now Playing list.
The following playlists each contain a single track which triggers the issue:
Test 2032 : Depeche Mode - Sacred
Test2033 : Depeche Mode - Little 15

Note that this appears to be a database issue rather than a track-specific issue since scanning these tracks into a new database and adding them to a playlist fails to trigger the bug.

Full DB shared offline.

Ludek

2020-04-13 20:04

developer   ~0057590

I can replicate the issue on Rusty's config and is related to artwork lookup (as it does not happen when '[ ] Search for missing artwork' is disabled).

Sounds like the same issue that we have been solving here: https://www.mediamonkey.com/forum/viewtopic.php?f=1&t=96144&e=1&view=unread#p466923

peke

2020-04-13 20:30

developer   ~0057592

CPU Usage on Idle without Auto Album art lookup enabled.

michal

2020-04-14 09:43

developer   ~0057595

Fixed in build 1904.

rusty

2020-04-14 14:29

administrator   ~0057598

Verified 1904.