View Issue Details

IDProjectCategoryView StatusLast Update
0015712MediaMonkey 5Main Panelpublic2019-09-06 18:07
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015712: "Art View", "Browser View", "Grid View" - why different names for the same view
DescriptionAs reported here:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94520

We have three different names for the same view type: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94520
Screenshot: https://photos.google.com/share/AF1QipMVpnrwvObzK518uvnyAB86WwsWaRC9rms5V8_MnGy9Fuv9LNLxGpIoWgKMhnM3hQ?key=VTh3MV9OeFFsSzhJUWN5Z2t0eE1tZEppbkp6Y2lB

Shouldn't we unify them? I guess that at least "Art view" should be unified to "Grid view" ?
TagsNo tags attached.
Fixed in build2191

Relationships

related to 0014132 resolvedpetr Add views for other Art collations 
related to 0015756 newpetr 'Manage views' functionality seems broken / incomplete 
related to 0015584 closedpetr Views: Subviews should persist on a per-view basis 
related to 0015926 assignedjiri Improvements to navigation of Playlist/Folder hierarchy 

Activities

peke

2019-06-03 11:22

developer   ~0053709

Last edited: 2019-06-03 11:24

View 2 revisions

I was experimenting last night regarding that an I wonder if we can split Main Layout so that needed parts/views are enabled as SUBVIEWS to layout?

Ludek

2019-06-03 11:43

developer   ~0053710

This is just about wording, e.g. "Art view" => "Grid view"

Ludek

2019-06-21 17:34

developer   ~0053920

Last edited: 2019-06-21 17:36

View 2 revisions

OK, assigned to me -- to incorporate the suggested changes per the above document.

Ludek

2019-06-21 19:01

developer   ~0053921

Last edited: 2019-06-21 19:27

View 4 revisions

Most of the changes and suggestions (green text in the online document) are implemented in build 2184.

I just don't understand:
Re: [Music > Genres] > Default views: Grid, List (new!)
a) I added both the 'List' and 'List (by Album)' there.
Or is there a reason why 'List (by Album)' shouldn't be included?
b) what is the 'Grid' ? Should it be the 'Genres categories' grid or the 'Genres' grid ??
Or should I understand it that the genre categories should be removed? It was originally implemented as 0014214

rusty

2019-07-26 21:15

administrator   ~0054219

Tested 2188:

To answer your comments:
Re: [Music > Genres] > Default views: Grid, List (new!)
a) I was recommending this for Music > Genres--I didn't spec changes for Music > Genres > GenreName views. I've since updated the document. Note however, that I don't think that a List (by Album) view makes sense for Genres since in most cases, Grouping by Album will conflict with Sorts by Genre since Genres are often track-specific.

b) As to whether the 'Grid' should be based on 'Genres categories' grid or the 'Genres' grid (issue 0014214), ideally it would be user-configurable in the View Options.

I've updated the spreadsheet with missing items/recommended changes in Red. Here's a summary:
c) View name: Genres --> Grid
d) View: Genres > List is missing. Note: this implies implementing a list view for 'folders' so it might not be feasible for 5.0.
e) Music > Albums > AlbumName:
 - Simplified list ---> Album Summary OR Browser
 - Tracklist ---> List
f) Music > Artists > ArtistName:
 - Album Grid --> Artist Summary OR Browser
 - Tracklist --> List
Note: there are many other changes listed e.g. re. missing subviews, missing configuration items in 'Manage views', failed sorting/grouping, etc. but these will be tracked separately.

Ludek

2019-08-08 19:50

developer   ~0054291

Fixed in 2191

rusty

2019-08-09 16:35

administrator   ~0054304

Last edited: 2019-08-09 16:42

View 2 revisions

Tested 2191. The only major remaining issues are:
Music > Albums > AlbumName (List): shouldn't have the info-panel by default (but disabling it shouldn't disable it from the Browser view).
Music > Artists > ArtistName (list): Should not have the info-panel enabled (but disabling it shouldn't disable it from the Browser view).
Music > Artists > ArtistName (list (by album)): Should not have the info-panel enabled (but disabling it shouldn't disable it from the Browser view).

The root of this issue is described at 0015584 - can you discuss with Jiri?

EDIT: I'm closing this bug since the original issues are resolved. I'll copy the comments above to 0015584.

Ludek

2019-09-06 14:10

developer   ~0054523

Last edited: 2019-09-06 14:11

View 2 revisions

Re-opened:

Users are confused by the "Playlist grid" sub-view, see details here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95040
I guess we should rename it to "Sub-playlists" ?

Similarly "Folders" should be renamed to "Sub-folders" in the location tree.

rusty

2019-09-06 18:07

administrator   ~0054527

Re-resolving since I've opened a new bug to track the issue of naming of the Playlist Grid vs Sub-playlist grid at 0015926 (the confusion stems from more than just a language issue).