View Issue Details

IDProjectCategoryView StatusLast Update
0014132MediaMonkey 5Track Browserpublic2019-07-26 21:24
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0014132: Add views for other Art collations
DescriptionCurrently, when the user is browsing, they're unable to choose alternative collations or collations that include track details. i.e. there is an 'Art View' but users can't change what is displayed:
- Artist, the user can't view by Artist + Tracks
- In <Genre>, the user can't display by Composer images, by Albums, etc.
- In <Artist>, the user can't display by Composer (image)
- In all views, the user can't display by Album (image) & Tracks, Composer (image) & tracks, etc.

An updated/simplified set of views appears in the second tab at https://docs.google.com/spreadsheets/d/1UtVNVw6k1k1X1j1elBeL7-G0e3F7SM6ke8MSb5AkdJY/edit#gid=891691505

What this means in general is that the view selector will have more options for what views users can choose, and will be more specific (since Art or Art and Details, doesn't indicate the relevant collation). Moreover, only a limited set of views will be included to begin with (e.g. not optimized for Classical music), but users will be able to create new views based on their specific requirements.

[View icon]v
[icon] Browser
[icon] Tracks
[icon] Album & Tracks *
[icon] Album
[icon] Artists *
Manages views...

Note:
- * indicates new options
- Tracks (simple) no longer appears as an option since it is relegated to customized views such as Browser / Now Playing.
- Manage views... opens a new dialog that allows the user to Create/Edit views so that e.g. user can create a view for Composers & Tracks. The basic functionality of this would be (though this could be significantly expanded in the future:

Grouping: _field_ (grouping to be specced in another bug)
Collate by Image: _field_
 . ( ) Display associated tracks
 . (o) Display metadata: __Field1, Field2_______
TagsNo tags attached.
Fixed in build2083

Relationships

related to 0014170 closedmichal Views / View Selector changes 
has duplicate 0013932 resolvedjiri Ability to sort albums by release date 
related to 0015112 resolvedmichal Missing features in some views 
related to 0015712 closedLudek "Art View", "Browser View", "Grid View" - why different names for the same view 

Activities

Ludek

2017-06-13 12:48

developer   ~0048133

Many of these already resolved/implemented by the new sub-views (0014170)

"Album & Tracks" to be implemented as sub-view

jiri

2017-07-19 14:31

administrator   ~0048390

TBD:
1. A&T view.
2. Support for Column Browser in the Album grid.
3. Configurations & saving of views.

jiri

2017-09-04 11:12

administrator   ~0048655

Last edited: 2017-09-04 12:21

View 2 revisions

1a. Minor issues in the current implementation of the A&T view: Click on an album selects it, but subsequent Ctrl- and Shift-clicks don't select >1 album per usual selection conventions. Not a big issue, can be deferred, but should be fixed sometimes.

1b. Another minor one: Artwork column can't be made smaller than equivalent of 3 rows. I'd be nice to be able to make it even smaller for cases when there are albums with only 1 track. I suppose that the main reason is that the Album column requires 3 rows per album. I guess that we could collapse it to just 1 row when Artwork is too small? E.g. just show Album (Album Artist / Year)? Album is first, since it's the most important part.

jiri

2017-09-07 15:25

administrator   ~0048677

4. Sort by feature:

A. Views without columns (Art view) will only have hardcoded sorting options in the View Selector button. In order to be easily accessible, they should be in the top level of the View Selector menu, not hidden in a lower level, i.e.:

[View Selector]
  [x] Art View
  [ ] List View
  --------------------
           Sort by {section title}
  [x] Album
  [ ] Release date

  Note: It means that this view can't be sorted e.g. by Bitrate (which could be defined as Album average bitrate?) or other such fields. Not sure, whether it's a problem, but probably not for now, we can consider changes later.


B. Views with columns (List View, Album + Tracks) can already be sorted using the column headers. Apart from this feature:
   a. Sort order should be saved with newly created views (feature tbd by Petr), i.e. this way it will be possible to restore favorite views including layouts, columns, grouping, sorting, etc.
   b. Do we need anything else? Originally I was thinking about something like in the case A, i.e. a list of sort orders to be available in the View Selector button, but I'm not sure it's really that useful and whether it doesn't introduce unnecessary complexity - like the necessity to configure favorite sort orders, etc. We probably can defer this or let it be later implemented as an Addon.

petr

2017-10-11 20:07

developer   ~0048939

Items 1-4 fixed. Remaining 1a.

jiri

2017-10-12 10:34

administrator   ~0048946

2. Implemented correctly for the Album grid, but should also be for Artist grid (for consistency).

3a. Manage Views dialog should contain also the build-in views (like List View and Album & Tracks). They should be partially editable (can't be deleted, but e.g. sort order and columns could be configured).

3b. The bottom toolbar seems like an outdated UI design. Up & Down arrows could be replaced by d&d, Edit & Delete buttons could be shown next to the focused item, and Add could be the last item in the listview - similarly to how we implemented in other places.

3c. Add new view action should create the new view based on the current setting (e.g., if I have Column Browser enabled, it should be enabled in the new view).

3d. We need to find a way, how to update settings for the current view. E.g. if I create a view 'Test', without a Column Browser (CB), but then in MM5 main window UI enable the CB - there's no straightforward way how to keep the CB enabled whenever I select the Test view. It seems that the easiest way is to always save the changes, which is how currently the build-in views work - when I enable CB in 'List view', it's always shown there, until I manually hide it.

3e. Changes would better be updated live - if I enable CB in the currently active view, it should be shown in the main window right away. Note that currently it isn't shown even after the configuration dialog is closed.

4. Doesn't seem to work when the CB is enabled (Albums view)

petr

2017-10-16 14:43

developer   ~0048972

Last edited: 2017-10-28 19:12

View 7 revisions

Fixed 2, 3a, 3b, 3c, 3d, 3e, 4

jiri

2017-10-30 08:12

administrator   ~0049077

1. A&T view - when shown (e.g. switch from List View), the view often isn't correct: Headers don't correspond to the Columns below (the first 2 columns are often wrong), artwork overlaps (related to column widths), a user also mentioned that the horizontal scrollbar isn't shown until the view is resized.

5. Per IM discussion, sub-views visibility shouldn't be configurable per-view, since it's currently being shared by all views (that can show given sub-view).

6. Art view configuration should contain 'Sort by: ______ [v] dropdown (currently there's a cut-off listbox).

7. Sort By section of the Art view in the View Selector dropdown often doesn't have either checkbox ticked (I suppose that there's always one of the two orderings active).

8. Stability fixes per IM discussion.

petr

2017-10-30 10:41

developer   ~0049079

Last edited: 2017-10-31 08:37

View 2 revisions

Items 1, 5, 6, 7 fixed

jiri

2017-11-06 16:28

administrator   ~0049115

1a. Fixed.

petr

2017-11-16 21:44

developer   ~0049195

Fixed

peke

2017-11-23 00:48

developer   ~0049229

Verified 2083