View Issue Details

IDProjectCategoryView StatusLast Update
0016379MediaMonkey 5Track Browserpublic2020-12-23 02:11
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016379: Creating custom views causes View corruption / other issues
DescriptionCreating custom views causes:
1) The view switcher to get stuck on certain views
2) Other views to get corrupted
3) Crash

e.g.
1 Switch to Music > Genres > Rock
2 Click 'Manage Views...' and add new 'Test' view of Type: 'Grid (by album)' , with column filter and status bar enabled.
3 Click the View Switcher several times
--> it gets stuck on the 'Grid (by album)' view (i.e. it stops advancing beyond that view) !
4 Click 'Manage views...' and delete the 'Test' view
5 Click the view switcher several times
--> It works correctly now!
6 Click 'Manage views...' and add new 'Test 2' view of Type: List with Column Filter and Status bar enabled.
7 Click the View Switcher several times
--> It gets stuck as before
8 Use the view switcher to manually select the Browser view
--> It appears blank!
9 Click 'Manage views' and attempt to delete the 'Test 2' view
--> MM5 crashes - log A04C5335 !
10 Restart MM, Manage views, and delete the 'Test 2' view
--> Success, but switching to the browser view still shows a blank view!
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95611
TagsNo tags attached.
Fixed in build2262

Relationships

related to 0016423 closedpetr Displaying folders recursively causes Folder view element to stop working 

Activities

petr

2020-02-21 14:00

developer   ~0056785

Fixed

peke

2020-03-01 03:11

developer   ~0056953

Verified 2229

Unable to reproduce

peke

2020-03-01 03:32

developer   ~0056958

Verified 2229

Unable to replicate.

rusty

2020-03-02 20:02

administrator   ~0057007

I'm still observing corruption issues in 2229. e.g.
Music > Location > Path contains Browser, List, List (by Album), Grid (by album) views
1 In Music > Genres > Rock, create and delete and then recreate a custom View as originally described in this bug
2 Switch to Music > Location > Path > all
3 Disable 'all' and then click the View Switcher
--> the following Views appear in order: Browser, Browser, Grid (by album), List, List, List (by Album), List (by Album), Grid (by album), Test 10
4 Click 'Manage Views...'
--> Browser, List, List (by Album), Grid (by album), Test 10 appears
5 Click the first Browser view
--> Crashlog A04CDC9A

It seems that somehow, creating & deleting Custom views and/or editing views in other nodes causes duplicate/corrupted nodes to appear.

rusty

2020-03-04 18:53

administrator   ~0057047

This has manifested in other crashes as well. e.g.
1 In playlists switch between views
--> no problems
2 Switch to Music > Locations views and switch between various views (incl. the custom view)
--> Corrupted list of views appears as described above
3 Switch to Playlists node
--> List of playlist views is now corrupted
4 Switch between playlist views
--> crash A04C2E95 OR A04CC723

petr

2020-03-05 13:59

developer   ~0057051

Fixed

peke

2020-03-07 01:20

developer   ~0057100

Verified 2230

Tested number of times using various views and steps from 0016379:0057047 / 0016379:0057007

rusty

2020-03-08 01:42

administrator   ~0057105

The usecase at 0016379:0057007 is still buggy, but I think it's probably a different issue so I've opened a new bug at 0016423.

rusty

2020-03-09 22:22

administrator   ~0057133

2)b) View settings are still getting applied to the wrong views. e.g.
1 In Music > All tracks [List] create a 'Test' view for 'List' views
2 Switch to Music [Browser] and click 'Manage views'
3 Double click the 'Test' view and enable/disable Artists
--> The Browser view is modified!!
This bug occurs because the View Type doesn't properly persist (i.e. upon double-clicking the 'Test' view at Step 3, the View Type is 'Browser' instead of 'List')

2a) I was also able to trigger the bug in which multiple duplicate views appear, but can't replicate it yet--perhaps this is somehow caused by 2b?

petr

2020-03-10 12:49

developer   ~0057134

Fixed

rusty

2020-03-10 16:28

administrator   ~0057138

Verified 2b) in 2231.

rusty

2020-05-14 21:42

administrator   ~0058011

Last edited: 2020-05-19 01:09

View 3 revisions

3) If the user adds custom views based on existing views, and then edits the custom views, then original View Types get corrupted as follows:
a) the Column Filter gets enabled / Status gets disabled
b) the column filter cannot be disabled by unchecking it (the user must instead go into the manage views config to do so)

e.g.
i) In Music > All tracks, Add custom List view and change the column/sort settings settings 2x --> the original List view has the Column Filter enabled! And it can't be disabled by unchecking it via the combobox!

ii) In Music > All tracks, Add custom Grid (by Album) view and change the sort settings 2x --> the original Grid (by album) view has the Column Filter enabled and the original List view has the Status bar disabled! Neither Column filter can be disabled via the combobox!

I'm sorry for the length of this video, however, it takes quite a few steps to replicate
https://www.screencast.com/t/626t5FiHUjBY

Test note: Issue 18) at 0015756 should also be verified after this is fixed

petr

2020-05-18 19:34

developer   ~0058089

Fixed

rusty

2020-05-19 01:29

administrator   ~0058101

Tested 2250 and I'm still able to replicate 3a/b). Moreover, on some occasions changing the Column Filter / Status settings for the custom filter after this bug has occurred triggers a crash. e.g.
1 Create a filter based on List
2 In Music > All tracks [Custom List Filter], click 'Manage Views'
3 Add a column / remove a column / change column order
4 Enabled Column Filter / Disable Status and commit the changes
5 Switch to Music > All tracks [List]
--> Column Filter is enabled and Status is disabled!!
6 Switch back to Music > All tracks [Custom List Filter], click 'Manage Views'
7 Disable Column Filter / Enable Status and commit the changes
--> Crash A04CAADD

https://www.screencast.com/t/LGpW7kOv2

rusty

2020-05-19 01:29

administrator  

bug16379-build2250.7z (92,546 bytes)

petr

2020-05-27 15:37

developer   ~0058304

Fixed

rusty

2020-05-28 17:15

administrator   ~0058364

Similar issue in Location > Path [List] view:
1 Create custom List view
2 In Manage Views: Disable the list (folders) and enable grid (folders)
--> Upon clicking ok OR upon clicking within the view, the folders disappear!

https://www.screencast.com/t/bxZ7RyddQ7C

petr

2020-06-09 15:00

developer   ~0058476

Fixed

rusty

2020-07-07 20:38

administrator   ~0058802

I'm still seeing corruption in the Manage Views list of views in the Music Locations node:
Multiple custom views appear in duplicate (including a view that appears to have been previously deleted. I don't know exactly how the situation arose, but presumably it involved deleting a view (prior to installation of build 2259).

https://www.screencast.com/t/8rRHPNIq

Debug log posted to ftp

petr

2020-07-08 11:17

developer   ~0058810

I've found small issue which can cause this issue.

rusty

2020-07-14 20:35

administrator   ~0058969

This still occurs in my environment. Would the database allow you to replicate the issue?

petr

2020-07-27 17:33

developer   ~0059148

Fixed

peke

2020-12-23 02:11

developer   ~0061054

Verified 2291

I am unable to replicate issue as described at 0016379:0058802