View Issue Details

IDProjectCategoryView StatusLast Update
0016991MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-01-08 00:21
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016991: MediaMonkey steals focus
DescriptionWhen launching Properties > Artwork's Lookup Image and then cancelling the lookup dialog, if you immediately switch to another application, the focus switching back to MediaMonkey. This continues until user clicks on Properties dialog.
TagsNo tags attached.
Fixed in build2292

Relationships

related to 0016868 closedlowlander Windows not shown on top 
related to 0016130 closedpetr Plackback: Spacebar causes focus to switch to MediaMonkey on track transitions 
related to 0016866 closedLudek MediaMonkey takes keyboard input while not the active window 

Activities

petr

2020-11-10 09:12

developer   ~0060116

Unable to reproduce in current sources. Please retest.

lowlander

2020-11-16 21:07

developer   ~0060263

Last edited: 2020-11-16 21:18

View 2 revisions

This is still happening on 2274 (see end of The Very Best Of Grateful Dead log where this occurred for the The Very Best Of Grateful Dead Album).

Artwork is pasted from Firefox and after this MediaMonkey can take focus 5+ times. It partially seems to do it more and more the more Albums tagged, but it also seems somewhat random.

The question is, why does MediaMonkey need to get focus in the first place. Maybe once when Add Cover window is closed and Properties window becomes top Window, but MM seems to keep asking focus as Artwork is loading.

lowlander

2020-11-18 18:24

developer   ~0060279

Another log: 2274 Rokia Traoré - Né So.zip

MediaMonkey kept taking focus from Firefox till I started screen recording.

lowlander

2020-11-18 18:46

developer   ~0060282

It seems that if you Add Artwork and don't click the Properties dialog after adding that this issue occurs.

1) Select an Artwork in Firefox (right click > Copy Image)
2) Right click in Properties > Artwork for an Album and select Paste
3) Set Image Type (may not be relevant)
4) Hit OK
5) immediately make Firefox active window

This cause MediaMonkey to become active, making Firefox active again will often have MediaMonkey take focus again, sometimes repeatable in infinity.
However if in step 5 you clicked in the Properties dialog, then made Firefox active window the problem doesn't seem to occur.

drakinite

2020-12-01 16:32

developer   ~0060487

I believe this occurs whenever there are multiple dialog windows open at once (Specifically, when one dialog window opens another; and then you close the second one).

1) in Tools > Addons, open the options panel of AutoDJ
2) Close the options panel (via OK, Close, or the X button)
3) Switch to another program

This causes MM to take focus repeatedly, until you close the first dialog window.

lowlander

2020-12-22 23:02

developer   ~0061052

Last edited: 2020-12-22 23:09

View 2 revisions

Yes, that likely is it. I see the same in Options (screencast & log added) after a second dialog was launched from Options. It seems that this can cause MediaMonkey to take key input when user doesn't expect this.

rusty

2020-12-23 01:05

administrator   ~0061053

Raised the priority on this since it can cause input to be applied to MM inadvertently.

Ludek

2020-12-28 20:52

developer   ~0061110

Last edited: 2020-12-28 21:02

View 3 revisions

Barry sent me a video and debug log showing MM5 and Chrome browser sitting side-by-side, where MM5 is reacting to keystrokes in the Chrome browser window.
Reported as item 5 here: https://www.mediamonkey.com/forum/viewtopic.php?p=476103#p476103

Uploaded the files to FTP

petr

2020-12-30 18:16

developer   ~0061127

Fixed Barrys issue with MM5 reacting to keystrokes even when not focused.

petr

2020-12-30 21:29

developer   ~0061131

Fixed

peke

2021-01-08 00:21

developer   ~0061210

Verified 2292

Unable to replicate