View Issue Details

IDProjectCategoryView StatusLast Update
0016866MediaMonkey 5Main Panelpublic2021-01-21 01:47
Reporterlowlander Assigned To 
PriorityurgentSeveritycrashReproducibilityrandom
Status closedResolutionduplicate 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0016866: MediaMonkey takes keyboard input while not the active window
DescriptionI've not noticed this before and it happened after MediaMonkey had been open a while. While working in Firefox, MediaMonkey seemed to keep reacting to keyboard input. In video it shows MediaMonkey moving around the tree while not the active window.
TagsNo tags attached.
Fixed in build2265

Relationships

duplicate of 0016130 closedpetr Plackback: Spacebar causes focus to switch to MediaMonkey on track transitions 
related to 0016787 closedLudek Media Tree Node selection changes, possibly due to scanning 
related to 0016991 closedpetr MediaMonkey steals focus 
related to 0017414 closedpetr MediaMonkey context menus steal focus 
related to 0017422 closedpetr MM steals focus soon after track transitions (regression 2296?) 

Activities

lowlander

2020-08-03 16:42

developer   ~0059215

Video shows 0:55 (and end of log) after using Backspace that Tree starts moving around: https://1drv.ms/u/s!AjRcJhPd0elwgfhBPn3xoPpvk3PfPw?e=TCOQaF

Ludek

2020-08-12 12:16

developer   ~0059351

Last edited: 2020-08-12 12:27

View 4 revisions

It is curious, but on the video it is really clearly seen that MM takes the keaboard input even when the window is not foreground.
It expands/collapses tree nodes when using right/left arrows etc.

We are unable to replicate (tested by Ludek & Michal), but to me it looks like a bug in the Chromium engine (that could be potentionally fixed in newer version) as it reacts on 'keydown' events in DOM.
Or maybe the FireFox uses a same type of events and somehow redirects it to MM window?

@LowLander: Have you found a consistent steps to replicate so that we could test whether Chromium update would fix this or find a clue?

lowlander

2020-08-12 16:26

developer   ~0059352

No, this is a rare thing to happen and don't know how to force this (reproduce) to happen.

rusty

2020-08-12 21:44

administrator   ~0059357

I've been able to replicate a variant of this issue documented with log at 0016130. The key in that case was:
1) MM must be obscured by another app
2) MM must be playing music
3) User must type the SPACEBAR in the app that is obscuring MM at the time that playback transitions from one track to another.

Ludek

2020-08-24 11:54

developer   ~0059460

Seeing that 0016130 was fixed in 2265, so I suppose that this issue is also resolved in 2265.

Please test 2265 once is available

peke

2020-08-28 11:50

developer   ~0059514

Verified 2265

Unable to replicate, background playback or properties edit do not take keyboard actions.

Test note: OPen properties and click on Comment to edit -> Switch to other apps like firefox, Notepad++, ... and type. No characters are added to MM in background