View Issue Details

IDProjectCategoryView StatusLast Update
0016988MediaMonkey 5Now Playingpublic2020-12-28 18:25
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016988: Tracklist moves and touch menus de-activate on track transition
DescriptionIf the user plays a bunch of tracks, then each time a track advances to play the next track:
1) The tracklist in Music > All tracks repositions to the position of the last selected track
2) The contextual menu in Touch mode disappears

e.g.
1) Tracklist moves:
1 play a bunch of tracks starting with TrackA
2 switch to Music > All tracks [List]
3 scroll partway down the list and select e.g. Track50
4 scroll further down the list e.g. to Track 200
5 when TrackA finishes and TrackB starts playing
--> the tracklist moves by itself back to Track50!

2) Touch mode context menu is hidden:
0 switch to Touch mode
1 play a bunch of tracks starting with TrackA
2 switch to Music > All tracks [List]
3 select track50
--> Contextual menu appears so that the user can e.g. send it to a Playlist
4 select track53, and Track55
--> Contextual menu continues to display as expected
5 when TrackA finishes and TrackB starts playing
--> the Contextual menu disappears!
TagsNo tags attached.
Fixed in build2270

Relationships

related to 0013437 closedpetr Browser view: position changes / scrolls by itself [on track edit] 
related to 0015917 closedLudek Tracklist/view moves by itself (sometimes continuously) [on search/filter] 
related to 0015475 closedpetr Dynamic sorting issues 
related to 0016961 closedpetr Selected file problem on sort in Playlists 
related to 0017007 closedmichal Calling Properties on artist node can cause crash 0x998CC5A4 - regression 
related to 0017299 newpetr Focused track gets out of view after resort 

Activities

Ludek

2020-10-13 09:00

developer   ~0059842

Last edited: 2020-10-13 09:03

View 3 revisions

This is a regression caused by Petr's SVN revision 36251 -- fix of 0015475
i.e. the new code in handleBeforeSort / handleSortChanged is causing this: https://www.dropbox.com/s/9al6xkl9x58gqr1/screenshot%202020-10-13%2010.56.25.png?dl=0

Track transition raises track property change which causes re-sorting of the list in [Music > All tracks] which causes the scroll to the focused item (in handleSortChanged )

petr

2020-10-15 09:42

developer   ~0059867

Fixed