View Issue Details

IDProjectCategoryView StatusLast Update
0017299MediaMonkey 5Main Panelpublic2021-04-14 23:48
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017299: Focused track gets out of view after resort (regression)
DescriptionOpen Music - All Tracks view to see the list of all songs.
Mark a song somewhere in the list.
Change the sort order, e.g. by "Album".
The 1st song of this sort order remains on top, but the song you have marked before is now out of view (although still marked).
In MM4 the window scrolls automatically so that the marked song remains in view

Reported at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98009
TagsNo tags attached.
Fixed in build2334

Relationships

related to 0017009 closedpetr Track Browser: Selection Using keyboard do not scroll View 
related to 0016961 closedpetr Selected file problem on sort in Playlists 
related to 0015475 closedpetr Dynamic sorting issues 
related to 0016988 resolvedpetr Tracklist moves and touch menus de-activate on track transition 
has duplicate 0017752 closedLudek Currently focused track gets out of view after changing sort (regression) 

Activities

Ludek

2020-12-28 18:24

developer   ~0061105

This seems a regression to me?

Looks like this has been already fixed as 0016961 in 2270 and is broken again?

Ludek

2021-04-12 20:29

developer   ~0062800

Re-repored as item 7) here:
https://www.mediamonkey.com/forum/viewtopic.php?p=480256#p480256
https://chat.tbp.land/t/mediamonkey-5-suggestions/4679#3-kbdrating-upkbd-and-kbdrating-downkbd-hotkeys-should-be-switched-by-default

Changing target back to 5.0 as it looks like regression. i.e. already fixed as 0016961 and in 2270+ is broken again?
Also MM4 correctly preserves the last focused item in the view.

Ludek

2021-04-13 08:50

developer   ~0062805

Last edited: 2021-04-13 09:00

View 3 revisions

Fixed in 5.0.1.2400 and merged to 5.0.0.2334

peke

2021-04-14 23:48

developer   ~0062821

Verified 2334

Unable to replicate in 2334, close after 2400 is verified.