View Issue Details

IDProjectCategoryView StatusLast Update
0013437MediaMonkey 5Track Browserpublic2020-10-08 20:49
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0013437: Browser view: position changes / scrolls by itself [on track edit]
DescriptionWhen the user is in the Browser view, the view sometimes scrolls by itself unexpectedly. This occurs as follows:

1) If the user does an on-screen edit
1 Right-click on a track in the list
2 Click another track in the list
--> list scrolls unexpectedly

2) Click 'Show all x tracks'
--> list scrolls to the top
note: I believe that we might have specced this, but in practice it's a bit unexpected

See demo of both of the above at:
http://screencast.com/t/WxwEyXbETcl
TagsNo tags attached.
Fixed in build2263

Relationships

related to 0015475 resolvedpetr Dynamic sorting issues 
related to 0015917 closedLudek Tracklist/view moves by itself (sometimes continuously) [on search/filter] 
related to 0016433 closedmichal Removing songs in the Playlist edit panel auto-scrolls up 
related to 0016602 closedmichal Scrolling is broken sometimes 
related to 0016915 closedpetr Issue with 2 instances of same song in a playlist 
related to 0016988 resolvedpetr Tracklist moves and touch menus de-activate on track transition 

Activities

michal

2016-08-02 17:16

developer   ~0045298

2) autoscrolling is implemented based on issue #13407 point 1) (comment). It is improved in the current build, scrolling is animated and scrolled only as much as needed, not always to the top.

michal

2016-08-10 08:54

developer   ~0045376

Fixed in build 2029. It displays loading message during loading of all tracks and switch to new tracklist after it is loaded, so it does not lose scroll position and no need to scroll automatically.

rusty

2016-09-01 15:57

administrator   ~0045537

I found another usecase that triggers the bug in 2031:
3) Click on the ratings indicator (for a track that has a rating) --> screen shifts position. This seems to occur in a variety of views.

rusty

2016-09-08 20:38

administrator   ~0045622

4) In Music > Artist > Death Cab for Cutie, display all tracks, then
1 click a field to activate in-place editing
2 click outside of the field
-->tracks scroll

rusty

2016-10-05 21:57

administrator   ~0045827

5) Another usecase:
In Music > Artist > Death Cab for Cutie, display all tracks, then
1 click a field to activate in-place editing
2 press TAB to edit the next editable field
-->tracks scroll

michal

2016-10-23 12:16

developer   ~0045998

3)4)5) Fixed in build 2038.

peke

2019-11-22 23:07

developer   ~0055461

Verified 2215

No more unexpected scrolling

rusty

2020-03-11 18:53

administrator   ~0057152

Last edited: 2020-03-11 19:03

View 2 revisions

I've observed this issue again in build 2231. It occurs in Music > Album Artists > Various [Browser:infopanel,tracks] as images are looked up. i.e.
1 Navigate to Music > Album Artists > Various [Browser:infopanel,tracks]
--> Images for albums start getting looked up
2 Scroll down
--> MM5 scrolls back to the top of the view!

https://www.screencast.com/t/46golsGO

rusty

2020-03-11 19:04

administrator  

13437-build2231.7z (101,022 bytes)

michal

2020-03-14 18:11

developer   ~0057194

I cannot reproduce. But I fixed some possible causes related to 0016433, please retest.

rusty

2020-03-20 19:23

administrator   ~0057250

Unable to replicate in 2233.

rusty

2020-05-11 21:59

administrator   ~0057953

I've found another instance of this bug in 2247:
1 Navigate to Music > Location > DirectoryA [Browser] (containing folders and tracks)
2 Scroll down a small bit (the bug doesn't happen if you don't scroll down)
3 Select child DirectoryA-1
4 Select child DirectoryA-1-i (the bug doesn't happen if the user doesn't navigate down a second level in the hierarchy)
5 Press BACK 2x
--> Position changes (original position is lost)!

It may be easier to understand via a video:
https://www.screencast.com/t/cOvcTrX4w

Leaving as Urgent since it's quite annoying.

michal

2020-05-21 16:41

developer   ~0058160

Could you retest it in the last version? There were some changes there. Me and Petr are not able to reproduce this at all, even with your DB and the same folders.

peke

2020-07-10 00:41

developer   ~0058846

Verified 2259

Unable to reproduce.

peke

2020-08-08 15:45

developer   ~0059289

Re verified 2262

Closing unable to reproduce and no regressions

rusty

2020-08-11 00:42

administrator   ~0059316

6) I retested 2262 and am able to replicate additional variants of this issue that occur whenever a folder/container is renamed. For example (and there are likely many other cases):
a) In Music > Genres > GenreName [Browser] select an artist, rename it, and press ENTER
--> view scrolls to the bottom of the list of Artists (even though the position of the artist is unchanged)
b) In Home > Locations > Path [List: List (folders)] , select a directory, rename it, and press ENTER
--> view scrolls to the bottom of the list of directories (even though the position of the directory is unchanged)

See: https://www.screencast.com/t/4DMyg1pVR

michal

2020-08-11 11:25

developer   ~0059324

6) is regression caused by fix of 0015475

petr

2020-08-11 12:38

developer   ~0059326

Fixed

peke

2020-08-14 23:05

developer   ~0059414

Verified 2263/2264

Unable to replicate any more issues based on steps from 0013437:0059316 in both 2263 and 2264.

@Rusty Can you please close after second confirmation?

peke

2020-09-18 23:26

developer   ~0059608

Re verified 2267

Still unable to replicate. Closing