View Issue Details

IDProjectCategoryView StatusLast Update
0009216MediaMonkey (current)Synchronizationpublic2016-04-13 10:10
Reporterlowlander 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0.3 
Target Version4.0.4Fixed in Version4.0.5 
Summary0009216: User should be able to check what type of playlist synced to device
Description0009066 fixed playlist issues for some, but seems to have broken it for others. Instead of MediaMonkey choosing what playlist type to sync the user should be able to select what type of playlist should be send to the device.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=65031
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=65122
LWM-632475
XUL-766861
QCX-680508
RWB-705-84927
TagsNo tags attached.
Fixed in build1480

Relationships

related to 0009066 closedjiri M3U playlists should be preferred over MTP 
related to 0013182 closedLudek Sync: Windows 10 Phones do not sync Playlists 
related to 0010779 closedLudek Add support for generation other playlist formats 
related to 0013228 assignedLudek Playlists fail to sync to Sony Walkman (NWZ-E465) 
related to 0009821 closedLudek Samsung Galaxy Note: Tracks show unknown Album Artist / Album (failed device detection) 
related to 0009962 closedLudek Setting Support Formats Playlist type fails 

Activities

jiri

2012-03-29 16:35

administrator   ~0030807

Last edited: 2012-03-31 22:50

View 2 revisions

Fixed in build 1480.

MM now respects playlist settings in Supported formats per device. I.e., if M3U is configured, it's created during synchronization, if PLA is, the abstract (MTP specific) playlist is created. No other format is (or ever was) supported.

MM also tries to make a good initial guess about which playlist format to choose, i.e. M3U for Androids, PLA for other MTP device (even if they report both types as supported).

stephen_platt

2012-04-23 18:08

developer   ~0030879

verified in the forum, 1481

lowlander

2016-03-21 20:37

developer   ~0044303

This still seems to be an issue: http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=65973

jiri

2016-03-21 21:17

administrator   ~0044304

We'd need a log to see what's going on there. I wouldn't expect m3u being synced when pla is selected in MM.

Ludek

2016-03-23 08:38

developer   ~0044313

Based on the user's log here: http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=65973&sid=5306a07225a07be21036c857eaaf73c7&start=15#p421514

The device isn't MTP connected, but UMS connected with drive letter H:\ , that explains why PLA abstract playlist cannot be synced. I wonder how Windows Media Player could sync the PLA. Asking more in the forum...

Ludek

2016-04-13 10:09

developer   ~0044438

The Sony's issue is now clarified, tracked as 0013228