View Issue Details

IDProjectCategoryView StatusLast Update
0009962MediaMonkey 4Synchronizationpublic2012-12-19 20:51
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.0.7 
Fixed in Version4.1 
Summary0009962: Setting Support Formats Playlist type fails
DescriptionUsers are reporting that setting M3U as supported format on their devices still syncs PLA instead of M3U.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?p=351247#p351247
TagsNo tags attached.
Fixed in build1606

Relationships

related to 0009821 closedLudek Samsung Galaxy Note: Tracks show unknown Album Artist / Album (failed device detection) 
related to 0009961 closedLudek PLA playlist being sycned to Samsung Galaxy S2 instead of M3U 
related to 0009518 closedLudek Sync with Galaxy S3 can fail due to PLA playlists 
related to 0009216 closedLudek User should be able to check what type of playlist synced to device 
related to 0009066 closedjiri M3U playlists should be preferred over MTP 

Activities

Ludek

2012-11-12 22:49

developer   ~0033114

Based on the code revision it looks that if both PLA and M3U are configured, then PLA is preffered.

I guess that leaving there just M3U solves this problem?

lowlander

2012-11-12 23:15

developer   ~0033115

Do you mean as Supported Format (under Auto-Conversion rules in the Device Profile)? None are listed by default for Playlists so it would seem users only have M3U listed as Supported Format after they add it. Although PLA is what MM is sending by default to the users device, it isn't listed as Supported Format.

Ludek

2012-11-13 12:04

developer   ~0033123

Yes I mean Device->Options->Auto-conversion->Supported formats

If I have both PLA, M3U there, then PLA are synced, but if I remove PLA then M3U is preffered, isn't this the same in your case?

Nevertheless waiting for confirmation here:
http://www.mediamonkey.com/forum/viewtopic.php?p=351247#p351351

lowlander

2012-11-13 16:20

developer   ~0033128

No, I've never seen Playlists listed as Supported Formats (ie. default setting set by MM like set for Audio and Video). This means as forum post replied that only M3U is listed after the user adds it. I just checked for Galaxy Note and Sansa Clip+ and neither has any playlist type listed as Support Format.

Ludek

2012-11-14 14:18

developer  

GT-I9199 - card.mmdc (3,468 bytes)

Ludek

2012-11-14 14:20

developer   ~0033138

It really doesn't work for the user. Attached is his device profile (GT-I9199 - card.mmdc), if I import the profile then M3U is listed between supported formats, but clicking [Set formats] button doesn't list the M3U. So there seems to be a bug in the format handling.

Ludek

2012-11-14 15:57

developer   ~0033143

Hmm, further testing shown that the profile behaves different way on 4.0.7 and 4.1 (I previously tested 4.1), there was most probably a change in structure of auto-conversion data that causes the issue.

Ludek

2012-11-14 16:21

developer   ~0033144

It seems that it is caused by revision 14864 that hasn't been merged into 4.0 in course of fixing 0009216

Ludek

2012-11-14 16:45

developer   ~0033145

Last edited: 2012-11-14 16:48

So the migging SVN revision 14864 caused that
On first connect, 4.0.7 adds the M3U to SuppVFormatsList and it works, but M3U is not shown, until user adds it manually, but it is added to SuppFormatsList (old structure). The result is that M3U is shown, but doesn't work.

i.e. it is fixed in 4.1

If we want to merge it into 4.0.8 then the revision 14864 needs to be merged.

lowlander

2012-12-19 20:51

developer   ~0034010

MediaMonkey no correctly assigns Playlist Supported Type to devices.