View Issue Details

IDProjectCategoryView StatusLast Update
0010779MediaMonkey 4Synchronizationpublic2016-03-23 08:28
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version4.1Fixed in Version4.1 
Summary0010779: Add support for generation other playlist formats
DescriptionCurrently we can sync various playlist types virtually via MTP (PLS, PLA, ASX, ...) if the device supports it.

But for USB MS devices and simple USB memory sticks (like SD card) we can generate only M3U.

This should be enhanced to support also other formats (like PLS, ASX, XSPF)
Additional Informationhttp://gonze.com/playlists/playlist-format-survey.html
TagsNo tags attached.
Fixed in build1637

Relationships

related to 0010746 closedrusty Playlists: Ability to force output Playlist format 
related to 0011634 closedLudek Playlist supported format setup 
related to 0009216 closedLudek User should be able to check what type of playlist synced to device 

Activities

Ludek

2013-04-26 14:45

developer   ~0035794

Added PLS and XSPF file generation in build 1635.


I am not sure whether we need to add others (ASX, WAX, WPL, ...) because these are formats specific to particular app or file format and are not widely used. So I see this as low priority. We can re-open this and add them once we find that they could be useful.

peke

2013-05-05 22:08

developer   ~0035918

I would suggest 2 Small tweaks:

1. Only supported playlists should be shown in dropdown eg. M3U, PLS, XSPF even others are selected as supported

2. If selected formats MMW do not export I think maybe all should be disabled unless device is using MMA?

peke

2013-05-06 14:33

developer   ~0035932

Last edited: 2013-05-06 14:46

To make things more clear
1. MMW support M3U, PLS and XSPF even if Device support ASX it should not be listed, it will be not created as MMW do not export them. So dropdown should show which are of those three is selected in supported formats and ignore others.

2. if none of M3U, PLS and XSPF is selected as supported all of playlist options should be dissabled as MMW will not handle them unless sync MMW -> MMA/MM8 is made

rusty

2013-05-06 19:52

administrator   ~0035937

1. Sure--it doesn't really make sense to offer the ability to export to a playlist format that's unsupported by MMW, even if it is supported by the device. This should be fixed for MM 4.1.

2. I see what you mean--though I don't think it's really worth fixing. If no playlist format is supported, MMW currently lists m3u as the default. So it'll work even if the user accidentally disables all supported formats. We could change this, but I'm not sure if it's worth any effort.

Ludek

2013-05-07 09:55

developer   ~0035959

Last edited: 2013-05-07 10:32

Re: 1)
Currently we support ASX sync virtually via MTP (if device supports it). So either your device supports ASX over MTP or you configured a device profile offline (when the device was not connected)? These are the cases when ASX could get into the combo box.

I should problably adjust it and the playlists should be created both virtually and physically via MTP for consistency with MS USB.

Ludek

2013-05-07 11:36

developer   ~0035961

Added generation of ASX/WAX in build 1637.

+ playlist files are copied also physically via MTP in 1637.

peke

2013-06-05 22:34

developer   ~0036341

Verified 1641