View Issue Details

IDProjectCategoryView StatusLast Update
0017632MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-03-09 02:43
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017632: Linked album art is always saved as folder.jpg
DescriptionIf the user attempts to save Album Art via the 'Add cover' > Save image to file folder:
- the image filename displayed in the 'Add cover' dialog doesn't match the format configured in Options > Tags > Image filename
- the image filename that is added doesn't match what was shown in the 'Add cover' dialog

It seems that these bugs occur because:
a) MM (when in the Add cover dialog) isn't aware of the number of linked images that already exist (and therefore sometimes shows thm when it should be .jpg, or vice-versa)
b) The Add cover dialog doesn't apply the mask from Options > Tags > Image filename
Additional InformationReported at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98562
TagsNo tags attached.
Fixed in build2320

Relationships

related to 0017630 closedmichal Properties: Editing linked artwork causes failed artwork updates (linked and tagged) 
related to 0017639 newrusty Add cover: artwork format is always saved as thm in cases where artwork is in the directory but not in MM 
related to 0017640 newmichal Deleting and then adding new artwork cause the new arwork to always be added as .thm 

Activities

rusty

2021-03-05 13:55

administrator   ~0062258

Last edited: 2021-03-08 17:56

View 3 revisions

So it turns out that the description I provided is incorrect. I'd tested with tracks that were from multiple albums saved to a single folder, and in that case, thm is automatically applied.

Michal clarified that:
1) The user-reported issue is slightly different: because previous JPG is deleted after pressing OK, he cannot replace this file in one Properties editing session.

2) During a single Properties > Artwork editing session it shows folder.jpg for all newly added artworks, even though only the first should use it. i.e.
1 edit tracks from one album in one directory (that have no artwork)
-->folder.jpg was offered for the first image, but then also for the second newly added image and are saved as albumart.jpg, albumart_2.jpg, ...! Images subsequent to the first one should show and save with THM.

michal

2021-03-08 15:28

developer   ~0062283

2) fixed in build 2320

rusty

2021-03-08 19:28

administrator   ~0062288

Remaining issues are tracked at 0017639, 0017640

rusty

2021-03-09 02:43

administrator   ~0062300

Verified 2320.