View Issue Details

IDProjectCategoryView StatusLast Update
0017630MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-03-12 22:29
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017630: Properties: Editing linked artwork causes failed artwork updates (linked and tagged)
DescriptionIf the user adds/edits linked album art for a track in an album that is in a directory with other tracks from their own albums, then it causes:
- album art edits for linked artowork to stop working (edits/deletions often fail)
- album art additions for tagged artwork to appear as 'unsaved images' even after they should have been saved (and because they don't have a 'Save' button, they cannot subsequently be saved).

To replicate:
1 Navigate to a directory with 10 tracks from 10 different albums
2 Select one tracks from an album
3 Right-click > Properties > Artwork > Lookup image, select an image and press OK, and 'Save to folder' and click OK
4 Repeat step 3 a second time with a second image
5 Check 'Apply to all selected tracks / all tracks on the album/series' and Click OK in the Properties dialog to commit the changes
6 Right-click > Properties > Artwork
--> Chances are that the artwork doesn't appear as expected (if it does try deleting an image / adding an image until the changes don't appear as expected)!
7 Navigate to a directory with 10 tracks from a single album and select all the tracks
8 Right-click > Properties > Artwork > Lookup image, select an image and press OK, and 'Save to tag and folder if not possible' and click OK
9 Right-click > Properties > Artwork
--> Image appears as 'Unsaved image' and there's no way to save it as only a 'Delete' icon appears! (artwork labels / buttons should appear as described at 0017633)
Additional Informationrelated to: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98562

The failed artwork edits when saved to a folder is probably related to 0017632
TagsNo tags attached.
Fixed in build2324

Relationships

related to 0016480 closedmichal Album Art: image handling issues for 'unsaved images' 
related to 0017632 closedmichal Linked album art is always saved as folder.jpg 
related to 0017633 resolvedmichal 'Unsaved image' label / format in Add cover dialog should be clearer/more informative 

Activities

michal

2021-03-06 17:41

developer   ~0062275

This seems to be already fixed in 2320 by other related fixes, please retest.

rusty

2021-03-09 03:57

administrator   ~0062301

This is occurring similarly to the previous description i.e.

issue 1: tagging of a single track from a single album that is in a folder with multiple other single tracks from single albums, with multiple linked images
--> failure of one of the images to save correctly

issue 2: once issue 1 occurs, artwork fails to save all the time, even when attempting to tag artwork (the original issue of the missing 'Save' button didn't occur though--tags just failed to save)

https://www.screencast.com/t/0qXezOpcJ

michal

2021-03-09 13:55

developer   ~0062306

Fixed in build 2321.

rusty

2021-03-10 03:08

administrator   ~0062336

Last edited: 2021-03-10 03:16

View 3 revisions

Tested 2321 and issue 2 in which saving artwork to a tag stops working is still occurring despite the fact that issue 1 seems resolved. i.e.
1 Navigate to a directory with 10 tracks from 10 different albums
2 Select one tracks from an album
3 Right-click > Properties > Artwork > Lookup image, select an image and press OK, and 'Save to folder' and click OK
4 Repeat step 3 two more times
5 Check 'Apply to all selected tracks / all tracks on the album/series' and Click OK in the Properties dialog to commit the changes
6 Right-click > Properties > Artwork
--> Artwork appears as expected
7 Select the track and Right-click > Properties > Artwork > and delete all three images and press OK
8 Right-click > Properties > Artwork
--> Images update as expected
9 Select the track and Right-click > Properties > Artwork , and select the auto-looked up image and 'Save' and then choose to save it to the tag if possible. Click OK and commit the change.
10 Select the track and Right-click > Properties > Artwork
--> Image appears as 'Unsaved image'! And subsequent attempts to save the image to a tag fail!

p.s. Note that performing step 9-10 _prior_ to all the other steps --> Album art is successfully saved to the tag. i.e. the failure at step 10 is somehow related to the steps performed beforehand.

michal

2021-03-10 18:31

developer   ~0062355

Fixed in build 2322.

rusty

2021-03-11 05:21

administrator   ~0062371

Last edited: 2021-03-11 05:44

View 2 revisions

Tested 2322. The bug still occurs using the same repro steps as in build 2321 :-(

Note: the video also demonstrates that once the bug occurs:
- Tagging of auto-looked up artwork on another album fails, but succeeds if the auto-looked up image is first deleted
- Tagging of any kind of artwork to the track that experienced the bug fails

michal

2021-03-11 17:34

developer   ~0062387

Fixed in build 2323. It was timing issue harder to reproduce on my PC.

rusty

2021-03-11 23:31

administrator   ~0062398

Last edited: 2021-03-11 23:45

View 3 revisions

Tested 2323 and the issue is still occurring though slightly differently and not as badly. After following the repro steps:
- Saving artwork to a tag --> label indicates 300x300 (xKB), but nothing about where it's saved to (previous builds showed the image as unsaved)
- Tagging of auto-looked up artwork on another album fails in the same manner as above (previous builds showed the image as unsaved)
- Tagging of any kind of artwork to the track that experienced the bug seems to work now except that images saved to a tag aren't labelled correctly as indicated above.
- The only way to get MediaMonkey out of this state (in which saving images to a tag doesn't label it as such) is to restart it.

michal

2021-03-12 18:15

developer   ~0062418

Fixed in build 2324.

rusty

2021-03-12 22:29

administrator   ~0062424

Verified 2324. MM no longer seems to get in a state where artwork tagging fails.