View Issue Details

IDProjectCategoryView StatusLast Update
0016545MediaMonkey 5Main Panel: Toolbars & Menuspublic2021-01-11 11:13
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0016545: File Operation: Basic Drag and Drop, Copy/Paste issues in MM5
DescriptionThis bug is merge of several bugs in order to be evaluated at same time.

1. Drag and Drop from MM5 or to MM5 Now Playing do not work correctly (0016453 Video at ~0057684)
    a) MM5 -> MM4 Add double tracks (Unable to reproduce in 2247)
    b) MM4 -> MM5 Removes track from MM4 Now Playing (Unable to reproduce in 2247)
    c) MM4 -> MM5 If track is not accessible there is no indication that D&D can't be performed (Mouse icon should show it)

2. Drag and Drop from MM5 to other apps mostly do not work (originally tracked at 0014429) , the exception being that dragging a single track to Windows File Explorer works.
    a) MM5 -> AIMP Nothing is added in AIMP Now Playing
    b) MM5 -> Skype Nothing Happen (MM4 0014597)
    c) MM5 -> Total commander adds URL shortcut link pointing to file path as URL "file:///F:/HDD%20G%20Backup/track.mp3" (In 2247 nothing happens I guess same reason as for MM4 0014597)
    d) MM5 -> Drag and Drop of Multiple tracks to Explorer only copy first track (in 2247 it creates playlist.m3u8 that contain path to files[one per line])

3. Drag and Drop From Other apps to MM5 do not work (0014429)
    a) Drag and Drop from Explorer -> MM5 Now Playing Shows it should be added but nothing happen (expected to be to set position in Now playing) Pic Attached
    

TagsNo tags attached.
Fixed in build2292

Relationships

related to 0015287 feedbackpetr Drag&Drop improvements (Internal to MediaMonkey) 
related to 0015884 closedLudek Pasting to an empty directory fails 
related to 0016543 closedpetr D&D: Drag and Drop MM4 -> MM5 Now playing do not work 
parent of 0016000 closedpetr Copy & Paste of files problems 
parent of 0014429 closedpetr Drag and Drop to another app fails 
parent of 0014597 assignedpetr Drag and Drop: D&D do not work from MMW now playing to Skype chat Window 
Not all the children of this issue are yet resolved or closed.

Activities

Ludek

2020-12-16 22:23

developer   ~0060839

Last edited: 2020-12-16 22:29

View 4 revisions

Peke, can you test/verify which of these issues are still valid and are not tracked elsewhere ?

e.g. I cannot replicate 1a, 1b, 3a (tested 2286) -- and 2) is not feasible due to Chromium limitations (AFAIK)

rusty

2020-12-16 23:09

administrator   ~0060846

Last edited: 2020-12-16 23:15

View 2 revisions

Re. 3) I've updated 0014429 with more details. The only problem I see is:
b) The MM destination window freezes in cases where the cursor is dragged across multiple panels in MM

petr

2021-01-05 17:39

developer   ~0061163

Last edited: 2021-01-05 19:06

View 2 revisions

re 2) made some changes in chromium so we're able to drag more than one track from MM5 ... only remaining problem is destination where can be dropped ... based on tests currently Total Commander and Skype are not allowed as a destination (tried AIMP and it is allowed).

Ludek

2021-01-06 17:43

developer   ~0061174

Last edited: 2021-01-06 17:48

View 3 revisions

2) I can confirm that the files can be dropped to audio editors like AudiaCity now ;-)
Original user request at https://www.mediamonkey.com/forum/viewtopic.php?p=475995#p475995

Resolved for testing to which apps the drop is functional to review whether something needs to be done for 5.0

petr

2021-01-06 17:49

developer   ~0061175

2) i've also tried (and allowed) to MM4, SoundForge, MP3Tag, MediaInfo, AIMP

peke

2021-01-09 19:25

developer   ~0061255

Verified 2293

All implemented and described here in BUG now works.

Great JOB!

Will open new BUG just for Skype.

Ludek

2021-01-11 11:13

developer   ~0061276

Also user confirmed it here https://www.mediamonkey.com/forum/viewtopic.php?p=476570#p476570