View Issue Details

IDProjectCategoryView StatusLast Update
0015884MediaMonkey 5Track Browserpublic2020-06-03 21:12
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015884: Pasting to an empty directory fails
DescriptionIf the user selects and copies a bunch of files in MM5 and then navigates to an empty folder:
a) there's no context menu to allow the user to paste the files
b) CTRL-V has no effect

There is a workaround, but it's limited to users using the Tree: Open the tree and right-click > Paste on the destination directory.
TagsNo tags attached.
Fixed in build2255

Relationships

related to 0014429 closedpetr Drag and Drop to another app fails 
related to 0016000 closedpetr Copy & Paste of files problems 
related to 0016257 closedLudek Copy / Paste keyboard shortcuts don't work for playlists 
related to 0016684 closedpetr Clipboard is blocked for 5 seconds after context menu (or dialog) usage 
related to 0016545 closedpetr File Operation: Basic Drag and Drop, Copy/Paste issues in MM5 

Activities

petr

2019-08-22 15:05

developer   ~0054405

Fixed

rusty

2019-08-29 13:21

administrator   ~0054454

This isn't working correctly for me in build 2193-A
1 Go to Music > Artist > ArtistName [Browser View]
2 Select 2 tracks from the List view and CTRL-C
3 Go to Home > Folders > NearEmptyDirectory
4 Right-click in empty space
--> no context command appears allowing the tracks to be pasted!!
5 CTRL-V to paste the tracks
--> Nothing happens most of the time!!
6 Trigger a refresh of the Folder view by exiting the folder and then going back to it
--> The track appears (most of the time)

I wonder, though, if the first issue is somehow related to the DB problems at 0015914 since if I use the recursive folders function, it results in a crash. i.e.:
1 Go to Music > Artist > ArtistName [Browser View]
2 Select 2 tracks from the List view and CTRL-C
3 Go to Home > Folders > NearEmptyDirectory (All)
Paste
--> Crash
Crashlog ID: 7CC8812F

rusty

2019-08-29 13:22

administrator  

bug-15884_build-2193A.7z (738,114 bytes)

Ludek

2019-08-29 14:14

developer   ~0054456

Last edited: 2019-08-29 14:14

View 2 revisions

Note that 7CC8812F is flase positive assertion in the internal updated build sent to Rusty (there was a bug in the new debug code)

rusty

2020-01-22 19:27

administrator   ~0056119

Retested in 2221 and this still isn't resolved for me. There's no longer a crash, but right click in Folders > Path > Empty directory still doesn't show a context menu AND CTRL-V has no effect.

Ludek

2020-06-01 21:27

developer   ~0058400

Fixed in 2255

Ludek

2020-06-01 21:39

developer   ~0058401

Last edited: 2020-06-01 21:54

View 4 revisions

Re-opened, while it works there are some random issues:

1) 'Paste Ctrl+V' context menu item is often disabled on initial right-click of the empty area
Workaround 1: wait several seconds before the right-click
Workaround 2: right-click the empty area again and the Paste item gets enabled immediatelly

2) updates under the Folders node takes several seconds and the updates are often somehow broken until user navigates to the folder again (or F5 is pressed)
Namely it duplicates the already existing tracks instead of showing the new one (until F5 is pressed), the same issue happens when using D&D, to be figured out what is going on...

Ludek

2020-06-02 13:20

developer   ~0058407

Last edited: 2020-06-03 11:54

View 2 revisions

1) is tracked as 0016684

2) Fixed in 2255

rusty

2020-06-03 21:12

administrator   ~0058424

Verified both CTRL-V and Context Menu > Paste (other than the delayed appearance of context menu entries) in 2255.