View Issue Details

IDProjectCategoryView StatusLast Update
0016130MediaMonkey 5Playbackpublic2019-11-29 07:20
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version5.0 
Target Version5.0Fixed in Version 
Summary0016130: Plackback: Spacebar causes focus to switch to MediaMonkey on track transitions
Description1 Initiate playback in MM
2 In notepad, start typing A <space> A <space> A <space>....
3 Track1 finishes playback and track 2 starts
--> Focus switches from Notepad to MediaMonkey

Note: I've seen this several times and it's not new to recent builds, but am only noting it now because I happened to have dbgview running when it happened and realized how to replicate it. The problem is caused by pressing the SPACEBAR while the Pop-Up is active; it probably causes focus to switch to MM because MM is 'listening' for the Play/Pause keyboard command (the problem doesn't occur when typing other characters).
TagsNo tags attached.
Fixed in build

Activities

rusty

2019-11-21 20:09

administrator  

focus-lost_on_track-transition.7z (139,729 bytes)

michal

2019-11-22 18:11

developer   ~0055456

We cannot reproduce it, please try to find more about how to replicate.

rusty

2019-11-24 00:59

administrator   ~0055477

Haven't been able to replicate in 2214/15. Resolving for now.

peke

2019-11-29 02:31

developer   ~0055541

Unable to replicate in 2217

rusty

2019-11-29 07:20

administrator   ~0055551

I haven't been able to replicate this even after many tries. Closing.