View Issue Details

IDProjectCategoryView StatusLast Update
0015280MediaMonkey (current)Synchronizationpublic2019-09-04 09:54
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version 
Target Version4.1.24Fixed in Version4.1.25 
Summary0015280: iTunes reports corrupted device after sync with MM (iPhone XR and XS)
DescriptionAfter MMW sync to users iPhone even all looks OK on iPhone when starting iTunes it reports a corrupted device and suggest Factory Reset.

iPhone XR, iOS 12.1.2 (claiming that it also happened with 12.1.1)

Logs and related info in Ticket
Additional InformationBAO-120-59505
https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=93591
https://www.mediamonkey.com/forum/viewtopic.php?f=7&t=92985

https://forums.developer.apple.com/thread/108848
http://www.iphonehacks.com/2018/12/how-find-iphone-xr-udid.html
https://www.theiphonewiki.com/wiki/UDID
https://blog.diawi.com/2018/10/15/2018-apple-devices-and-their-new-udid-format/
TagsNo tags attached.
Fixed in build1888

Relationships

related to 0009360 closedLudek MediaMonkey (current) iOS: iTunes wants to restore device synced by MediaMonkey for iTouch 3rd gen 
related to 0015378 resolvedrusty web Replace [i-FunBox and DiskAid] by [iMazing and iExplorer] 
related to 0015375 closedrusty MediaMonkey (current) Syncing with iTunes causes music on iPhone X to disappear 

Activities

peke

2018-12-23 02:45

developer  

Capture.PNG (39,578 bytes)
Capture.PNG (39,578 bytes)

Ludek

2019-01-02 11:14

developer   ~0051901

Last edited: 2019-01-02 12:38

View 2 revisions

I was unable to replicate this with my iTouch and iOS 12.1.3

User can no longer replicate the issue and it is working for him now (based on BAO-120-59505 ).

peke

2019-01-06 11:50

developer   ~0051962

Reopen, user supplied new information, I'll ask him for a copy of iTunesCDB prior to iTunes sync and after.

peke

2019-01-09 04:54

developer   ~0052002

Another user reported issue.

rusty

2019-01-24 18:20

administrator   ~0052215

I was unable to replicate this (see notes at 0015375) when testing with an iPhone X (iOS 12.1.2), MMW 4.1.23, and iTunes 12.9.2.6 (64-bit). What I did find, that may be relevant to this issue, is that whenever I ran iExplorer (the app that I was using to access iTunesCDB) with the iPhone connected, then on the next time I ran iTunes with the phone connected, a different error would result as soon as iTunes was run:
"The iPhone 'Ari's iphone X" cannot be synced. An unknown error occurred (-54).
However, initiating a sync with iTunes --> successful synchronization, and elimination of the error when iTunes was run subsequently.

Could this particular user's case be caused by an app similar to iExplorer?

Ludek

2019-01-24 20:12

developer   ~0052216

OK, I asked him.

Ludek

2019-02-08 09:12

developer   ~0052501

Last edited: 2019-02-21 13:56

View 4 revisions

It seems that the issue happens with "iPhone XR" only. Not with "iPhone X".

The original user has stopped the communication, debugging further via forums with other users:
https://www.mediamonkey.com/forum/viewtopic.php?f=7&t=92985
https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=93591

Ludek

2019-03-12 13:49

developer   ~0052940

Some tech/dev notes:

I have been debugging this remotely via ticket BAO-120-59505 (as I don't have iPhone XR/XS) and found:
- the difference is in the AB hash value (diff between iTunesCDB generated by MM and generated by iTunes)
- the AB hash is calculated from iTunesCDB content + some random part + device UDID
- the UDID for iPhone XR/XS is in the new format, see: https://www.theiphonewiki.com/wiki/UDID
- I tried supplying the new UDID for the hash calculation in various forms, but the error still appears in iTunes
- I also tried to calculate the old style UDID to supply, i.e. SHA1(serial + ECID + wifiMac + bluetoothMac) -- still no luck :-/

So probably the AB hash is calculated another way for the new models.

I used workaround of writing MediaMonkeyCDB (instead of iTunesCDB) with following downsides:
- music synced by MM won't be visible in iTunes anymore, but will be still visible and playable by iPhone itself
- iTunes sync will wipe music synced by MM

This is applied only for the new models (iPhone XR/XS) with the new UDID format.

This workaround is added in 4.1.24.1883

Ludek

2019-03-25 14:49

developer   ~0053095

User confirmed the fix here: http://forum.mediamonkey.com/viewtopic.php?f=7&t=92985&e=1&view=unread#p456984

Ludek

2019-08-30 12:15

developer   ~0054474

Last edited: 2019-08-30 12:18

View 2 revisions

This is still an issue for some iPhone XR models.

Ticket JFO-481-83317 , https://www.mediamonkey.com/forum/viewtopic.php?f=12&t=93591&e=1&view=unread#p461154

User's iPhone XR has a little bit different USB ID format ( USB\VID_05AC&PID_12A8\8&14C74800&0&4 instead of USB\VID_05AC&PID_12A8\0000802000010D4E2EE8003A ) and this is the reason why MM is not detecting it correctly and considers it as the old style iPhone/iPod (resulting in bad iTunesCDB write).

Ludek

2019-08-30 14:00

developer   ~0054475

Fixed in 4.1.25.1888 and merged to 5.0.0.2195

Posted testing DLL to user for confirming the fix.

peke

2019-08-30 19:29

developer   ~0054482

Verified 1888

No regressions found on iPod Touch 4G. Done two factory resets and and 2x MM4/iTunes syncs to see if iTunes would report recovery needed.

Ludek

2019-09-04 09:53

developer   ~0054511

User from ticket JFO-481-83317 confirmed the fix, so closing for now