View Issue Details

IDProjectCategoryView StatusLast Update
0015185MediaMonkey 5Playlist / Searchpublic2019-05-31 10:01
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015185: Scroll to match doesn't find all matches (and improvements)
DescriptionThis functionality doesn't work well in certain instances. e.g.
1) if the user wants to find an entry with a space e.g. 'The Beatles' (or similar things beginning with 'A' or 'The') --> it won't find the intended result
2) Similar to issue 1, though a slightly different usecase: If the user wants to find a word in the middle of a title. e.g. 'hole' for 'fixing a hole' --> not found
3) If the user wants to find an album (Abbey Road) and types 'Abbey' to find next track from 'Abbey road' --> Titles beginning with 'A' are found. The issue is that at a minimum, the user expects that at least displayed fields will be found for this type of search. In MM4 this expectation didn't exist because the search was based on the words displayed in the tree. But the tree values (e.g. Genre Values) isn't displayed in MM5 so the user doesn't have any clear expectation of a restriction on which fields will be searched.
4) On all such searches, MM appears to highlight incorrect matches (due to the cursor's position)
5) It occasionally crashes. See video and eLog C84B45B3

https://www.screencast.com/t/7RikegsNuCK


Note: I think that this is a pretty confusing issue, but if it's not trivial to fix, we can push it.
TagsNo tags attached.
Fixed in build2179

Relationships

related to 0015077 feedbackLudek Improve incremental search 
related to 0015312 closedLudek Freeze when pressing space while a track is selected in large tracklist 
related to 0015344 closedpetr Auto-tag: Dynamic Sorting makes it difficult to edit tracks 
related to 0015106 resolvedrusty Searching and filtering issues and crashes 
related to 0015559 feedbackjiri Default tracklist columns sort and visibility is problematic 

Activities

Ludek

2018-10-26 12:24

developer   ~0051484

Last edited: 2018-10-26 12:46

View 2 revisions

Fixed in 2131

peke

2018-11-15 01:43

developer   ~0051544

Verified 2132

Ludek

2019-01-07 11:19

developer   ~0051965

Last edited: 2019-01-07 14:53

View 2 revisions

Re-opened:
3) isn't fully fixed, while it works for non-track entities (like albums/artists) it fails for track entities (in tracklist)

Some other issues requested at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93547
6) user is requesting a pop-up showing the text being searched
7) a scrolling shortcut to scroll to the next result, currently the search word needs to by typed again to find the next result
8) Barry's UI freeze (id 5367CF21) -- tracked as 0015312

Ludek

2019-01-07 12:18

developer   ~0051967

Last edited: 2019-01-07 15:00

View 2 revisions

Item 3 fixed in 2148
Item 8 is fixed as 0015312

Ludek

2019-01-09 13:40

developer   ~0052010

6,7 are fixed in 2148

rusty

2019-01-11 16:45

administrator   ~0052043

Note to Peke: Don't close--Rusty should review new strings added in this build:
e.g. 'Scroll to', 'Use %s for the next occurence', 'No occurence for' , you might want to review them in the next build

Ludek

2019-01-14 10:21

developer   ~0052066

Re-opened for further improvements based on the last feedback from http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93547#p454778

9) Similar to current "Ctrl + Down" for the next occurrence add also "Ctrl + up" shortcut for the previous occurrence
10) Increase the current 500ms timeout (in which another letter needs to be typed to be suffixed) for slower typists, i.e. increasing to 1000ms could work
11) Using "space" key when using the incremental search pauses a playing song

Ludek

2019-01-14 13:36

developer   ~0052069

9,10,11 are fixed in 2149

peke

2019-01-20 01:42

developer   ~0052130

Verified 2149

rusty

2019-01-20 23:03

administrator   ~0052137

I haven't tested items 1-10 in 2149, however, I noticed the following:
11) in Music > Locations > FolderName, if scroll to match is enabled and the user types a search term that matches Title or Artist for tracks that only contain inferred Title and Artist fields, then the items aren't found!
video: https://www.screencast.com/t/c8KxakCvQiCE

rusty

2019-01-20 23:03

administrator  

bug_15185_issue_11.log.txt.7z (8,338 bytes)

Ludek

2019-01-22 20:05

developer   ~0052183

Last edited: 2019-01-22 20:09

View 3 revisions

Rusty, note that contextual search (scroll to matches) isn't supposed to work the same way as filter matches.
This is going to work as in MM4 (related to 0015077 - see item a) there, namely:

a) When user focuses a list-view then it always scrolls to the first file/track starting with the search phrase within title of the track. When user sorts the file list by artist then it scrolls to the place where tracks from this artist are. Someone can call this "power scroll" (more at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90949&p=449187#p449182 ).

In your case you have sorted the list by Album artist so the term is searched within the Album artist column.
Nevertheless I agree that this is hard to realize for novice users (and by evidence for you too ;-) ), this could be resolved by changing current tooltip from
No occurence for "coasters"
=>
No occurence for "coasters" within Album artist column
?

Another possibility would be to search within all visible columns, but this would break the MM4 approach that some (or many?) users are expecting ( see the Power Scroll section here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90949&p=449187#p449136 )

rusty

2019-01-25 06:47

administrator   ~0052226

11) Somehow, in MM4, powerscrolling seemed more intuitive--possibly because it worked in the tree and the tree was always visible.

Also, in MM4, the user could powerscroll, or search the library, collection, node
In MM5, with powerscroll enabled, the user can only search the Library
However, with filtering enabled, the user can search collections, nodes, or the Library, and considering that it's enabled by default, we can probably leave things as is for now.

In the future, though, we may find that we have to expand search options that are available on-the-fly for users that opt to enable Powerscroll.

Ludek

2019-03-10 13:42

developer   ~0052928

Last edited: 2019-03-10 17:48

View 2 revisions

Re-opened:

12) power-scroll don't work for symbols. For example, if I search for "Don't Know Much", I get no occurrences, because it has an apostrophe in it. Other symbols - like brackets, quotation marks, slashes, etc. - also don't work. Reported as: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94019

=> Fixed in 2166

peke

2019-03-16 02:56

developer   ~0052987

Verified 2166

Tested on all symbols I have in library including brackets, quotation marks, slashes

rusty

2019-03-19 19:31

administrator   ~0053019

Looks good. I just noticed a couple of items in 2166

1) Still open. i.e. scroll to multi-word item fails (e.g. Abbey Road or The Beatles)

13) There seems to be a performance issue with the use of CTRL-DOWN / CTRL-UP. e.g. if the sort is by Album, and the user searches for Abbey Road --> the first instance is found. If the user presses CTRL-DOWN to find the next one (which is the next track in the list), MM should find the next track _instantaneously, and yet what actually happens is that the Toast message appears, and then about 500ms later, MM scrolls to the next track! Could it be that MM is applying the typing delay for CTRL-DOWN/UP?

Ludek

2019-03-19 21:03

developer   ~0053021

+ 11) No occurence for "coasters"
=>
No occurence for "coasters" within Album artist column
to prevent from confusion (related to 0015559 )

Ludek

2019-03-19 21:19

developer   ~0053023

Last edited: 2019-03-20 15:31

View 4 revisions

11) fixed in 2167
13) yes, fixed in 2167
1) fixed in 2167

rusty

2019-05-15 21:21

administrator   ~0053533

Tested 2175
1) Verified
11) It currently displays
'No occurence for: "SearchTerm" , column: ColumnName'
'No more occurence for: "SearchTerm" , column: ColumnName'

The following is simpler:
'phrase not found in "ColumnName"'

Also, the second string 'No _more_ occurences...' isn't required (it's grammatically incorrect, but more importantly, it's self-evident from the fact that MM loops back to the top).

13) Verified



Ludek

2019-05-20 10:58

developer   ~0053577

Fixed in 2177

Ludek

2019-05-29 16:12

developer   ~0053659

Last edited: 2019-05-30 12:49

View 2 revisions

Re-opened, items 1&2 are rather problematic based on feedback here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94486&p=458812#p458798

Namely:
I don't always know exactly what i'm searching for, but i may know it starts with " L" so if i can bring all the artists starting with "L" into focus then i can quickly scan thru them (visually) to find what i am looking for. This is also an aid to editing, so for example i may have typed "Lupez" instead of ""Lopez"

Maybe we should make it a little be tricky and whenever only one or two letters are entered ('L' or 'Lo') then it would scroll to artists starting with 'Lo' , but when three (or more letters are entered) like 'Lop' or 'Lopez' then it would rather scroll to "Jennifer Lopez". i.e. it would be combination of both behaviours based on the length of the entered phrase.

=> Implemented in 2179

rusty

2019-05-31 05:25

administrator   ~0053680

I haven't tested the revised implementation yet, but there's a problem with issue 11) in 2178:
1 Type 'postal service'
--> 2 tracks found
2 press the down arrow twice
--> MM loops back to the first instance, but displays the message 'phrase not found in "ColumnName"'. This message should never display if instances are found--even when they loop back to the first instance.

Ludek

2019-05-31 10:01

developer   ~0053687

Fixed in 2179