View Issue Details

IDProjectCategoryView StatusLast Update
0015559MediaMonkey 5Main Panelpublic2020-02-21 13:08
ReporterLudek Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015559: Default tracklist columns sort and visibility is problematic
DescriptionThe default tracklist columns sort is
[Album artist, Album, Disc#, Track#, Title],
BUT the default columns visibility is
['title', 'artist', 'album', 'date', 'genre', 'rating', 'length', 'bitrate', 'source', 'path', 'filename', 'lastPlayed']

So the 'Album artist' is the main sort column, but it is invisible by default (tested by deleting persistent.json file and run MM5), see:
https://www.dropbox.com/s/mfrgytelivd7m90/Screenshot%202019-03-19%2018.54.39.png?dl=0

This becomes problematic mainly with regard to incremental search, when the "power scroll" is performed within the 'Album artist' column that is invisible by default though.
But also looks strange on first run (having no idea what is the first sort column).

Solution A: Replace 'Album artist' column by 'Artist' column in the default sort (like in MM4)
Solution B: Hide 'Artist' column by default and show 'Album artist' column instead

TagsNo tags attached.
Fixed in build

Relationships

related to 0014935 closedLudek 'Source' column and other default columns for list views 
related to 0015077 closedLudek Improve incremental search 
related to 0015185 resolvedLudek Scroll to match doesn't find all matches (and improvements) 
related to 0016322 closedpetr View configuration: Sort config doesn't match sort order 
related to 0016382 closedrusty Track Browser: Views do not look like that have same default Sort 

Activities

Ludek

2019-03-19 21:52

developer   ~0053024

Last edited: 2019-03-22 07:54

View 3 revisions

Implemented item 11) from 0015185 to prevent from this confusion

jiri

2019-03-20 09:13

administrator   ~0053028

There some problems of the proposed solutions:
A. Would result in unwanted ordering of multi-artist albums.
B. Album artist isn't always known/present in tags.

I'd propose:
C. Keep it as is, just be smart about Artists vs. Album Artist, e.g. when the order is by Album Artist, but it isn't visible, Search by Artist.

rusty

2019-03-22 13:21

administrator   ~0053065

The actual bug would seem to be that MM is _sorting_ on a field that isn't visible and there's no way to understand what that sort order is. In other words, before the user gets confused about incremental search, they'll be confused about why tracks are displaying in a particular sort order!

The problem is even worse in 'Simplified list' view because:
a) the user doesn't have any way of displaying the columns that might help them understand the sort order
b) if the user changes the sort order, there's no way to change it back to the original sort order ('Reset sort order' seems to change it to a different sort order, but not to the original sort order)

A solution to all of these problems is to add a 'Sort by' context menu. e.g.
Sort by >
 o Album Artist/Album/Track#
 . Album Artist/Year/Album/Track#
 . Year/Album Artist/Album/Track#
 . Genre/Album Artist/Album/Track#
 . Date added / Album / Track#
-----------------------------------------------------
Define custom sort... (future??)

With this approach, if any of the preset sorts were active, the user can see what they are. And if the user initiates a sort by clicking a column, it overrides the preset, but the user can revert to any of these presets and know what they'll be reverting to!



So although C. solves a consequence of the problem, it doesn't solve the actual problem.

rusty

2020-01-30 18:36

administrator   ~0056401

In 2223, the issue of sort order not being visible is somewhat resolved since it can be seen via Manage views functionality.

As far as the original issue: if the user were to search for 'Various artists' even though 'Album Artist' field isn't displayed, wouldn't they expect to still see the tracks by that Album Artist (in which case nothing should b e done)?

Ludek

2020-01-30 21:57

developer   ~0056407

Last edited: 2020-01-30 21:58

View 2 revisions

Resolving, as the original issue has been reduced by adding:

1) tooltip of the sort order, see:

2) tooltip in case of failed scroll to match (with the column info), see:

tooltip 1.png (34,853 bytes)   
tooltip 1.png (34,853 bytes)   
tooltip 2.png (24,677 bytes)   
tooltip 2.png (24,677 bytes)   

rusty

2020-02-07 18:21

administrator   ~0056570

Verified 2226.