View Issue Details

IDProjectCategoryView StatusLast Update
0014935MediaMonkey 5Main Panelpublic2019-03-19 20:50
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014935: 'Source' column and other default columns for list views
DescriptionFor location sunodes (especially tracks scanned/paired from the cloud locations) it would be valuable to show the Source column like this:
https://www.dropbox.com/s/z3qvgk6s37jd7rc/Screenshot%202018-07-03%2015.09.54.png?dl=0
so that user can see/sort by the source (remote versus local)
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90338&p=447071#p447066
TagsNo tags attached.
Fixed in build2125

Relationships

related to 0014412 closedpetr List view columns should be customized per type 
related to 0015023 resolvedLudek Ability to show to which remote locations track is stored 
related to 0015559 feedbackjiri Default tracklist columns sort and visibility is problematic 

Activities

Ludek

2018-07-03 14:06

developer   ~0050692

Last edited: 2018-07-03 14:14

View 2 revisions

Maybe we could enable the Source column for all nodes with path column and place it just before the path?

i. e.
Title, Artist, Album, Length, Rating, Source, Path
like this https://www.dropbox.com/s/erzcuoiwr3jx3cp/Screenshot%202018-07-03%2016.14.17.png?dl=0

?

rusty

2018-09-18 21:33

administrator   ~0051155

Last edited: 2018-09-18 21:35

View 2 revisions

Sounds good.

Note: I assume that you mean to just modify the current defaults to include Source just before the path for Location/Folders/Cloud drive nodes.

Ludek

2018-09-19 08:40

developer   ~0051160

Last edited: 2018-09-19 08:58

View 6 revisions

The default columns in all views (except for 'All Videos') was
['title', 'artist', 'album', 'length', 'bitrate', 'path']
so I changed it to
['title', 'artist', 'album', 'length', 'bitrate', 'source', 'path']
in build 2124

I guess that the 'source' column is useful whenever the path column is displayed (e.g. in 'Music > All tracks) to see whether it is just remote track link or local file etc.
Let me know if you don't think so (or whether the defaults should differ based on node type)

Ludek

2018-09-24 12:30

developer   ~0051200

Last edited: 2018-09-24 12:46

View 4 revisions

Added the new column defaults per collection in build 2125.

Just a note, isn't there currently too many default columns for the "Automatic columns width" feature?
e.g. for music there are:
['title', 'artist', 'album', 'date', 'genre', 'rating', 'length', 'bitrate', 'source', 'path', 'filename', 'lastPlayed']
which isn't much usable for the "Automatic columns width" feature:
https://www.dropbox.com/s/0dnxbgxfyjo1w0s/Screenshot%202018-09-24%2014.41.56.png?dl=0

Especially the 'filename' column seems to be redundant to 'path' ? And the 'date' column doesn't seem to be needed in the defaults?
i.e. I would suggest to remove 'date' and 'filename' from the defaults?

Re the green fields for the 'simple list view', I haven't added them as the 'Simple list view' is deprecated and replaced by the "Automatic columns width" feature.

rusty

2018-09-27 19:52

administrator   ~0051216

Re. the fact that there are too many columns for 'automatic column widths': I wasn't aware of the decision to deprecate Simple list view (and the consequent effect that the default view will therefore be more crowded). That said, I think that for most of our users (who are reasonably advanced) there aren't many columns that should be removed by default. I've updated the document as follows:
- Removed bitrate as a default
- Removed last played as a default

Re. Now Playing: the basic NP should remain as it is: #, Title, Rating, Artist - Title, Time (my comment about Now Playing was in reference to a full NP view which isn't currently implemented).

Lastly re. duplication of Path and Filename, the intent is that Path should only display the first few characters of the path so that the user can either sort by path or hover over the path to see the full path.

Ludek

2018-10-02 10:09

developer   ~0051229

Fixed in 2125

peke

2018-10-05 09:47

developer   ~0051271

Verified 2126