View Issue Details

IDProjectCategoryView StatusLast Update
0015023MediaMonkey 5Properties/Auto-Toolspublic2018-10-16 17:54
ReporterLudek 
PriorityurgentSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version 
Summary0015023: Ability to show to which remote locations track is stored
DescriptionIn MM5 the local track can be paired with more remote locations of the track. This can be done by scanning cloud content (GPM, OneDrive, DropBix, MMS) into library, the tracks are paired with local tracks (based on metadata) and thus the local track gets one or more remote locations.

User is asking for the track properties dbox to display the location(s) where the track is stored. Maybe a new tab for track location(s) (ie. additional to Basic, Details Classification, etc). Or a list on one of the existing tabs. ... Something which would list the local and web locations where the track is stored. ... It would be good if we could also uncheck a web location, to disconnect the track from the web location.

More at:
http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&e=1&view=unread#p448192
TagsNo tags attached.
Fixed in build2129

Relationships

related to 0015029 feedbackrusty Deletion of library tracks stored also to the cloud 
related to 0015026 feedbackrusty Syncing Google Drive fails to add tracks to the library 
related to 0014983 feedbackrusty Cloud sync: further sync/scan sub-options 
related to 0014935 resolvedLudek 'Source' column and other default columns for list views 

Activities

Ludek

2018-08-10 13:49

developer   ~0050900

Assigned to Rusty for review.

Ludek

2018-09-12 11:25

developer   ~0051074

I guess this can be implemented as an addon?
e.g. adding "Synchronized to" tab into Properties dialog listing all devices and sync targets where the track resides.

rusty

2018-09-12 17:49

administrator   ~0051078

Last edited: 2018-09-27 16:01

View 2 revisions

I'm not sure that this should be an addon.

If we consider that a track entry represents all instances of the track that are in the library (i.e. it shows all locations of the track), then it also means, that changes/deletion of the track should automatically apply to all instances. When we'd discussed this at 0014665, there seemed to be concensus that edits should apply universally, and that deletion workflow needed to be modified so that it's clear what instances of a track are being deleted, but afaik, this wasn't yet implemented. From my perspective, this _should_ be implemented and at the same time we should add track reference indicators.

As to the UI, perhaps something along the following lines:
File path: _[[[icon1]] [icon 2] Path for [icon 1]
File name: _Filename for [icon 1]

In other words, when multiple paths exist within the library, the user can click an icon associated with a path, and that path/filename appears and is editable.


For list views and auto-tools, a possible approach would be to indicate multiple icons in the 'Source' column to communicate the existence of multiple insances. BUT, it's not clear how/whether auto-tools should apply to only specific instances of a track and/or how to choose which specific instances.

EDIT: Another possibility could be to only show a single icon but have two versions of the icon: one for the source and one for the source-synced. e.g.
- [HD icon] or [HD icon with synced indicator]
This way, if a [Google drive] icon appears, then it's clear to the user that the content isn't synced.
This approach has the advantage of always showing only a single icon, BUT the disadvantage that the synced locations aren't immediately visible.

Thoughts?

Ludek

2018-10-02 17:10

developer   ~0051233

Also, user is requesting ability to show unmatched tracks when the ' [ ] Add links to '<Device/Service Name>' content missing from the library' is disabled so that he could add it manually into MM library.
i.e. list of those tracks that exists in remote drive, but has failed to match with library track), i.e. those that we call "new" files
To be found how to integrate this into UI, we would probably need a new node (besides the 'All tracks') under Devices & Services > GPM > ... ??

More at http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&start=30#p449916

Ludek

2018-10-04 20:34

developer   ~0051251

Last edited: 2018-10-04 20:53

View 9 revisions

As for the showing multiple locations in Properties dialog:
I guess that current line (label, edit, icon)
File path: [C:\....][icon]
could be replaced by line (label, dropdown, edit)
Location: [icon^] [C:\........]

I don't think that the cloud locations need to be editable, actually some of them (e.g. GPM) even cannot be (there is nothing like path in GPM).

As for showing in list views:
I agree that a single icon is problematic, currently we have eight possible icons in the 'Source' column ('drive' (HDD), 'download', 'cloud', 'googledrive', 'dropbox', 'play' (GPM), 'server', 'youtube') -- see them in /skin/icon/*.svg
Per your suggestion there would need to be another ('hdd with synced indicator') and to distinguish between tracks located only in cloud and cloud tracks added (scanned) to library we would need another.
I guess that 10 different icons would be very hard to understand. i.e. we need to eliminate the set reasonably or introduce two icons in a row, the first icon would indicate the remote status and the second would indicate the library status.
[remote status][library status]

Examples:
[cloud][hdd] - cloud track that has been matched with already existing local track on hdd
[cloud][download] - cloud track that has been downloaded to library (cached)
[cloud][sync] - cloud track presented in library (added into library), but not cached
[cloud] - just cloud track (e.g. in Devices & Services > GPM > All tracks) - not in library
[hdd] - just local track scanned into library (as in MM4)
[youtube][sync] - youtube track in library
[youtube] - just youtube track (not in library)

Note that we would probably need to also eliminate the 'googledrive', 'dropbox', 'play' (GPM), 'server' icons and always presented them just as [cloud] icon.
The reason is that once a track is located in 'googledrive', 'dropbox' and 'server' (MMS) than we would need to show just one of them (even there are multiple cloud locations for the single track in library).
Another possibility is to show the 'googledrive' icon only when google drive is the only remote location (and show 'cloud' icon whenever there are multiple remote locations)

Thoughts?

Ludek

2018-10-09 20:37

developer   ~0051287

Last edited: 2018-10-11 17:39

View 6 revisions

Re: the usecase of showing unmatched tracks:
Implemented in build 2127 using the double-icon approach like this:
https://www.dropbox.com/s/vk74ujl2lg19cvx/Screenshot%202018-10-09%2022.43.42.png?dl=0


Re: the represantion of locations in list views:
Implemented in 2127.
Note that I used rather [local library status][remote status] ordering like this:
https://www.dropbox.com/s/nqfb8i43b9ydedc/Screenshot%202018-10-09%2022.30.32.png?dl=0
as it seems clearer when the local status is the first.

I just think of introducing a tooltip when hovering over the double-icons?
i.e. when hovering over [hdd][cloud] icon the tooltip could indicate to which remote/local locations it is stored?
Could you suggest a wording for the set of combinations above? Also, in the tooltip we could probably list all the remote locations where the track resides?


Re. representation of locations in the properties dialog:
- because there isn't a consensus yet (based on your last private note) and is unclear how/whether it should be represented in the Properties dialog then we can just deffer this for now and decide later?
- also based on the feedback the representation in file Properties seems no longer requested ( see http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&start=30#p450489 )
- we should probably just ensure that 0015029:0050907 is implemented in the manner that user can easily delete (or unlink) tracks from various locations

rusty

2018-10-11 19:28

administrator   ~0051300

Representation looks good--hopefully users agree.

Re. tooltips, how about:
1) [hdd][cloud] - x and y, z,... (synced)
2) [download][cloud] - y (cached)
3) [link][cloud] - y (linked)
4) [cloud] - y (not in library)
5) [hdd] - x (in library)
6) [link][youtube] - youtube (linked)
7) [youtube] - youtube (not in library)

Re. representation of locations in the properties dialog:
The properties dialog is the 'details' view, so we should probably at least display the same information as appears in the list view (e.g. using tooltips). How about we add a row for Source (informational only, with tooltips)?

As far as path/filename, I guess that if we only display a single path, it would work as follows (I guess this is probably how it's currently implemented)?
1) [hdd/network][cloud] - only show the hdd/network path/filename (editable) + metadata (editable)
2) [download][cloud] - only show 'cached from y' in the path and ?nothing in filename? + metadata (editable)
3) [link][cloud] - only show 'linked from y' in the path and ?nothing in the filename? (non-editable) + metadata (editable)
4) [cloud] - only show the remote filename (non-editable) + ?metadata?(?editable only in case of MMS?)
5) [hdd/network] - only show the hdd/network path/filename (editable) + metadata (editable)
6) [link][youtube] - only show the remote path (Youtube) + filename (non-editable) + metadata (editable)
7) [youtube] - only show the remote path (Youtube) + filename (non-editable) + ?metadata? (metadata non-editable)
8) Whenever metadata is editable, the edits apply to all sources of the file

Ludek

2018-10-12 08:38

developer   ~0051306

Last edited: 2018-10-12 09:12

View 6 revisions

Re the tooltips, I don't understand what do you mean by " x and y, z,... (synced)" ??
I meant something like this when hovering by mouse over the icons (just to understand what the icons represents):
[hdd][cloud] - Originally stored locally and matched with remote copy (copies)
[download][cloud] - Downloaded from a remote location
[link][cloud] - Links to remote location
....

Re. representation of locations in the properties dialog:
I guess we could just leave the double-icon there (as in list-view) with the tooltips?
I don't think that a new 'Source' row is needed? It just can remain placed next to the first 'File path' row? I just think that the 'File path' could be renamed to 'Location' like this?
Location: [C:\...][hdd][cloud]

EDIT:
Maybe a tooltip for the [cloud] icon could list all cloud locations where the track resides?
Or better, clicking the [cloud] icon could bring popup menu with all the cloud locations listed, I mean similar popup menu like in case of adding new service via the (+) icon like this:
https://www.dropbox.com/s/w30au3ux987ldkr/Screenshot%202018-10-12%2011.09.54.png?dl=0

Re: As far as path/filename ...
Yes, with this exceptions:
2) [download][cloud] - only shows the hdd/network path/filename (editable) + metadata (editable)
3) [link][cloud] - only shows the remote path (for OneDrive, DropBox, GDrive) and empty path for GPM + metadata (editable)
4) [cloud] - only shows the remote path (for OneDrive, DropBox, GDrive) and empty path for GPM + metadata (editable)

rusty

2018-10-12 15:52

administrator   ~0051322

Re. the tooltips:
1) 'x and y,z (synced)' could be:
'[D:] and MediaMonkey Server, Google Drive (synced)'
'[C:] and MediaMonkey Server (synced)'

note: I used 'synced' rather than language denoting the _original_ source because afaik the original source could be the cloud drive. Do you disagree with this approach?

2) [download][cloud] - y (cached) could be:
Google Drive (cached)

3) [link][cloud] - y (linked) could be:
One Drive (linked)

--
Re. representation in the Properties dialog: I'm fine with the first idea for now if that's easier, though I'd re-order it. e.g.
Location [hdd][cloud] : C:\....

I also like the idea of allowing the user to click the cloud icon to choose to view other locations, but it might not be necessary for now since in most cases the path isn't editable.
--
Re. paths filenames: thanks for clarifying.

Ludek

2018-10-16 17:54

developer   ~0051355

Implemented in 2129