View Issue Details

IDProjectCategoryView StatusLast Update
0014983MediaMonkey 5Syncpublic2020-10-11 19:51
ReporterLudek Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014983: Cloud sync: further sync/scan sub-options
DescriptionUser is asking for further scan/sync sub-options: https://www.dropbox.com/s/4sd8qmdy2r9hm3n/propose.png?dl=0
Described in a greater details and purposes at http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=447705#p447618

The three options are just split of the current '[x] Scan for media / playlist' checkbox

- the first option matches the tracks
- the second option adds unmatched tracks into library
- the third option sync tags (updates metadata) for the matched tracks

I guess that the splitting does make sense and is useful also for the other cloud services as well (GDrive, DropBox, OneDrive, MMS)
TagsNo tags attached.
Fixed in build2135

Relationships

related to 0014981 closedLudek Local version of cloud track is always preferred for playback (even if inaccesible) 
related to 0015023 closedLudek Ability to show to which remote locations track is stored 
related to 0014936 feedbackrusty Cloud scanning: Add scan results dialog 
related to 0014668 closedrusty Tweak Cloud profiles so that they're not so 'device' centric. 
related to 0015849 closedLudek GPM sync: Split config for metadata syncing into two directions 
related to 0015878 closedLudek Device config clearness issues 

Activities

Ludek

2018-07-24 18:28

developer   ~0050810

Rusty, what do you think?
Generally I agree on adding the sub-options, just not sure about the wording?

Ludek

2018-08-02 14:34

developer   ~0050856

Further related discussion: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=448018#p447780

Ludek

2018-08-10 12:18

developer   ~0050898

I guess that actually the layout should be simplified to

'[x] Scan for media / playlists
-- [x] Add unmatched tracks into library (adds new or missing tracks into library)
-- [x] Sync tags (Update metadata for matched tracks)

Ludek

2018-08-12 11:30

developer   ~0050920

Further feedback here: https://www.mediamonkey.com/forum/viewtopic.php?p=448318#p448318

The last proposal (discussed offline):

[x] Scan for media / playlists _manual^_
-- [x] Add new tracks and playlist to the library
-- [ ] Download new files
-- Save downloads to: __________________
-- [x] Sync metadata (Update metadata for matched tracks and playlists)

rusty

2018-09-07 21:20

administrator   ~0051057

To summarize the feedback:
- there's confusion between what is the 'library' vs what is the 'target'
- there's confusion of the terms scan vs sync (i.e. why confuse the user with 'sync' when they want to just 'scan' the drive)?
- Scan to Library / Sync to target imply _action_ rather than configuration
- add vs scanning (progress bar always indicates adding)
- file > add/rescan vs sync for cloud content is confusing
- tracks in the sync node vs the library is confusing
- It's unclear that almost all sync 'Options' refer to options for syncing to the target device/service

The following proposal, which consists primarily of changes in wording/order attempts to deal with all of these issues primarily by:
- indicating in all config screens what specifically is being synced
- not using 'action'-oriented terminology for the tabs, and instead referring to which content is being configured
- using 'add' where possible rather than scan
- re-organizing the 'Remote content' tab so that it is more clear how adding content from a drive relates to synchronization

Let me know what you think.

------------------------------------------------------------
1)
Breadcrumb: ...Devices & Services > <Device/Service Name>
Tabs: . . . . . . [Remote content] | Library content | Options

Google Drive
Account: ....... [Sign out]
Last synced:....
Capacity:....
Free: ...

[Folders] [All tracks] [Playlists]

[x] Add '<Device/Service Name>' content links to the library on sync (On sync, links to new files & playlists from the remote drive are added to the library)
-- [ ] Download files
-- Save downloads to: __________________

-- Sync schedule: _Manual_
-- [x] Sync metadata (Update metadata for matched tracks and playlists)
                                                                          [Apply] [Sync Now]

Note:
- 'Sync Schedule' and '[x] Sync metadata' apply to both Remote Content (scanning) and Library content (syncing). That's why they're separate from the options above (otherwise the UI would imply that these features are active only if 'Add remote content' is disabled).


------------------------------------------------------------
2)
Breadcrumb: ...Devices & Services > <Device/Service Name>
Tabs: . . . . . . Remote content | [Library content] | Options

[ ] Add library content to '<Device/Service Name>' on sync
. . Collections: . . . . Choose which library content to sync:. . . . . . . [ ] Hide unselected items
. .
. .
. .
. . . . . . . . . . . [ ] Sync a random subset of selected files up to the capacity of '<Device/Service Name>'
. . . . . . . . . . . . . .....
. . . . . . . . . . . . . .....
[ ] Delete other files and playlists from '<Device/Service Name>': ___________^
. . [ ] Confirm deletion

------------------------------------------------------------
3)
Breadcrumb: ...Devices & Services > <Device/Service Name>
Tabs: . . . . . . Remote content | Library content | [Options]

Changed strings:
a) Convert the following formats when synchronizing:
-->
Convert the following formats when syncing to '<Device/Service Name>'

b) Supported formats on the target
-->
Supported formats on '<Device/Service Name>'

c) Sync files to:
-->
Save files to the following locations on '<Device/Service Name>':

d) Enforce use of sync mask for files already on the target
-->
Enforce use of the sync mask for files already on '<Device/Service Name>'

e) Other media files:
-Is this setting actually used (it seems to be configured with paths specific to an Android device)?

f) Tagging:
Add: 'Modify metadata as follows when syncing to '<Device/Service Name>'

g) Playlists:
Sync playlists: Are any of the sync playlist settings relevant for cloud sync?

Ludek

2018-09-14 15:14

developer   ~0051116

OK, sounds good.

4) The three dots menu (overflow) for the device item should include 'Configure...' (as some users have not realized that they can just click the item to configure the device).

Ludek

2018-09-14 16:53

developer   ~0051117

Last edited: 2018-09-14 17:45

View 5 revisions

The wording changes + item 4) implemented in 2122.

There are just some TODOs about the new 'Sync Schedule' and '[x] Sync metadata' options.

-- [x] Sync metadata (Update metadata for matched tracks and playlists)
just to ensure -- when this option is disabled, should it mean that it doesn't update metadata only for the matched tracks or for all tracks+playlists? i.e. if there is a track that hasn't been originally in the target and is synced from our library to GPM then any subsequent changes re the track metadata are not synced between library and GPM, right? i.e. it should apply to all tracks+playlists and everytime?

-- Sync schedule: _Manual_
OK, we can make it independent on the 'Add content links to the library' checkbox, TBD

Shouldn't the '[ ] Download files' be renamed rather to something like '[ ] Download unmatched files' ?? This also implies that we should try to better communicate the fact that the already existing library tracks are just matched (based on metadata) to eliminate duplicities in the user library.

--there is still missing an option to match the remote tracks with library tracks without adding unmatched tracks into library, this was one of the Barry's requested usecases and a reason for entering this issue

rusty

2018-09-18 04:22

administrator   ~0051142

Re. -- [x] Sync metadata (Update metadata for matched tracks and playlists): agreed.

Re. '[ ] Download files' be renamed to something like '[ ] Download unmatched files': I agree that it should be clearer. How about:
[ ] Download new files.

Re. missing an option to match the remote tracks with library tracks without adding unmatched tracks into library: I'm not sure how common this requirement will be, but if we find it to be needed, we can modify this section as follows:
[x] Update the library with links to '<Device/Service Name>' content on sync (On sync, the library is updated with links to files & playlists from the remote drive)
-- [ ] Exclude new files
-- [ ] Download new files
-- Save downloads to: __________________

Ludek

2018-09-18 14:03

developer   ~0051146

Implemented in 2124

Ludek

2018-09-19 07:47

developer   ~0051157

Last edited: 2018-09-24 12:53

View 8 revisions

Re-opened:
Based on feedback the word "new" can be still confusing: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&e=1&view=unread#p449688
Maybe we should add tooltips also for the '[ ] Exclude new files' and '[ ] Download new files' checkboxes to clarify it and rename them as follows? :

[x] Update the library with links to '<Device/Service Name>' content on sync (On sync, the library is updated with links to files & playlists from the remote drive)
-- [x] Add missing files into library (Inserts files that exist in '<Device/Service Name>', but are missing in the library)
-- [ ] Download missing files (Downloads files that exist in '<Device/Service Name>', but are missing in the library)
-- Save downloads to: __________________

Also, user is requesting ability to show unmatched tracks when the '[ ] Insert missing files' is disabled so that he could add it manually into MM library.
i.e. list of those tracks that exists in remote drive, but has failed to match with library track), i.e. those that we call "new" files
To be found how to integrate this into UI, we would probably need a new node (besides the 'All tracks') under Devices & Services > GPM > ... ??

rusty

2018-09-27 16:03

administrator   ~0051214

Last edited: 2018-09-27 18:53

View 4 revisions

Re. 'new files' (on the Google drive) vs 'missing files' (on the local drive), the Tab and superior item is 'Remote content' and '...Google Drive' so I think it's clearer if the language is in reference to that content. That said, we should clarify via tooltips and a bit more context. Also, the term 'files' can be a misnomer since it's really new _content_ that is being linked.

Re. use of 'Exclude ... files' instead of '[x] Add missing files ...': 'Add missing files...' doesn't seem to differentiate from the superior option 'Update the library with links to Google drive' (i.e. if the 'Update' option is enabled, the 'Add missing files' option seems redundant to the user). We can fix this via a change in wording.

With the above in mind + the feedback received, how about:

[x] On sync, update the library with links to matching content on '<Device/Service Name>' (On sync, the library is updated with links to files ?& playlists? from the remote drive that match existing library content)
-- [x] Add links to '<Device/Service Name>' content missing from the library (Adds links to files and playlists that are in '<Device/Service Name>' but not in the library).
-- [ ] Download '<Device/Service Name>' content missing from the library (Downloads files and playlists that are in '<Device/Service Name>' but not locally in the library).
-- Save downloads to: __________________
[x] Sync '<Device/Service Name>' metadata with the Library (Update metadata for matching tracks and playlists)
Sync schedule: _Manual_^

Lastly re. a means of displaying unmatched tracks, this seems to be the same as 0015023, so let's continue the discussion there. As to having a command to sync a single track to a particular location, shouldn't this be possible via Send to > MediaMonkey Library (Sync) / Send to > MediaMonkey Library (as link)?

(note: as previously mentioned I think that the 'as link' functionality is an outlier usecase).

Ludek

2018-10-02 17:07

developer   ~0051232

I've updated the wording for tooltips and checkboxes as suggested in the build 2125.

Re displaying of unmatched tracks, I don't think it is the same as 0015023, but rather related, because 0015023 is about showing the linked locations via Properties dialog.
User is rather asking to list all unmatched tracks at once, i.e. probably via a new node sibling to Devices & Services > GPM > All tracks ??
Moved to 0015023 as suggested.

Ludek

2018-10-10 11:32

developer   ~0051290

Re-opened for the wording evaluation, user is still seeing it as confusing, details at
http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&start=30#p450334

rusty

2018-11-27 15:59

administrator   ~0051625

A number of issues were raised at http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&start=30#p450334 . I'm only commenting on those that relate to UI changes (I assume that functional issues have already been resolved):

1) Re. the apparent conflict between download location at Tools|Options|Downloads|DefaultDLLocation, and a different one at Devices&Services>GPM SaveDownLoadsTo.

Based on discussions with Ludek, it probably makes sense to only use the setting at Tools > Options > Downloads , especially considering that the currently scenario could result in identical files (from different cloud services) being copied to different locations.

Note: in the future, we can decide whether additional masks are required (e.g. for Audio vs Video)

2) Barry asked which scan settings (Tools > Options > Library) re. Add/RescanFilesToLibrary apply to Cloud Services/MMS scanning. Ludek, can you clarify which scan settings (aside from file extensions) apply?
We may want to modify the wording in that config panel / include a link to 'scan settings...'/ and perhaps update the wording of the sync dialogs to better communicate the relationship to scan settings.

3) Based on the confusion re. some of the wording and the work we've done re. MMS, it might be simpler to use wording similar to that used for MMS. e.g.

Sync settings:
[ ] Scan 'Google Drive' content to the local database {this is an existing MMS string} {"On sync, the database is updated with links to files and playlists from 'StorageLocation'"}
 . . [ ] Exclude content that doesn't match files already in the database /OR/ Only include content that matches files already in the database {"On sync, the database is only updated with links to files & playlists from 'StorageLocation' that match files already in the database")
 . . [x] Download 'Google Drive' content that's not accessible locally {can be enabled only if item above option is disabled} {"Downloads files and playlists from 'StorageLocation' that aren't accessible via the local drive or network"}.

Ludek

2018-11-27 21:36

developer   ~0051631

Last edited: 2018-11-27 21:36

View 2 revisions

Implemented in 2135

peke

2020-10-11 19:51

developer   ~0059805

Verified 2269

Described Functionality and UI changes tested and confirmed fixed. In case of new tweaks and improvements we can open new bugs.