View Issue Details

IDProjectCategoryView StatusLast Update
0015878MediaMonkey 5Synchronizationpublic2019-09-20 20:59
ReporterLudek 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015878: Device config clearness issues
DescriptionThere are various device config clearness and tooltips issues raised here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94739&p=460800#p460394
and here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94739&p=460800#p460798
to review and update.

Some of them are fixed in 2192 -- mainly added the missing tooltips from MM4 etc.
 
TagsNo tags attached.
Fixed in build2198

Relationships

related to 0014668 resolvedrusty Tweak Cloud profiles so that they're not so 'device' centric. 
related to 0014983 resolvedLudek Cloud sync: further sync/scan sub-options 

Activities

rusty

2019-08-19 18:36

administrator   ~0054393

Last edited: 2019-08-19 18:37

View 2 revisions

# 1: Re. apparent conflict re. Auto-sync of Playlists and Options > Playlists > Sync Playlists: this option and many others in Options: File Locations/Tagging/Playlists are relatively advanced (used only for setting profiles) and not required for 90% of cases (which involve Android or Apple devices). Considering this, we might want to consider moving all Profile-specific Settings directly into the Profile settings screen so that it's clear which items are part of a Sync Profile, and so that these settings wouldn't even be looked at in the case of pre-configured profiles. What do you think?

# 2: I agree that it would be useful to have a summary that showed all selected items. Possible future enhancement.

# 4 Tooltips:
A) Deletes files from the device if they're not on the Auto-Sync list. In general, this should be enabled, but be aware that it can delete files from the device if you've added them to the device via another computer or if you've modified file tags on the device but not in the Library.
-->
Deletes remote content that isn't selected in the Auto-Sync list (either all unselected content or only unselected content that exists in the local database). Deletion occurs after remote content has been synced (if that option is available/enabled). In general, deletion should be enabled to prevent duplicates on the remote location, but the option to delete 'all' unselected content should be used carefully if the remote location contains new/modified content that isn't in the local database.

B) MM4 tooltips are still missing (in 0002192) for the Auto-Sync (-->Library) tab

C) Device profiles contain default settings that allow adevice or storage location to sync correctly. They don't include user-settings such as which content will sync
-->
Sync Profiles contain default settings for a device or storage location to sync correctly. They don't include user-settings such as which content will sync.

Also, I'd suggest that this text should appear at the top of the screen (instead of at the bottom), replacing "Profiles for various devices and storage locations can be imported via the MediaMonkey addons database:"

At the same time, for consistency:
Settings profile --> Profile settings

C)ii Reset Settings...: Resets this sync profile to its default settings

C)iii Are you sure you want to reset this profile settings? --> Are you sure you want to reset this profile to its default settings?

D) This causes the playlist to use a relative path to the files --> Relative paths store file links in a playlist in relation to playlist's location, allowing the playlist and content to be moved to other locations without breaking the links.

E) Level volume when synchronizing audio: Adjusts the volume of files to the chosen level (lossless only for MP3 files). Mainly for older devices since since most devices can adjust volume on the fly based on Replay Gain tags.

Minor UI changes:
F) Confirm deletion (recommended)
-->
Show confirmation dialog (Tooltip: Shows a confirmation dialog with a list of the files that will be affected)

G) Confirm updates (recommended)
-->
Show confirmation dialog (Tooltip: Shows a confirmation dialog with a list of the files that will be affected)
 
# 8: If the phone goes offline, and the associated nodes disappear, 'tracklist' focus should probably switch to whichever node comes in focus (I suppose it would make sense for focus to switch to the Parent of the inaccessible node.

Note: the logic for this should probably be the same logic that is used when other nodes disappear. e.g. if the user deletes a node that is currently in focus.

# 9: filter to show only MM-synced content [Possible future enhancement]

Ludek

2019-09-06 15:05

developer   ~0054524

Last edited: 2019-09-06 15:07

View 4 revisions

Mostly fixed in 2195.

Just re #1 and your question re moving Profile-specific Settings directly into the Profile settings screen.

I guess that all the profile specific settings already is under the [Options] tab, so I just renamed the tab to [Profile settings]

Let's review this in 2195 -- the only strange thing now is that the [Profiles settings] tab has a 'Profile settings' sub-panel that includes the Import/Export buttons.
So we might want to rename the panel to 'Import/export' or something like this ?

Ludek

2019-09-09 12:04

developer   ~0054558

Last edited: 2019-09-09 12:05

View 2 revisions

All settings on the [Options] are part of the profile (including auto-conversion).

BUT while checking this I found that more than this is part of the profile.
Also some user specific settings like whether to scan on connect, folder to sync content back, whether to delete content etc. are part of the profile!
So I guess that we should just adjust this and ensure that we save/load (from *.MMDC) just all the items that are on the [Options] tab -- and not any others (as all the other settings on the other tabs are user specific settings).

Do you agree?

rusty

2019-09-09 13:32

administrator   ~0054560

Yes--it should be obvious which settings are part of the 'profile'. The only question is whether some of the settings you describe _are_ profile-specific and not in the 'profile settings'. Specifically,
- are there 'devices' for which additional folders need to be pre-configured in the 'Auto-Sync (--> Library)' settings ?
- is 'Auto-sync file metadata from the device to the PC' a 'Device profile'-dependent setting?

BTW, I also agree with your previous comment that we shouldn't have 'Profile settings' both in the tab and in the panel. Perhaps:
Tab: Device/Service profile
Panel: Manage settings

Ludek

2019-09-09 16:27

developer   ~0054563

Last edited: 2019-09-09 16:29

View 2 revisions

Fixed in 2196.

i.e. corrected the wording + adjusted loading/saving *.mmdc to keep just the values under the [Device/Service profile] tab.
I believe that 'Auto-Sync (--> Library)' settings is user-specific and shouldn't be part of the profile, but we can adjust later (if we find it as not desirable)

peke

2019-09-14 20:53

developer   ~0054649

Verified 2197

Verified Wording, much clear now, also verified Import/export that as Ludek said no user specific settings are Exported/imported

rusty

2019-09-15 19:06

administrator   ~0054653

Minor tweak.

Currently the tabs indicate:
Auto-Sync (-->Device) and Device/Service profile

Would it be possible to use text that matched the device/service? e.g.
For devices: Auto-Sync (-->Device) and Device profile
For services: Auto-Sync (-->Service) and Service profile

Ludek

2019-09-16 09:31

developer   ~0054656

Last edited: 2019-09-16 09:53

View 8 revisions

Shouldn't we use the word "Target" (as we use in the other places)?

So it would be "Auto-Sync (-->Target)" and "Target profile" ?

EDIT1:
Note that for cloud profiles we don't have the [Auto-Sync (-->Service)] tab at all, we have only [Remote content], [Library Content], [Device/Service profile] as suggested elsewhere.

EDIT2: I see that we have already eliminated also the "Target" terminology and replaced it by the device/service name, see 0014983
So with that in mind the tabs should look like
[Remote content], [Library Content], ['Google Drive' profile] -- for clouds ('Google Drive' in this case)
[Summary],[Auto-sync (-->Device)],[Auto-sync (--> Library)]['G6' profile] -- for devices (LG G6 phone in this case)
??

But maybe for the tab name we shouldn't use the exact device/service name, but rather generic 'Device' and 'Service' as you suggested.
i.e. [Service profile] for cloud services and [Device profile] for device storages.
=> Adjusted in 2198

-----------------------------------
Another choice is to use just generic [Sync profile] as the tab name? This would make most sense as the heading text below indicates: "Sync profiles contain default settings that allow a device or storage location to sync correctly. They don't include user-settings such as which content will sync."

Thoughts?

rusty

2019-09-16 20:31

administrator   ~0054660

"Another choice is to use just generic [Sync profile] as the tab name?"

Yes--that's probably simplest.

Ludek

2019-09-17 09:03

developer   ~0054661

OK, changed to [Sync profile] in 2198

rusty

2019-09-20 20:59

administrator   ~0054757

Verified 2200.