View Issue Details

IDProjectCategoryView StatusLast Update
0015344MediaMonkey 5Tagging / organizing (properties / auto-tools)public2020-11-12 23:30
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015344: Auto-tag: Dynamic Sorting makes it difficult to edit tracks
DescriptionFrom uu) at #14224:
If the user changes a value of the 'Album' field --> the entry is moved and it's difficult for the user to find it to continue editing the track (especially if a large number of tracks are being auto-tagged).

When the user edits Album Name, the sort order changes even though the Artist/Album Artist hasn't changed (and the original sort seems to be by Artist). e.g. Change the Album for 'Tequila' by 'The Champs' --> no change in Artist/Album Artist, but the Track moves towards the bottom of the list! Could it be that initially tracks are sorted by Artist and Prefixes are ignored, and then on changes prefixes aren't ignored?

 not only does its position in the list change, but the sort order of the entire list changes! This is a problem since if a user has reviewed tracks 1-10, and then tracks b,c,d are inserted among tracks 1-10, the user won't realize that s/he hasn't reviewed those tracks!
 
 See video at https://www.screencast.com/t/3qEZJWhO8 .

I would suggest that tracks shouldn't be dynamically sorted in this dialog (they should be resorted _only_ if the user presses F5 or clicks a sort arrow).
TagsNo tags attached.
Fixed in build2259

Relationships

related to 0015185 resolvedLudek Scroll to match doesn't find all matches (and improvements) 
related to 0015464 closedpetr Auto-tag: dialog can't be used effectively while lookups are in progress 

Activities

petr

2019-01-31 13:27

developer   ~0052358

Fixed

rusty

2019-02-01 03:10

administrator   ~0052368

Tested 2154. The original problem seems to be resolved (i.e. when the user makes edits to tracks, they are now not resorted/regrouped on the fly). In addition, a message appears:
'Press F5 once you are finished with editing to regroup tracks to albums.'

The message should:
a) Appear as a toast rather than as a persistent message
b) Appear using standard formatting/font (i.e. a nicely formatted toast)
c) Be simpler: 'Press F5 to re-sort/re-group tracks'
d) Only appear when relevant i.e. if the edit actually results in a change that affects sorting/grouping, rather than on every edit.

Test note: this is a separate issue, but if this approach works well, we may want to do something similar for Playlist re-ordering with ALT-F5.

petr

2019-02-01 10:16

developer   ~0052374

Fixed

rusty

2019-02-08 03:01

administrator   ~0052487

This is working fine in 2156. However, the implementation seems to be different from that which is implemented for contextual search (powerscroll). Is it possible to rationalize the two toast implementations so that it looks/works the same in all cases?

Note: if you prefer to defer this, we can open a new bug to take care of this in the future.

petr

2019-02-08 10:03

developer   ~0052503

Fixed

rusty

2019-02-10 05:00

administrator   ~0052523

Verified 2157.

rusty

2019-02-14 05:46

administrator   ~0052623

This issue has been re-introduced to 2159.

petr

2019-02-14 08:16

developer   ~0052628

Fixed

rusty

2019-02-15 21:45

administrator   ~0052652

Verified 2160.

rusty

2020-06-30 01:15

administrator   ~0058683

This behavior has reverted (tested 2258).
https://www.screencast.com/t/zMZRM5YVO

petr

2020-06-30 18:24

developer   ~0058690

Fixed

peke

2020-06-30 23:11

developer   ~0058695

Verified 2259

It correctly resorts on pressing F5

peke

2020-11-12 23:30

developer   ~0060162

Re verified 2273

No additional regressions found it behaves as designed.