View Issue Details

IDProjectCategoryView StatusLast Update
0017045MediaMonkey 5Main Panelpublic2021-02-17 08:24
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017045: Auto-focused media tree node is often out of view (regression in 2270)
DescriptionAuto-focusing of media tree node either with "Focus tree nodes when browsing content" enabled or when performing incremental search on nodes with many items (like expanded Album node) often ends up that the focused media tree node is out of the view (auto-scroll to focused item is broken)

Details at: https://www.mediamonkey.com/forum/viewtopic.php?p=474248#p474248
TagsNo tags attached.
Fixed in build2273

Relationships

related to 0017009 closedpetr Track Browser: Selection Using keyboard do not scroll View 
related to 0016995 closedLudek Now playing: Playlist position view not persistent on D&D 
related to 0017568 closedLudek Shift+Arrow select doesn't scroll the window when the selection moves off current view (regression) 

Activities

Ludek

2020-11-03 18:37

developer   ~0060051

This regression has been introduced while fixing 0016995 in build 2270 (also 0017009 was regression of 0016995)

Ludek

2020-11-03 18:54

developer   ~0060052

Last edited: 2020-11-03 19:11

View 2 revisions

Fixed in 2273

Note that I fixed also 0017009 that hasn't been fully fixed in 2271 (the last item was still behind the edge -- only the last but one item was visible when pressing Down arrow in a list view or tree view)

peke

2020-11-08 00:14

developer   ~0060083

Verified 2273

Unable to reproduce in 2273 auto focus is correct.