View Issue Details

IDProjectCategoryView StatusLast Update
0012371MediaMonkey 5[All Projects] Generalpublic2019-10-28 20:47
ReporterLudek 
PriorityurgentSeverityfeatureReproducibilityhave not tried
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version5.0 
Summary0012371: Search bar functionality
DescriptionAdd search bar to MM5 with full text search (similar to MM4)
TagsNo tags attached.
Fixed in build2196

Relationships

related to 0015549 closedLudek Contextual Search (Filter): Collection nodes searches shouldn't appear in Global Search bar 
related to 0014293 resolvedLudek Filtering fixes and improvements 
related to 0015959 closedLudek CTRL-F triggers a view switch before the search is initiated 
related to 0015615 closedLudek Clicking cancel in the search bar should return to previous view 
related to 0015910 closedpeke Advanced search does not give accurate results sometimes 
related to 0016062 resolvedLudek Search: filters always switch to List view 
related to 0016067 feedbackLudek Clarify Search Terminology and UI 

Activities

Ludek

2014-12-05 23:11

developer   ~0041347

Implemented

peke

2019-02-11 12:34

developer   ~0052559

Last edited: 2019-02-11 12:38

View 2 revisions

Verified 2157

Search Bar working as implemented.

peke

2019-02-11 12:38

developer   ~0052560

2. I would also change "Filter: OFF/ON" to "Advanced Search Filter: Off/On" as it is more clear what it do even we do not Change Search tips in point 3.

3. I would only add additional line in Search Tips
"Right click on Search icon to get Advanced search or Options"

ATM it is not fully clear how to get into Advanced search or Setup what metadata will be searched thru search bar.

peke

2019-02-12 03:32

developer  

Ludek

2019-02-25 11:34

developer   ~0052791

Last edited: 2019-02-26 12:49

View 2 revisions

2) I agree with Peke that "Filter: OFF/ON" is currently confusing and should be changed to "Advanced Search Filter: Off/On"
see: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93931#p456087

Another reasons / feedback:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93847&p=455673
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93936&p=456123#p456123

Ludek

2019-02-26 12:55

developer   ~0052808

Last edited: 2019-02-26 12:59

View 2 revisions

The current wording 'Filter on/off' is problematic because:
1) it is not clear that it is a toggle
2) it is not clear that it switches between MM4 like advanced search and standard search
i.e. MM4 users using Ctrl+F in MM4 (or menu Edit > Search in MM4) are not aware how to achive this kind of search
see: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93847&p=455673&hilit=search+edit#p455673
3) The word "filter" is ambiguous

I would suggest to change 'Filter: on/off' to a button
e.g. show [Advanced] button and upon clicking it -- it would bring the search editor and the button caption would change to [Simple] ?

Ludek

2019-02-27 09:42

developer   ~0052813

Last edited: 2019-02-27 12:37

View 3 revisions

A good suggestion is here https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93936&p=456151#p456141

"filter:off" button does what the new "funnel" toolbar button does in the other views.
So unifying the "filter:off" button with the "funnel" toolbar button makes perfect sense for consistency.

The only remaining downside of this is that MM4 users are not aware how to achive this kind of search
i.e. that MM4's menu Edit > Search will be available via the "funnel" toolbar button in MM5.

Solution could be to rename current menu [Edit > Search (Ctrl+F)] to [Edit > Advanced search] that would bring the search view (already opened in the advanced mode)?

Ludek

2019-02-27 13:13

developer   ~0052818

Last edited: 2019-02-28 17:05

View 2 revisions

Another complaint is that search bar is missing close button (to clear the search term)
=> added the close button in build 2164

rusty

2019-03-15 14:14

administrator   ~0052976

2) I agree that the Filter: On/Off functionality as it relates to Global Search is confusing, but I don't think that a change in wording is the solution. To summarise the issues (most of which Ludek has already written):
. 1) It's not clear that it's a toggle
. 2) It's not clear that it activates/disables advanced search
. 3) Filter in this context is ambiguous, because Filters (Funnel icon) by definition apply to any view, and yet when the user initiates an advanced search, and user turns Filter to 'on', MM isn't actually creating a Filter (in the Funnel icon sense). The UI makes it appear as if a filter is being created, but other cues (forced selection of a Collection/Entire Library) conflict with that (since a Filter should apply to _all_ views).
Net result in that with Advanced Search and filter:on , it's unclear whether the filter or search is being configured.
. 4) The UI isn't consistent with Filtering functionality in other views. i.e. other views use a filter icon in the toolbar to turn the filter on/off.

 So the root issue is that it's possible (and desirable) for Global Search and Filters (in the Funnel icon sense) to be integrated, but not for Advanced Global Search and filters to be integrated.
 
With the above in mind, the simplest solution would be:
A) Get rid of the 'Filter:off' button entirely (since Advanced search is already available via the context menu)
OR
B) As suggested by Ludek, to change Filter:off to an 'Advanced search' button (I'm not even sure that a toggle is required,)

For either A) or B) Filter (Funnel icon) functionality should be available for Global Search (but not Global Advanced Search).

C) An alternative (and I think preferable solution) that would clarify filters vs search AND unify the filtering implementation was alluded to in 0015077 item F I). There I mentioned that if we implement Search as a toolbar, there would be room to include and explain filtering. i.e.:

CTRL-F/Search Button --> Search bar appears. It would look something like this:
___________________ [Current View] [Find all] [Scroll to] . . . . . . . . . . [Advanced search...]

D) A further refinement to C) would be to integrate Filtering into this UI so that the Filter icon can be eliminated from the toolbar (but not from the breadcrumbs). i.e.

CTRL-F/Search Button --> Search bar appears. It would look something like this:
___________________ [Current View] [Find all] [Scroll to] . . . . . . . . . . [Advanced search/filters...]


Clicking 'Advanced search/filter...' --> the advanced search settings display but the first couple of lines are modified as follows:
 ( ) Filter view . . . . . . . . . . . . . . [Save as filter...]
 (o) Search library: __Entire library_^_ [Save as Auto-playlist...]

Match __all__ of the following criteria: +
...
...
...
 
- The Filter/Search selector would not be shown when an already created filter/playlist is shown
- As before, whenever a Filter is enabled, it appears in the breadcrumbs
- This approach would also require the following change to the Search context menu:
. - Remove 'Advanced search' (it's on the search bar)
. - Add: Filter view > choice of filters
- I would suggest that 'Save as filter...' should be an option (in the future?) user can save filters with short names (that won't take up too much space in the breadcrumbs) rather than just have an MRU list of filters.


4) 'Close button' appears even on a brand new search. e.g.
1 Execute a global search
2 Navigate to Music > ....
3 Initiate global search (i.e. press the magnifying glass, but don't complete a search)
---> The 'x' button appears even though the Global Search field is empty!!


5) An issue related to the above is that if the user performs a global search then using the filtering functionality breaks:
1 Execute a global search for 'beatles'
--> results appear
2 Click 'Home'
3 Right click on the search icon > Advanced Search
--> Breadcrumbs bar shows '[Search icon] Any text fields contains 'beatles''
--> But search results are empty!


6) Doing a Global Search and then enabling the 'Filter' On/off keeps causes the position of the tracklist to change!

Ludek

2019-03-20 16:58

developer   ~0053037

Last edited: 2019-03-21 13:14

View 4 revisions

I don't think that adding __ [Current View] [Find all] [Scroll to] . . . . . . . . . . [Advanced search...]
would clarify something, I am afraid it would add further confusion (e.g. what is "find all" ? , what is "scroll to" ?)

Funnel icon on toolbar is fine, other apps also uses toolbar as placement for the funnel icon

From what I have read on the forums there are two types of user's confusions:
- MM4 users: they are confused why menu Edit > Search isn't doing what it used to do in MM4
- both MM4 and MM5 users are confused by the 'Filter: off' text (and don't know that it is clickable at all)
- MM5 users are confused why the 'funnel' icon is missing from the toolbar in the search view and hardly realize that they need to click 'Filter: off' text

It can be resolved by:
i) replace menu 'Edit > Search (Ctrl + F)' by 'Edit > Advanced search' that opens global advanced search (like in MM4)
ii) change 'Filter: off' text to 'Add further criteria' or 'Switch to advanced' link (toggle not needed probably?)
iii) add 'funnel' icon to the toolbar for search view too

=> Fixed in 2167

rusty

2019-06-19 17:22

administrator   ~0053894

Last edited: 2019-07-16 17:50

View 3 revisions

I haven't tested this extensively, but noticed a couple of small issues:
1 Global search for 'U2'
-->
1) Search results appear with option to 'Switch to advanced'.
. . Toolbar shows the 'Filter' icon which in this context does the same as 'Switch to advanced' but is confusing
. . because it looks like there are two different commands, but they both do the same thing.


2 Click the 'Filter' (=Advanced Search) icon
--> 2) Search bar (that had contained an 'x' to exit the search) is removed, so now there is no means of exiting the search! Possible options could be to retain the search bar OR to add an 'x' to the advanced search config area.
Another possibility would be to just get rid of the concept of 'Advanced search' altogether, and instead allow filters to apply to Searches. Then filters could be closed as they usually are, and the Search can be terminated as usual.

The above are relatively minor issues that we can defer until we get more feedback.

3 Type CTRL-F while search results are displayed
--> User would expect a new Global Search to initiate, but nothing happens!

Ludek

2019-06-20 11:04

developer   ~0053906

1&2) ok, lowered priority for these items

3) I cannot replicate, for me pressing Ctrl+F while search results are displayed always opens the search bar and starts new search.
Couldn't this be a test error or testing an older build?
Or maybe it happens only in certain scenarios? Catching this in YT video could probably help.

rusty

2019-06-20 14:19

administrator   ~0053913

3) I can't seem to replicate this ?!

4)a) UI: Criteria shouldn't be highlighted on hover (auto-playlists & advanced search)
b) UI: Sorts shouldn't be highlighted on hover (auto-playlists & advanced search)

5) Sorts: Should have a separator between sorts. i.e.
Sort by: Random - Title A..Z - +
-->
Sort by: Random - then Title A..Z - +

Ludek

2019-06-21 19:37

developer   ~0053922

Items 4a, 4b are fixed in 2184

Ludek

2019-07-02 09:46

developer   ~0054067

Last edited: 2019-07-02 15:27

View 2 revisions

6) in the 'Entire library' mode context the search term is twice in the breadcrumbs.
On this screenshot ( https://www.dropbox.com/s/k5parsburb0whek/advanced%20search%20menu%20option.png?dl=0 ) the "hap" is there twice (once in the search bar and once outside of it.

Item 6 is fixed in 2186.
Items 1,2,5 remains.

rusty

2019-07-16 19:22

administrator   ~0054159

Re. item 1) The issue of confusion confusing between filtering and global search can be eliminated by implementing them identically. The only real differences between filtering and search is that:
- Search always applies at the home node / filtering works on any code
- Filters persist automatically / Searches can be saved as playlists
The changes to resolve the inconsistencies are:
a) Item 2) Add an 'x' to the Search icon so that search can be disabled in exactly the same way as filters are disabled.
b) Have common behavior for editing the filter/search. i.e. currently the user can click the filter text in the breadcrumb bar to open up the filter. Similarly clicking the search term should open the advanced search config.
c) Display search/filters in the same way in terms of scrolling i.e. currently filters persist at the top of the view, whereas Advanced Search scrolls off the top of the view. Have them both scroll.
d) Make the behavior of the filter icon consistent across both functions. Currently:
- Search: filter icon enables advanced search and doesn't disable it
- Filter: filter icon opens/collapses the filter
If b) and a) and c) are implemented, then the filter icon can be eliminated almost entirely since
- Search: clicking the search term shows advanced search / clicking the 'x' on the search icon disables it / scrolling hides it
- Filter: clicking the filter enables it / clicking the 'x' on the filter icon disables it / scrolling hides it
e) Remove the 'Save' icon from the menu bar. Instead add 'Save as playlist...' on the upper-right side of the advanced search menu (just as Filters are managed from within the upper-right portion of the filter config).

Ludek

2019-07-29 12:56

developer   ~0054228

Further feedback related to this topic is here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94838

Ludek

2019-09-03 17:28

developer   ~0054508

Last edited: 2019-09-03 17:29

View 2 revisions

Fixed in 2195.

i.e. view filtering and advanced search are now unified (per notes above)

rusty

2019-09-08 02:51

administrator   ~0054544

Tested 2195 and there seem to be a number of issues:

b) the Filter button doesn't appear consistently. e.g.
- navigate to Music > ArtistName --> Filter icon displays
- navigate to Home > ArtistName --> Filter icon doesn't display

f) If the user applies a filter to a view and then initiates a global search, the filter should no longer be applied (i.e. Global Search _replaces_ the current view/filter)

h) Search for Year:1980 --> breadcrumbs bar shows "year: year: 1980" and no results appear!

i) In Music>Genres>Alternative Rock, initiate contextual search for 'Beatles'; Activate Filter; Type 'Smith' to trigger a contextual search --> crash Log ID: A04CA890
This crash can be replicated consistently.
Screen shows: Music > Genres > Alternative Rock > Filter: Any text fields contains "beatles". . Search _smith_ (note: this is the contextual search box)

j) Filters are sometimes applied when they shouldn't be. e.g.
1 Navigate to Music > Genres > Alternative and apply a filter "talking"
2 Close the filter
3 Initiate Global Search for Beatles
4 Press ESC to terminate the Global Search
--> Music > Genres > Alternative > Any text field contains 'talking' !! (the filter shouldn't be active)
note: step1 isn't exactly right. I'm not certain what exactly causes the filter to re-appear--it might be that it needs to be first opened via a Global Search. I can replicate the problem quite often...just not 100% certain of the trigger.

k) Global searches sometimes fail in the following manner (it's not consistent but it often seems to occur after a contextual search has been done)
1 CTRL-F and type Beatles
-->"Beatles" appears in the Global Search text box
2 Press ENTER (right away)
--> Home > [SearchIcon] "les" appears
--> No search results appear (i.e. the page appears as if the user just clicked 'Home'

Note: although this doesn't occur consistently, I've noticed it at least 5-10 times over the course of testing Search/Filtering for an hour. Sometimes it even occurs _without_ pressing ENTER!!

Ludek

2019-09-09 11:20

developer   ~0054556

Last edited: 2019-09-10 20:03

View 4 revisions

m) one more related issue mentioned here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95044

Ludek

2019-09-10 19:57

developer   ~0054581

Last edited: 2019-09-11 14:11

View 9 revisions

Items b,f,h,i) + crashes A04CA890, C4919FC7 fixed in 2196

j) filters are saved in history (per item 1 in 0014293), but you are true that step 2 should clear the filter permanently
=> fixed in 2196 (this fixes also the item m) reported on the forum)

k) I cannot replicate, but might be fixed by fixing the other items, let's re-open if you still see it.


Note: view filtering does not work correctly for the "Entire Library" sub-nodes, e.g. [Entire Library > Artists > U2]
But this will be fixed as item 17) here: 0014293 -- as it is not related to the searchbar

peke

2019-09-13 21:56

developer   ~0054642

Verified 2197

Also Confirming that fixing 17) from 0014293 fixed majority of erratic behavior I have mentioned in Thread.

Test Note j) History is available in ?