View Issue Details

IDProjectCategoryView StatusLast Update
0016062MediaMonkey 5Playlist / Searchpublic2019-12-02 22:10
Reporterrusty 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016062: Search: filters always switch to List view
DescriptionIn 0015910, Peke indicated that if the user switches to 'Advanced' for a Global Search, it's impossible to return to 'normal' (non-advanced) search results that group content. i.e.
1 Global search for 'moon'
--> results appear in browser view (grouped by Artists, Albums, Videos, Playlists, Tracks)
2 Press Filter icon
--> Filter criteria appear
--> Only a list view of tracks is shown (even though Browser view is still active)
3 Press Filter icon again
--> Filter criteria collapse (though the filter is still active)
--> Only a list view of tracks is shown (even though Browser view is still active)!

So there appear to be 2 issues above:
1) when a filter is active, it causes view settings to be ignored. I believe that we implemented it in this manner because
a) filters can be saved as playlists, and it is only the list that is saved
b) filter results that include Artists/Albums/etc. can be ambiguous because e.g. an Artist can be representative of _all_ tracks by the artist or only those tracks by the Artist that also match the filter.

These don't seem to be a valid arguments though, because this exact functionality is already working well in other parts of the product e.g. in Genres:Accoustic Rock, the user can set a filter, and groupings of Artists and Albums appear (and any ArtistName / AlbumName represents only those tracks that match the filter. And this can be saved as an AutoPlaylist.
 
2) there's no way to revert from a filtered view to the Global Search that spawned it.
Assuming we fix the first issue, this becomes a moot point since, once fixed, Filtered Views will not revert to list views.

This isn't a huge issue, documenting it for your to triage.
TagsNo tags attached.
Fixed in build2219

Relationships

related to 0012371 closedLudek Search bar functionality 
related to 0016157 feedbackpeke Advanced search: Initiating Advanced search is not unified 

Activities

Ludek

2019-12-02 22:09

developer   ~0055585

Last edited: 2019-12-02 22:10

View 2 revisions

Fixed in 2219