View Issue Details

IDProjectCategoryView StatusLast Update
0015549MediaMonkey 5Playlist / Searchpublic2019-07-18 15:27
Reporterrusty 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015549: Contextual Search (Filter): Collection nodes searches shouldn't appear in Global Search bar
DescriptionRe. #12521 item 7) we'd decided that contextual search filtering should work on Home, Music, etc. nodes.

Normally, when the user initiates a contextual search, the textbox appears within the Breadcrumbs bar, signifying that it is within the context of the node.

When we implemented contextual search filtering for Home/Collection nodes, though, the Search text always appears in the Global search bar. This makes sense for the Home node (since it's a Global search), but it doesn't make sense for other Collection nodes in which the search is limited to the context of the node.

Note: if we implement the Search Bar as proposed at 0015077 F I), then we could either display the search bar always for contextual searches, or never (the latter being the preferred approach, I think).
TagsNo tags attached.
Fixed in build2167

Relationships

related to 0012371 closedLudek Search bar functionality 

Activities

Ludek

2019-03-20 17:21

developer   ~0053038

Fixed in 2167

rusty

2019-07-18 15:27

administrator   ~0054161

Verified 2186.