View Issue Details

IDProjectCategoryView StatusLast Update
0004826MediaMonkey 4Otherpublic2008-12-30 23:50
Reporterpetr Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.1 
Summary0004826: Customizeable toolbars
DescriptionMany programs have a functionality for customize toolbars (add/delete toolbars, define buttons on it etc.). MediaMonkey haven't this feature and some users mentioned that it's necessary for comfortable use of MediaMonkey.
Tagsdoc_help
Fixed in build1205

Relationships

related to 0005012 closedpetr Some polishing of Toolbar Configuration 
related to 0004980 feedbackpetr Configurable toolbar of Now Playing window 
related to 0000628 closedpetr Configurable Toolbar for Shortcuts (favorites) 
related to 0005035 assignedpetr Configurable toolbar for Categories 
parent of 0005111 newpetr Toolbar Buttons added thrum Scripts can't be Customized 
has duplicate 0000090 closedpetr Configurable Toolbar 
related to 0004838 closedLudek No easy way to hide/show Music Tree 
Not all the children of this issue are yet resolved or closed.

Activities

petr

2008-09-03 16:06

developer   ~0014523

Added into 1186.
Toolbars can be configured using right-click on top toolbars dock and selecting 'Configuration'.

For adding of the new buttons into toolbar simply use D&D from right panel to the left.

I also added 2 new actions (in General section) :
1. Run Script - user can define script/procedure to run using this button
2. Auto-Organize Using Mask - user can define mask and using this button he can immediately organize selected track without need to open Auto-Organize dialog.

stephen_platt

2008-12-04 03:43

developer   ~0015359

Verified 1199

rusty

2008-12-12 16:24

administrator   ~0015619

Last edited: 2008-12-12 17:02

1) Customizable toolbars functionality often causes an MM freeze. Here's how to replicate:
-Expand a Toolbar on the toolbar config dialog
-Select an Action in the toolbars column, and drag it onto itself
-->MM will freeze up (CPU locked at 50%, task manager needed to exit)

2) Actions are draggable _on top_ of existing actions. Wouldn't it make more sense to only allow them to be dragged between existing actions?

3) Several toolbars are missing. Is this intentional?
-Shorcuts
-Search
-Categorize
-View

petr

2008-12-12 18:29

developer   ~0015624

Item 1&2 are fixed in 1203.
Also because of some complications leaving item 3 for post 3.1

rusty

2008-12-12 18:45

administrator   ~0015626

I'll add a new bug re 'Categorize' toolbar. Others are already covered.

peke

2008-12-30 02:12

developer   ~0015850

1, 2 Verified 1205

peke

2008-12-30 02:13

developer   ~0015851

4. Adding/creating new toolbar icon UI.AddMenuItemSub( UI.Menu_TbCategorize, -1, 1) thru scripts is not in customization of toolbar order. Possible solution would be to use SDBMenuItem.Caption as Reference for Customization or even better make something Like Firefox Toolbar Customization Uses?

I think it is post 3.1

rusty

2008-12-30 22:06

administrator   ~0015880

Resetting to Resolved. The issue that Peke raises can be tracked as a new issue for a future release.

peke

2008-12-30 23:50

developer   ~0015891

Verified 1205.

Others are moved to new bugs.