View Issue Details

IDProjectCategoryView StatusLast Update
0000090MediaMonkey 4Main Panel/Toolbars/Menuspublic2008-12-05 03:57
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.1 
Summary0000090: Configurable Toolbar
DescriptionThe user should be able to:
a) easily re-configure toolbars with icons/commands of choice in the order desired
b) Add new toolbars or remove existing toolbars.

To achieve a) there are a couple of approaches, both of which work (see attached graphics).
- In Firefox, the user is allowed to drag and drop icons from the toolbar which is being customized. This is a clean approach, but may not work well in the context of a design in which multiple toolbars must be managed (not to say that it can't work, but it would result in a slightly inconsistent design in which Toolbars are managed within the dialog (see section b) below), but Toolbar contents are managed outside of it.
- In IE, the user modifies the selected toolbar within the customization dialog itself. This is probably the best choice for our purposes.

To achieve b) users would require something along the following lines:
---------------------------------------------------------------------
| Customize Toolbars:
---------------------------------------------------------------------
| Toolbar:
| -------------------------------------------
| | Toolbar A . . . . . . . . . . . . . . . . . [Add]
| | Toolbar B . . . . . . . . . . . . . . . . . [Remove]
| | Toolbar C . . . . . . . . . . . . . . . . .
| -------------------------------------------
| Icons:
| (Design for section a)
|
| Icon Size: _Small_^
---------------------------------------------------------
TagsNo tags attached.
Fixed in build1186

Relationships

duplicate of 0004826 closedpetr Customizeable toolbars 
related to 0004838 closedLudek No easy way to hide/show Music Tree 

Activities

rusty

2003-08-17 18:10

administrator   ~0002172

As part of this feature, the user should also be able to assign scripts to toolbar buttons. This would also imply that the user should be able to assign graphics to toolbar buttons (or we'd have to create some generic script buttons).

This would meet the need of users such as those mentioned in:
http://www.songs-db.com/forum/viewtopic.php?t=475
or
http://www.songs-db.com/forum/viewtopic.php?t=474

rusty

2003-10-30 01:07

administrator   ~0002690

Last edited: 2006-02-16 14:01

Note: ideally this should be implemented in conjunction with 0000351 (configurable hotkeys) since a single table should be used for both hotkeys and toolbars.

Update: After further reconsideration, I disagree with this thought. The two functions, though related, are very different, and a single UI combining the 2 would likely be too confusing.

2006-02-16 13:58

 

ffoxtoolbar_editor.gif (39,081 bytes)   
ffoxtoolbar_editor.gif (39,081 bytes)   

2006-02-16 13:59

 

IEtoolbar_editor.gif (25,636 bytes)   
IEtoolbar_editor.gif (25,636 bytes)   

petr

2008-09-14 20:25

developer   ~0014582

Already fixed in mantis 0004826

stephen_platt

2008-12-05 03:57

developer   ~0015410

Verified 1199