View Issue Details

IDProjectCategoryView StatusLast Update
0005012MediaMonkey 4Main Panel/Toolbars/Menuspublic2009-02-19 22:30
Reporterjiri Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version3.1 
Summary0005012: Some polishing of Toolbar Configuration
DescriptionToolbar Configuration dialog could be slightly improved in several aspects:

1. Up/Down/Delete buttons have some internal messages assigned as Tooltips.
2. Available actions have only internal names of Categories, they should be changed to agree with how they are normally named in MM, like: CDDB -> FreeDB, Jumps -> Find more from..., etc.
3. Some categories could probably be removed.
4. Some actions should be removed:
 4a. Add to Clipboard isn't officially supported.
 4b. Others?
5. Some actions are missing icons.
6. Separator button would probably make more sense to be in Actions list (as the first or last item).
TagsNo tags attached.
Fixed in build1213

Relationships

parent of 0005117 closedpetr New icons for custom toolbar actions & Extensions 
parent of 0005203 closedpetr Custom Back/Forward buttons miss history drop down 
related to 0004826 closedpetr Customizeable toolbars 

Activities

jiri

2008-12-08 11:41

administrator   ~0015551

Assigning to Rusty to review and make suggestions re. these items.

rusty

2008-12-12 16:15

administrator   ~0015618

1. Tooltips are not required for this. We can just get rid of them.
2/3. Agreed.
a) There's no need for new names for the various categories of functionality. We can use existing strings from MM, and if an icon doesn't have an existing name, use the Context Help for the icon. e.g. Back, Forward, Go to Now Playing, etc...
b) Organization of the tree should
-Match organization of functionality in the Menu
-For items that aren't in the menu, new categories can be created when necessary, except in cases where the functionality 'fits' within an existing menu (e.g. Configure existing output plug-in).

e.g. (note: I haven't ordered the items below--ideally they should be ordered as they appear in the menus OR alphabetically. Also, I haven't made certain that the list is comprehensive e.g. I noticed that some Play commands were missing e.g. 'Play Now', but this may be because they already exist in another toolbar)

File
-Add/Rescan Tracks to the Library...
-Clear Library...
-Maintain Library...
-Export to Playlist
-Locate Moved/Missing Tracks
-Manage Filters
-.m3u Playlist --> Export as .m3u playlist (existing string)

Edit
-Change Album Artist
-New Playlist...
-New AutoPlaylist...
-Properties
-Select all
-Update Play Order

View
Minimize to tray / Maximize (how does this work if there's no icon?)
Switch to MicroPlayer / Maximize (how does this work if there's no icon?)
Switch to MiniPlayer / Maximize (how does this work if there's no icon?)
-Refresh
-Properties

Player
-Next
-Pause
-Play
-Play/Pause
-Previous
-Stop
-Stop After Current
-Volume Up
-Volume Down
-Volume Mute
-Open URL or File
-Configure current input plug-in
-Configure current output plug-in
-Setup Player


Tools
-Analyze Volume
-Level Track Volume
-Auto-Organize Files...
-Auto-Organize Using Defined Mask
-Auto-Tag from Filename
-Auto-Tag from Web...
-Get Album Info from Freedb
-Save Preview
-Synchronize Tags...
-Options...

Help
-Enter registration code for MediaMonkey
-About
-Online forum
-Help Content

Find more from same
-Album
-Album Artist
-Artist
-Composer
-Conductor
-Folder (Library)
-Folder (My Computer)
-Genre
-Year


Podcasts
-Add Directory
-Download
-Edit Subscription
-Subscribe to new Podcast
-Unsubscribe
-Update all Podcasts
-Update Directory
-Update Podcast

My Computer
-New Folder

Portable/Audio Devices
-Rebuild Device Database
-Safely remove device

Search
-Amazon
-CD Universe
-eMusic
-Google
-Info/Buy --> Amazon
-Wikipedia

Tree
-Back to previous view
-Forward to previous view
-Collapse the Tree
-Go to the Now Playing node
etc...

4) Confusing / Broken items (aside from I wasn't clear what some of these were ):

-Add to Clipboard
-Run Script button doesn't do anything
-Open in Explorer button doesn't appear and isn't really required (since we have find more from same directory in Explorer BUT that function was missing)
Get Track Details button doesn't appear. I'm pretty sure that it's deprecated.
-New .m3u Playlist button doesn't appear. Nor do I know what it is. Probably not needed?
-Play - duplicate entry isn't needed.

5. Items with missing icons are pointed out above. Hopefully we have something you can use...

6. I agree that the separator should appear on the right column and not as a button. '-- Separator --' should just be an item there.

petr

2008-12-15 11:14

developer   ~0015652

Fixed in 1203. Also missing icons for :
minimize to tray
minimize to mini player
minimize to micro player

rusty

2008-12-16 21:19

administrator   ~0015671

I didn't test a build that includes this, but I reviewed the .po files and noticed some changes weren't implemented.

For the Tree shortcuts, we should use existing strings whenever possible (almost all of the nodes already have associated text via their tooltips). If an existing string isn't available, then we should use consistent terminology i.e. Go to xxxx. e.g.
-Jump backward --> Back to previous view
-Jump forward --> Forward to previous view
-Jump to Home --> Collapse the tree
-Jump to Radio node --Change text to--> Go to Radio Node [CHANGE]
-Jump to Artist --> Go to the Artist node
Jump to Album --> Go to the Album node
Jump to Genre --> Go to the Genre node
Jump to Year --> Go to the Year node [NEW]
Jump to Now Playing --> Go to the Now Playing node
Jump to Playlists --> Go to the Playlists node
Jump to Podcasts --> Go to the Podcasts node
Jumpt to My Computer --> Go to the My Computer node [CHANGE]
Jump to Web node --> Go to the Web node [NEW]

petr

2008-12-16 21:45

developer   ~0015672

Texts changed in 1203

Bex

2008-12-28 14:16

updater   ~0015824

As reported here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35387

Find More From Same - Folder (Explorer), is missing.

petr

2008-12-28 22:44

developer   ~0015831

Added missing action. Will be in 1205

rusty

2008-12-31 05:30

administrator   ~0015913

There are 2 actions that appear to be duplicates:

File > Manage Filters
Tree > Edit Filter and Views

I don't think that the second one is required. But the first one doesn't seem to work!

petr

2008-12-31 14:11

developer   ~0015921

Removed 'Tree > Edit Filter and Views' and fixed 'File > Manage Filters'. Will be in 1206.

rusty

2008-12-31 18:39

administrator   ~0015927

Tested 1207 and there are a few more items that should be changed:

Available Actions > Other:
1) Properties: This entry should be deleted. It opens a properties window that is supposed to stay in sync with Now Playing, however, this functionality was never completed.
2) Search: This entry should be moved to the 'Search' category
3) Level Track Volume: This entry should be moved to the Tools category
4) Open in Explorer: I think that this entry can be deleted--it only seems to work for CD Tracks (I'm pretty sure that it has been deprecated / replaced in all cases by Find more from same folder (Explorer). Please confirm.
5) Get Track Details: This entry can be deleted. It looks like deprecated functionality (it's never active, and was replaced by auto-tag as far as I remember).

I think that the 'Other' category can also be deleted, since it no longer seems to contain anything (unless buttons on the default toolbars have been mistakenly categorized as other--haven't tested this).

Teknojunky

2008-12-31 18:44

updater   ~0015928

I thought that 'open in explorer' was for folders not in the library (ie my computer node).

Teknojunky

2009-01-07 19:34

updater   ~0016064

missing ability to LOCK toolbars in position to prevent in-advertent moving

rusty

2009-01-09 14:45

administrator   ~0016108

Last edited: 2009-01-09 14:46

4) Tekno's right, though we'll probably want to combine these 2 functions so that the Find More from same folder (Explorer) function also works for directories.

Jiri, any preference about how to handle for 3.1?

jiri

2009-01-11 22:41

administrator   ~0016143

Yes, it all makes sense and should be implemented in 3.1.

petr

2009-01-13 14:34

developer   ~0016177

Item 4 fixed in 1213

stephen_platt

2009-02-19 22:30

developer   ~0016714

verified 1223