View Issue Details

IDProjectCategoryView StatusLast Update
0019563MediaMonkey 5Main Panelpublic2022-11-17 22:34
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.4 
Target Version5.1Fixed in Version5.0.4 
Summary0019563: List (by Album) views: Mouse-based drag-select (lasso) selects all tracks/no tracks (regression)
DescriptionIf the user attempts to drag-select multiple tracks in a List (by Album) view, then ALL tracks below the selected tracks get selected!

The bug varies depending on whether drag-selecting up or down:
a) down: all tracks below the selected tracks get selected except for the tracks that the user intended to select
b) up: all tracks below the selected tracks get selected in addition to the tracks that the user intended to select
c) up and release mouse button above the top track: no tracks get selected
Peke:
d) Drag-Select do not work if you click on space below Summary or Album art

https://www.screencast.com/t/v62fr3LxLGtb

Note: issue c) occurs with 5.0.3, but issues a) and b) are regressions

@Peke EDIT: It only happen if click on non Track ROW Empty space eg. Colapse/Expand, Album Rating Line
TagsNo tags attached.
Fixed in build2686

Relationships

related to 0017763 closedLudek Mouse lasso selection fails when started below the list component 
related to 0019564 closedpetr List by Album: Actions can be performed on tracks other than those that are selected 
related to 0019565 assignedpetr List (by Album) views: Mouse-based drag-select (lasso) has various issues 

Activities

rusty

2022-11-15 15:57

administrator   ~0070318

Please triage

Ludek

2022-11-15 21:49

developer   ~0070328

Last edited: 2022-11-15 22:04

Regressions (a, b) fixed in 2686

c) not replicated here

d) Please enter this as another item for 5.1 (minor issue)

rusty

2022-11-15 22:07

administrator   ~0070329

To replicate c)
1 Move the cursor to an empty space to the right of the last track on an album and click hold (it could be any track though, the key is that you initiate the click in an empty space adjacent to a track, rather than below the last track)
2 Drag the lasso to a space above the first track and release the cursor
--> no tracks selected!

peke

2022-11-15 22:28

developer   ~0070330

Last edited: 2022-11-15 22:30

d) moved to 0019565

Video to replicate c) sent offline.

lowlander

2022-11-16 19:47

developer   ~0070352

Last edited: 2022-11-16 22:25

Verified a, b, c on 2686.

d) This persists on 2686.

e) A file only gets deselected when the mouse goes over the next file in the list. Instead it should be deselect as soon as the mouse leaves the file. This happens when there is empty space (because different Album between files).

----
EDIT by Rusty:
This issue is easiest to replicate when drag-selecting up and the higher album only has a couple of tracks (so that there's plenty of blank space below those two tracks). Drag select upwards to select both albums, then move the cursor down just below the two tracks of the top album ---> the second track fails to deselect!
----

f) Every time a mouse selection is made the vertical scrollbar space reservation is toggled. This is with a screen that does not require vertical scrolling. The scrollbar itself isn't show, but the space for it toggles.

g) Mouse select up may not include all files at the bottom of the selection. Not entirely sure why this is the case.
--
EDIT by Rusty: I also see this issue when Drag-selecting down. Also it only occurs when the drag starts in the blank space above or below an album (it doesn't occur if the drag starts in the blank space adjacent to a track).
--

rusty

2022-11-16 21:32

administrator   ~0070356

Last edited: 2022-11-16 22:33

h) When drag-selecting up multiple albums such that the tracklist scrolls, moving the mouse up and down to select/deselect more albums causes the point of selection to change. e.g.
1 Drag up from Album 10, and include Album9, Album8, Album7, Album6 (enough albums that the tracklist scrolls)
2 Drag down from album 6 to reduce the selection
3 Drag up to increase the selection
(repeat steps 2/3 if needed)
--> The 'selection point' changes from the bottom of album 10 to some other arbitrary location (e.g. the middle of Album 9)

Ludek

2022-11-17 15:44

developer   ~0070370

Last edited: 2022-11-17 16:06

Assigned to Petr to review what from the above is easily fixable (as the lasso selection in "List (by Album)" is Petr's code).

My inclination is that these issues are rather minor and should be fixed for 5.1 (to eliminate risk of introducing a regression right before 5.0.4 release)

rusty

2022-11-17 22:28

administrator   ~0070381

The most severe issues a) and b) have been resolved in 5.0.4. Remaining items are deferred and tracked at 0019565.

rusty

2022-11-17 22:34

administrator   ~0070382

Verified 2686.