View Issue Details

IDProjectCategoryView StatusLast Update
0019564MediaMonkey 5Main Panelpublic2022-11-30 11:33
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.4 
Target Version5.0.4Fixed in Version5.0.4 
Summary0019564: List by Album: Actions can be performed on tracks other than those that are selected
DescriptionIn the List (by Album) view, MM can sometimes fail to update selections, resulting in cases where an action is performed on the wrong set of tracks.

A) Selecting an albumX by selecting Album Art and performing an action, causes subsequent selections and actions to be performed on the wrong tracks (which tracks depends on whether the action is performed on a track above or below AlbumX):
1. Right click Album art for Album X -> Play now
--> The tracks associated with the Album plays
2a. Double click on any track from other albums _above_ or Right click -> Play now or select few tracks and right click -> Play now
--> MM plays previous selection!
2b. Double click on any track from other albums _below_ or Right click -> Play now or select few tracks and right click -> Play now
--> MM plays a completely different set of tracks!

If at steps 2a/2b, the user pressed DELETE, then MM would prompt to delete the wrong set of tracks!

Note: to get MM to stop silently selecting AlbumX, the user has to right-click on the album art of another album.


B) The converse of the above also occurs: Selecting No tracks, causes selection of AlbumX by right-clicking on Album Art to fail to select any tracks
1. Click on in an empty space in order to deselect all tracks
2. Right click on Album Art
---> Tracks appear to be selected
---> BUT all contextual options are greyed out (indicating that they're probably not actually selected)!

c) Right click Play now on Album name in summary play different tracks should behave same as Right click on Album art eg. Select all listed tracks from album and play

d) If you select track -> Right click on different album name from summary column -> Play now -> It plays selected track instead of selected album
TagsNo tags attached.
Fixed in build2689

Relationships

related to 0019563 closedpetr List (by Album) views: Mouse-based drag-select (lasso) selects all tracks/no tracks (regression) 
related to 0019571 assignedpetr List (by Album) - Performance optimizations 
related to 0019584 resolvedLudek Crash when ctrl+click on artwork in List (by Album) view (regression) 
related to 0019592 resolvedLudek Next & Previous buttons in Properties does not work in certain situations 

Activities

Ludek

2022-11-15 23:16

developer   ~0070332

Last edited: 2022-11-15 23:20

I am unable to repliacte, can you attach a screencast video please?
For me right-click > 'Play now' always plays all tracks (as expected) but starting with the right-clicked track. Maybe it somehow depends on default Play now action settings?

And maybe it depends on certain view/node? I have been in Playlist > Test [List by ALbum]
image.png (5,346 bytes)   
image.png (5,346 bytes)   

rusty

2022-11-15 23:23

administrator   ~0070334

Note: c) and d) are just variants of A) and B) that occur with the Album Summary i.e.

Like A): Selecting an albumX by selecting Album Art and performing an action, causes subsequent selections and actions to be performed on the wrong tracks
c) is just another example of this, where the subsequent selection is of the Album Summary

Like B): Selecting No tracks, causes subsequent selection to fail to select any tracks.
d) is a variant of this when a single track has been selected previously, selection of the Album Summary selects the previous track
e) in addition this also occurs exactly like B) i.e. if no tracks are selected, then right clicking on the album summary results on the context menu being disabled

rusty

2022-11-16 04:07

administrator   ~0070339

Ludek, the issue is unrelated to Playback--it can be replicated by selecting tracks in the manner described and performing any action. e.g. an alternative version of A) is:
1. Right click Album art for Album X -> Copy
2a. Right click on any track from other albums _above_ and choose Delete
--> MM prompts to delete the tracks from Album X!

I tested and replicated in both Playlist and Genre nodes. Hopefully the video will provide some indication of why it occurs for me but not on your system:
https://www.screencast.com/t/B7sf8VoGCLAr

Ludek

2022-11-16 10:41

developer   ~0070342

OK, the reason why I couldn't replicate was that I was testing on current 5.1 sources (SVN Trunk).
If I am testing on 5.0.4 sources then I see the same issue, i.e. it must have been already fixed by another fix for 5.1, to be found what it is...

Ludek

2022-11-16 11:59

developer   ~0070346

Fixed in 5.0.4.2686

lowlander

2022-11-16 19:59

developer   ~0070354

Verified on 2686

rusty

2022-11-16 21:10

administrator   ~0070355

Last edited: 2022-11-16 21:12

In my environment, issue A is fixed, but issues B, c/d/e, still occur i.e.

B) Click on an empty space and then right-click on Album Art to issue a command --> context menu entries are disabled!

c/d/e) When right clicking on the album Summary to perform a contextual action --> in all cases the action is performed on whatever is or isn't selected prior to right clicking on the album summary (i.e. album summary never causes the contained items to become selected, even though contextual commands may be enabled). Possible fixes:
- fix selection
- always make it disabled (less preferable, but if it's too difficult/risky to fix, it's preferable to the current implementation)

Please triage. From my perspective B) can probably be pushed, but c/d/e can result in inadvertently performing actions on the wrong tracks.

petr

2022-11-17 09:16

developer   ~0070362

Fixed

rusty

2022-11-17 20:28

administrator   ~0070375

Last edited: 2022-11-17 20:42

Tested 2687, and verified B) , and c/d/e.

But there's a regression:
f) Right clicking on tracks in the List(by Album) view no longer works at all if the user has previously right-clicked on Album Art!
1 Genres > Rock [List (by Album):default sort
2 Right click on an Album Art image
3 Right click on a Track (as opposed to Album Art or Album Summary)
--> No context menu appears!

petr

2022-11-17 20:51

developer   ~0070376

Fixed

peke

2022-11-17 22:17

developer   ~0070380

Verified 2688

Unable to replicate f)

rusty

2022-11-17 22:52

administrator   ~0070383

Verified 2688.

lowlander

2022-11-18 00:01

developer   ~0070385

g) Now when you right click in Artwork or Summary the files belonging to the Album get selected. However this doesn't work for left click anywhere on the Artwork column. Instead when left click on Artwork the files briefly flash as being selected, but ultimately don't show selected.
Ideally I think that the empty space under Artwork and Summary next to the files of the Album would also allow selection (neither right nor left click do currently).

petr

2022-11-18 07:22

developer   ~0070393

Fixed

rusty

2022-11-18 12:46

administrator   ~0070395

Verified 2689.