View Issue Details

IDProjectCategoryView StatusLast Update
0018183MediaMonkey 5Main Panelpublic2022-06-28 13:46
Reporterpeke Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Fixed in Version5.0.2 
Summary0018183: Bookmarking visual presentation in now playing is wrong
DescriptionBookmarking visual presentation in now playing is wrong hen enabled for tracks that have Played # > 0

1) Bookmarking Progress in Now playing is not shown after enabling it in options till view is refreshed

2) Bookmarking progress shows full for tracks that do not have bookmarking info and have Played # > 0
Steps To ReproduceEasiest way to replicate is to:
1. Add several tracks that have Played # > 1 of type that have no bookmarking enabled (Like Music)
2. Go to Options -> Playback rules -> Music
3. Enable Bookmarking -> OK
4. Now Playing is not showing Playback progress as expected
5. Clicking on Track browser and back to Now Playing updates view, but all tracks that have Played # > 0 show playback progress full even tracks actually do not have any bookmark value. Expected to be empty as no bookmark info is recorded for those tracks (2)
6. Go to Options -> Playback rules -> Music
7. Disable Bookmarking -> OK
8. Now Playing still showing Playback progress instead of removing it from view (1)
TagsNo tags attached.
Fixed in build2500

Relationships

related to 0017937 closedrusty Now Playling: Podcast Playback progress is shown only on Stop Event when Played is updated 
related to 0016166 closedLudek Played mark for already played episodes 
related to 0016227 closedpeke Podcasts: UI Feature Tweaks for better presentation 

Activities

michal

2021-08-02 10:54

developer   ~0064347

2) is by design, 0016166

peke

2021-08-02 13:22

developer   ~0064348

Last edited: 2021-08-02 13:27

View 2 revisions

2) If bookmarking info is missing it should show Empty as for those tracks bookmarking was never used, you are right implementation of 0016166 works as designed. Only case this refers to is when there is no bookmarking information on properties.

2a) Maybe we should add some sort overlay so that it is clear taht Track is already fully played, but also make clear what current bookmarking position is eg. something like outlined full progress bar that will indicate that tracks was already played fully previously, but inside of it have bookmark position similar to what is covered in 0016227

michal

2021-08-02 18:31

developer   ~0064350

1) fixed in build 2500.

2) won't fix, it is by design and bookmarking info is always reset to zero after playback was finished, there is no difference between played file when bookmarking was on, and played file when bookmarking was set on later.

peke

2021-08-02 19:59

developer   ~0064351

Last edited: 2021-08-02 20:07

View 3 revisions

2) You are correct when there is Bookmarking info, but when it is missing it shows as full instead of zero. See attached picture.
EDIT: Bookmarking is enabled later.
2a) I am asking as unless user open properties there is no way to tell if he played it fully or not eg. Bookmark progress bar is too small and some audiobooks can be 10-20h long and you cant distinguish if you played 95% or 100% we need to somehow make this happen. Assign to @Rusty if needed.

peke

2021-08-02 19:59

developer   ~0064352

bug18183_2.png (183,498 bytes)   
bug18183_2.png (183,498 bytes)   

peke

2021-08-02 20:08

developer   ~0064354

bug18183_2a.png (116,207 bytes)   
bug18183_2a.png (116,207 bytes)   

rusty

2021-10-12 19:57

administrator   ~0065138

Last edited: 2021-11-01 19:58

View 3 revisions

As far as I'm concerned, the current behavior is correct. i.e.

A) If Bookmarking is enabled prior to complete playback of a track
--> Track shows with a full bar, and counter is correctly increased by 1

B) If Bookmarking is enabled after complete playback of a track
--> Track shows with a full bar, and counter displays the correct count

Resolving for verification. Feel free to re-open if I've misunderstood.

peke

2021-11-11 12:35

developer   ~0065847

To be reviewed for 5.0.3 few users complained that files with > 0 Play count show as fully played after tehy switch from Music to Audio books.

peke

2022-04-18 23:03

developer   ~0067567

Pushed to 5.0.4

peke

2022-06-28 13:46

developer   ~0068722

Setting as resolved won't fix, except me I have not seen anyone reporting similar problem.