View Issue Details

IDProjectCategoryView StatusLast Update
0018006MediaMonkey 5Main Panel: Toolbars & Menuspublic2021-06-10 02:02
Reporterdrakinite Assigned To 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0018006: "Invalid class typecast" error dialog when mousing over Play > Play To...
DescriptionOn my device, mousing over the Play > Play To... submenu causes an error dialog to appear after some delay, saying "Invalid class typecast". No more info is given by debug logs.
May be caused by Network Discovery being turned off in Windows.
TagsNo tags attached.
Fixed in build2414

Relationships

related to 0017945 closedLudek Crash on trying to select DLNA renderer and crashes on close 

Activities

drakinite

2021-06-09 07:16

developer   ~0063839

Actually, after some more poking I found that it's actually caused when I mouse over the "Play To" section. There's just a delay, which caused me to think it was caused by toggling the checkboxes.
On line 517, that's where it shows the Exception log, but there doesn't appear to be much information around it.

Ludek

2021-06-09 08:07

developer   ~0063840

Last edited: 2021-06-09 08:22

View 2 revisions

I have finally simulated the issue, the key is to delete persistent.json and go to meny Play > Play to (or click the Cast icon on the player)

Ludek

2021-06-09 08:22

developer   ~0063841

Fixed in 2414

drakinite

2021-06-10 01:44

developer   ~0063886

Verified 2414