View Issue Details

IDProjectCategoryView StatusLast Update
0017945MediaMonkey 5Casting (Google Cast / UPnP)public2021-06-09 07:05
Reporterpeke Assigned To 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017945: Crash on trying to select DLNA renderer and crashes on close
DescriptionCrash on trying to select DLNA renderer and MM5 crashes on Close.

NOTE other Rendered name is containing e8200 as seen in Video

Log ID attached

Clean MM5 install.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=482295#p482295
TagsNo tags attached.
Fixed in build2411

Relationships

related to 0018006 closedLudek "Invalid class typecast" error dialog when mousing over Play > Play To... 

Activities

peke

2021-05-29 02:05

developer  

bug17945.png (91,517 bytes)   
bug17945.png (91,517 bytes)   

Ludek

2021-06-01 08:03

developer   ~0063650

Last edited: 2021-06-01 08:09

View 3 revisions

I think that the reason for the issue is the "Invalid class typecast" dialog seen at 0:12 on your video, but on the video there has been no [Send log] button so I can't see where this exceptions occured.
Was the test on the video performed with debug build? Could you attach debug log generated usiing DbgView started prior to MM start? I suppose that specific cast device on your network is somehow causing this exception.

EDIT: In the crash 91942329 on close there is part of the debug log (but it is on closing and is just consequence of the "Invalid class typecast" error shown at 0:12 of the video) --> that I need to see in the DbgView (where I could see also the list of the cast devices on the network). So please generate debug log.

peke

2021-06-01 22:03

developer   ~0063677

Another user reported same behavior, description updated.

michal

2021-06-03 06:39

developer   ~0063708

Last edited: 2021-06-03 07:12

View 4 revisions

Crash 91942329 already fixed in build 2411. It happened when mediamonkey.m3u8 was missing during app start. I think "Invalid class typecast" is different error.

Ludek

2021-06-03 08:31

developer   ~0063709

Yes, the "Invalid class typecast" is a different error, user is not willing to debug this further: https://www.mediamonkey.com/forum/viewtopic.php?f=21&t=99144&start=15

I've done some code review and made some changes that should prevent this + added more debug strings for sure

Fixed in 2411

peke

2021-06-04 01:57

developer   ~0063724

Verified 2411

It doesn't happen with me or the user that initially had the problem when this bug is created.