View Issue Details

IDProjectCategoryView StatusLast Update
0017849MediaMonkey 5Main Panelpublic2021-07-05 11:59
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017849: TAB key navigation can be confusing in the main panel
DescriptionWhen the user uses the TAB key to navigate, it can be confusing because:
1) Pressing TAB often results in nothing appearing to be in focus (related to 0016371 ). e.g.
a) When TABbing to the main panel for some views (e.g. Music > Albums [List (by album)] ), focus is lost. MM should show the first track as selected!
b) When TABbing to the Playing list, focus is often lost if the last selected track isn't visible. TABbing to the dialog should could the currently focused track to be displayed/in focus.

2) TAB skips some controls:
a) It would be expected that after Tabs, the second item to navigate would be the Breadcrumb/Command bar (use arrows within)
b) After the seek bar Tab should navigate to:
 - Play controls (use arrows within)
 - Ratings (use arrows within)
 - Player buttons (use arrows within)
 - Volume
TagsNo tags attached.
Fixed in build2415

Relationships

related to 0016371 assignedLudek Switching views expands / changes selection 
related to 0017844 closedmichal Arrow keys don't navigate between items correctly in some views 
related to 0017797 newdrakinite Improve accessibility of MediaMonkey 5 
related to 0018057 resolvedLudek Ctrl+Arrow key triggers hotkey when inline editing 
related to 0018107 closedmichal "Max callstack size exceeded" when using 'Ctrl+A' in expanded album pop-up 

Activities

michal

2021-05-25 17:42

developer   ~0063473

1) fixed in build 2408.

rusty

2021-05-27 13:09

administrator   ~0063543

Last edited: 2021-05-27 13:10

View 2 revisions

Re. 2b) following discussion with Michal, it would be preferable to TAB through player controls since groups are skin-dependent. i.e. Arrows in the Player should be used only within the Seekbar, Ratings control, and Volume bar.

michal

2021-05-28 12:15

developer   ~0063588

Fixed in build 2410.

rusty

2021-05-28 21:24

administrator   ~0063597

Tested 2410 and it's mostly working quite well. The only problem is that using the arrows to navigate within a group also causes the Seekbar to move. e.g.
0 Initiate Playback
1 TAB to breadcrumbs bar
2 Use the Arrow keys to navigate within the breadcrumbs
--> seekbar also moves!

peke

2021-05-28 22:18

developer   ~0063603

Beside 0017849:0063597 Tab orders in various skins and menu navigation (Arrow keys) work very well also when tabbing in player Arrow keys only react on seek bar and volume bar which is desired behavior.

Tested on various skins.

michal

2021-05-29 08:17

developer   ~0063608

Collision with arrow Hotkeys fixed in build 2411.

lowlander

2021-06-04 02:16

developer   ~0063729

1) Tab highlights Waveform in Player twice, 2 tabs to pass it, this is not a problem with the Seekbar
2) Not sure if this is a problem, but if you tab, open Context (with keyboard key) and tab again the Context Menu stays open
3) Using keyboard enter key on the Arrows in the navigation Breadcrumb after tab + arrow key to one the context menu opens at the left+top of main window (not an issue when using mouse)
4) Right/Left Arrows move Seekbar when Tab highlights Player buttons (Previous/Pause/Stop/Next/Repeat/Shuffle/Cast)
5) Right/Left Arrows move Seekbar on Rating when reaching the lowest/highest Rating and continuing to use the arrow key used
6) Right/Left Arrows move Seekbar when Tab is selected (either when 1 tab or multiple tabs are open
7) Not sure if this is an issue, but tab sequence skips the Main Menu

michal

2021-06-04 12:46

developer   ~0063747

Last edited: 2021-06-04 12:47

View 2 revisions

1, 2, 3, 5, 6 fixed in build 2412.

4) it is expected, player buttons do not have any functionality on arrow keys, so global hotkeys are processed
7) main menu is accessible by Alt key from any part of the GUI, no need to select it by Tab

lowlander

2021-06-04 16:30

developer   ~0063755

8) When My Library is tabbed to in the Browser View in the Filelisting the arrow key can be used to switch to Online, but Seek also responds to arrow keys

michal

2021-06-04 16:38

developer   ~0063756

8) fixed in 2412.

lowlander

2021-06-04 18:38

developer   ~0063761

9) In Browser View add Tab step to All Tracks/Top Tracks with arrow key accessibility to List/Simplified List selector
10) In Browser View add arrow key accessibility to Play/Shuffle/3 dots when Tab select My Library

michal

2021-06-04 18:48

developer   ~0063762

Last edited: 2021-06-04 18:48

View 2 revisions

9) List/Simplified List selector is depricated and will be removed soon, as simple list can be better simulated by list with automatic column width
10) I would prefer TAB stops, they are different controls

Ludek

2021-06-04 20:18

developer   ~0063767

As for the collisions with Left/Right assigned as hotkeys for 'Skip 5 seconds forward/backward'.
I would rather remove these from default hotkeys or change them to 'Ctrl+Left' / 'Ctrl+Right' , because left/right is needed in almost every control and would be in collision with the hotkeys

drakinite

2021-06-04 20:35

developer   ~0063768

Ctrl + Left and Ctrl + Right sounds like a good idea. The fact that there are so many controls that use left/right keyboard inputs.

The exception, of course, should be when the seekbar itself is selected. If the seekbar is selected then it certainly makes sense to accept left/right keyboard inputs.

michal

2021-06-05 15:37

developer   ~0063778

9) and 10) fixed in build 2413. Used TAB (user can skip whole rows by pressing up/down arrow in the view and left/right key sometimes can do horizontal scrolling)
Hotkeys for skipping 5s changed to Ctrl+arrows.

lowlander

2021-06-09 16:55

developer   ~0063867

11) In Browser View tab to the Tracks doesn't highlight the selected file with the dotted outline like every other item tabbed to. The item is highlighted though (background changes shade of grey).

lowlander

2021-06-09 17:02

developer   ~0063868

Last edited: 2021-06-09 17:06

View 2 revisions

1,2, 3, 5, 6, 8, 9, 19) Verified on 2413
4) Arrow key navigation removed, now moves seek only

lowlander

2021-06-09 17:11

developer   ~0063869

11) Can't reproduce, so not sure why this was initially the case
12) Tab has 2 stops on Breadcrumbs
a) Tab from Tab it stops twice, first highlighting and second not highlighting
b) Shift+Tab from Media Tree, it stops once, without highlighting

michal

2021-06-09 19:06

developer   ~0063871

12) fixed in build 2414.

michal

2021-06-10 07:57

developer   ~0063887

11) improved in build 2415. Now it should always select line and column after tabbing into tracklist.

rusty

2021-06-10 23:00

administrator   ~0063893

Verified 2415.