View Issue Details

IDProjectCategoryView StatusLast Update
0017844MediaMonkey 5Main Panelpublic2021-05-28 22:21
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017844: Arrow keys don't navigate between items correctly in some views
DescriptionWhen the user attempts to use the arrow keys to navigate within a view, it usually works, except for the following cases:

1) When navigating between 'sections' in a browser view. e.g.
Genres > GenreName [Browser]: When navigating down from the Artists section, the user has to press the DOWN arrow 4 times before focus switches to the Albums section, and then another 4 times before focus switches to the Tracks section. The workaround is to use the TAB key to switch sections, but this isn't intuitive.

2) When navigating in Genres > GenreName [list(by album], pressing the DOWN arrow works correctly but often results in 'false' selection of another track (i.e. occasionally other tracks appear selected even though they're not).

EDIT: This issue also applies to the tree. i.e. if the cursor is towards the top of the tree and the user clicks DOWN to navigate lower and scroll to lower portions of the tree, then the mouse cursor continues to remain active and highlight the portions of the tree that scroll by it!

3) When navigating in Artists > ArtistName [Browser], pressing DOWN fails to advance to the Albums section. This seems to be a different problem than 1). In this case, the issue appears to be that focus doesn't rest in the main panel.

4) A similar issue occurs in Years > <decade>:
a) DOWN has no effect because nothing is initially in focus (same as issue 3)
b) Click an album to get it in focus and then press DOWN --> view moves down but nothing is in focus and the view just keeps refreshing
TagsNo tags attached.
Fixed in build2405

Relationships

related to 0016371 assignedLudek Switching views expands / changes selection 
related to 0017849 closedmichal TAB key navigation can be confusing in the main panel 
related to 0017797 newdrakinite Improve accessibility of MediaMonkey 5 

Activities

michal

2021-05-14 10:11

developer   ~0063206

Fixed in build 2405.

peke

2021-05-15 20:55

developer   ~0063225

Verified 2405 issues based on video and description.

Also tested for regressions when navigating items with keyboard,

Left resolved till second verification is confirmed due the complexity of test cases.

peke

2021-05-28 22:21

developer   ~0063604

Re Verified 2410

Except regression described at 0017849:0063597 Arrow keys navigation works.