View Issue Details

IDProjectCategoryView StatusLast Update
0017826MediaMonkey 5Main Panel: Toolbars & Menuspublic2022-08-01 15:05
Reporterdrakinite Assigned To 
PriorityurgentSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version5.0.1 
Target Version5.0.4Fixed in Version5.0.4 
Summary0017826: Add the ability to add/configure custom items in the toolbar
DescriptionMM4 allows the user to add custom toolbar icons, but the feature is not currently present in MM5.
User has requested it here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98966

There is plenty of space to the left of the View toolbuttons; but also, custom toolbuttons could be placed between the Show Sidebar button and the Navigation bar.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100263
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99394
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99447
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99466
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100418
https://www.mediamonkey.com/forum/viewtopic.php?f=27&t=97190
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100904
https://www.mediamonkey.com/forum/viewtopic.php?t=102255
https://www.mediamonkey.com/forum/viewtopic.php?p=498238#p498238
Ticket 1990
Tagstodoc-help
Fixed in build2658

Relationships

related to 0018383 feedbackrusty Multi-attribute fields: multi-selection/deselction of attributes requires the keyboard and multiple views of the attribute list 
related to 0019219 newLudek Custom Toolbar is not available as Layout selection element 
related to 0019296 closedLudek Rating set through Context Menu fails in Playing panel [Regression 2658] 

Activities

barrym

2021-12-08 09:07

reporter   ~0066282

LowLander: "There is plenty of space to the left of the View toolbuttons"

I don't think so.
AFAIK part of the design objective of MM5 was to allow the option of making the Media Tree panel largely irrelevant, with the left hand panel closed most of the time.
This is how I use MM5, the advantage being more screen space for the central panel, and a grateful goodbye to wrangling with, and scrolling through, great long vertical lists.

This way of operating relies upon reserving plenty of space for the breadcrumb menu to grow (see image).
And this left hand space will be required if you are to consider the request to put the terminal nodes back into the breadcrumb menus
ie. Music>AlbumArtist>The Allman Brothers> Brothers and Sisters, like they were in MM4
no so much free space.png (44,843 bytes)   
no so much free space.png (44,843 bytes)   
terminal nodes.png (4,884 bytes)   
terminal nodes.png (4,884 bytes)   

Ludek

2022-06-16 20:52

developer   ~0068576

Last edited: 2022-06-16 20:52

Yes, I think that the custom toolbar needs to be another line as in MM4:
image-2.png (38,152 bytes)   
image-2.png (38,152 bytes)   

Ludek

2022-06-16 20:53

developer   ~0068577

Changing target to 5.0.4 as this seems frequently requested feature.

Ludek

2022-06-23 14:18

developer   ~0068659

Implemented in 5.0.4.2655

Custom items can be configured in Options > Layout > Toolbar and are shown as the new line:
image.png (97,378 bytes)   
image.png (97,378 bytes)   

peke

2022-06-24 21:32

developer   ~0068680

Verified 2655

Toolbar is available and working.

peke

2022-07-09 21:41

developer   ~0068794

Last edited: 2022-07-09 21:44

Serious regression against rest of MM.
If no tracks are selected then buttons should be disabled.
https://www.mediamonkey.com/forum/viewtopic.php?p=499056#p499056

peke

2022-07-09 21:42

developer   ~0068795

image-3.png (46,803 bytes)   
image-3.png (46,803 bytes)   

Ludek

2022-07-15 23:20

developer   ~0068843

Fixed to the same level like in MM4.

i.e. actions like 'Convert Files', 'Auto-Organize' are still performed on whole tracklist of the selected node
while actions like Mood, Tempo, Occassion, Quality, My Rating are performed only on tracks that are selected in the tracklist.

=> Fixed in 5.04.2658

barrym

2022-07-16 03:45

reporter   ~0068845

Nice addition, but can there be a toggle control on the main toolbar to hide|display the secondary toolbar.
eg. something alongside the piano-looking thing at the left, which toggles visibility of the left hand panel.

It would be good if this requested toggle control was invisible if there was an empty "Selected" list for the secondary toolbar.

I tried option "General: Add directory"
I was hoping that it would give me a way to be able to add a directory to a top level share using the Folders node, when coming from a Pin of the top level Share ... there is no way to do this in MM5 at the moment. This has to be done outside MM5 in Microsoft File Explorer.

The "General: Add directory" option seems to be connected to the wrong action, or the option name is misleading.
It asks for a podcast directory .. ?