View Issue Details

IDProjectCategoryView StatusLast Update
0017770MediaMonkey 5Generalpublic2021-04-21 10:34
Reporterdrakinite Assigned To 
PriorityimmediateSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017770: Unresponsive window on clean install / crash 539F6172
DescriptionMultiple users reported the same behavior on 2336 RC-8: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98829
Steps To ReproduceSteps to reproduce:
1) Create a clean installation of *portable* 5.0.0.2336
2) After the "MediaMonkey COM elevator" prompt opens, click *either* Yes or No.
The window goes white and unresponsive after the elevated permissions prompt is either accepted or declined.
Additional Informationdjasonpenney also mentioned that it occurs on non-portable install, though I have not seen it on non-portable myself.
TagsNo tags attached.
Fixed in build2337

Relationships

related to 0015176 closedLudek Playing from portable version to a renderer may fail (as portable version doesn't auto-conf firewall) 
related to 0017717 closedLudek MM5 UPnP server often becomes inaccessible after MM5 is running for an extended period 

Activities

drakinite

2021-04-17 18:04

developer   ~0062866

I vaguely recall discussion about this in the past, but I don't see why a portable install should use COM at all. I don't recall the reasoning that was given for running the COM elevator on portable.

rusty

2021-04-18 02:25

administrator   ~0062867

Last edited: 2021-04-18 03:06

View 3 revisions

fwiw, I had installed 2336 in both portable and regular modes without an issue (though never as a clean install).

But when i try a clean install of 2336 I experience either of the following when the wizard is run:
a) crash 539F6172 in UPnP.dll and MM is frozen (sometimes with a white screen)
b) MM is frozen (on the scan screen) without a crash
(logs for both cases posted)

Note that an escalation prompt doesn't usually appear for me (I wonder if it sometimes appears in back of MM?)

drakinite

2021-04-18 02:55

developer   ~0062868

Deleting UPnP.dll appears to cause the issue to stop.

Ludek

2021-04-18 14:20

developer   ~0062871

Last edited: 2021-04-18 14:23

View 4 revisions

Fixed in 2337

This regression was introduced while fixing 0017717
The portable version uses the COM elevator because of 0015176

peke

2021-04-21 10:34

developer   ~0062895

Re Verified 2238

Tested on 20 installations/de-instalaltions of clean, imported, portable/Normal

NOTE I was Able to replicate White screen on one PC that was on re installation and 2236 all tests done on that PC and on my main PC to check for regressions.