View Issue Details

IDProjectCategoryView StatusLast Update
0017599MediaMonkey 5Generalpublic2022-07-15 21:20
Reporterdrakinite Assigned To 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0017599: Clicking in empty space below tracklist does not cause it to be focused
DescriptionIf the column filter is enabled, and you select an album then click the empty space below the tracklist and hit Ctrl + A, the column filter selects all items instead of the tracklist. I believe this is because clicking on the empty space does not cause MM to change the currently focused control.
TagsNo tags attached.
Fixed in build2656

Relationships

related to 0017763 closedLudek Mouse lasso selection fails when started below the list component 
has duplicate 0019173 closedLudek Click on empty area of main tracklist should give focus to it 

Activities

rusty

2021-05-21 17:37

administrator   ~0063358

It's a little complicated because:
a) CTRL-A should also work within the column filter (if the user wants to select all attributes in a column and then deselect some)
b) Clicking outside the available fields is currently treated as if the user clicked the 'All' entry in the column

Nonetheless, I agree with the suggestion. This would mean that:
a) CTRL-A should continue to work in the column filter except if the user has clicked outside the active fields
b) Clicking outsidethe available fields would continue to result in 'All' being activated, BUT it shouldn't be in focus.

michal

2021-05-24 07:43

developer   ~0063408

Rusty: the issue was about clicking below tracklist, not below items inside column filter control.

It is not a bug, the space below tracklist is empty space, there is no tracklist control there and no other focusable control too. The only thing, we can do, is setting last focused control to null, so Ctrl+A will not select anything after this click. Should we change it this way?

Ludek

2021-05-24 09:01

developer   ~0063410

This issue is strictly related to 0017763
I think that the solution would be so that the last component in the column (tracklist in this case) would always take up all the remaining space in the Scroller compoennt above.
This would resolve also 0017763

Ludek

2021-05-24 19:49

developer   ~0063429

Last edited: 2021-05-24 19:50

View 2 revisions

I have prepared code for this and backed up to SVN as revision 38030
By activating this code the last component in the scroller will always take the remaining space (below the last component).

Nevertheless currently I am not sure whether the code is even needed, because for me clicking below the tracklist and pressing Ctrl+A still selects all tracks (even with my code disabled).
So probably there is already implemented another mechanism and my code isn't needed? Leaving it disabled (to prevent from potential regressions by enabling it needlessly)

zvezdan

2022-06-23 21:52

updater   ~0068668

> for me clicking below the tracklist and pressing Ctrl+A still selects all tracks

I don't know how this issue is related to the one that I reported and you marked as Resolved, but for me clicking below the tracklist and pressing Ctrl+A selects items in the wrong panel:

1. click on any item in the Playing list;
2. click on the empty area below the tracks in the main tracklist;
3. press Ctr+A -> all tracks in the Playing list are selected instead of tracks in the main tracklist.

The same apply if you have initially focused any item from the Media Tree instead of Playing list.

MM4 didn't have this problem.

zvezdan

2022-06-23 22:06

updater   ~0068669

Um sorry, the same thing with Ctrl+A doesn't apply when you have initially focused an item from the Media Tree, i.e. when you click on the empty area below tracks in the main tracklist you will get selected tracks in the main tracklist.

However:
1. click on a node in the Media Tree that has just a few tracks;
2. click on the empty area below the tracks in the main tracklist;
3. press Up or Down key -> nothing will happen, neither tracks in the main tarcklists, nor the items in the Media Tree will be focused.

Ludek

2022-06-28 19:33

developer   ~0068727

Fixed in 5.0.4.2656

peke

2022-07-04 22:14

developer   ~0068774

Verified focus issue in 2656

Small tweak is needed as:
1. Add 5-10 tracks to Now playing
2. Select Playing -> List in Tree
3. Select one track in The middle of playlist
4. Click on Preview Windows Title to loose focus from Track browser
5. Click on Empty space in track browser to restore ficus (working)
6. Selection is lost

I think that expected is that selection is preserved if Track browser was not in focus, as that way user can continue browsing eg. like focus is returned when TAB is used to Switch back Focus (instead of click in step 5 use 2x SHIFT+TAB to restore focus to Playing)

Please review and close if you do not agree as it is just suggestion.

Ludek

2022-07-15 21:20

developer   ~0068842

Clicking below the list always clears selection even in Windows Explorer and in MM4, so I guess changing this behaviour wouldn't be welcome.