View Issue Details

IDProjectCategoryView StatusLast Update
0017591MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-02-26 20:07
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017591: Option panel opens behind the Auto-tag panel (regression)
DescriptionSteps to reproduce the issue:
select any track from the list and open the Auto-tag panel from context menu (right click)
click on the Option button in the Auto-tag panel
the panel opens behind the Auto-tag panel
If you click on any part of the player (not on the Auto-tag Panel), the Option panel will come to the foreground.

Version: MediaMonkey_5.0.0.2314
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98481
TagsNo tags attached.
Fixed in build2316

Relationships

related to 0017570 closedpetr Sub-dialog appears in back of MM window requiring MM to be force-closed OR causing loss of menu functions 
related to 0016016 closedmichal Multiple Missing Codec Pack dialogs cause loss of focus 

Activities

petr

2021-02-21 19:51

developer   ~0062079

Fixed

peke

2021-02-25 08:52

developer   ~0062136

Verified 2315

I tested steps here and those from Forum, also tried on any dialog that can also open second dialog to see if there is no regressions eg. liek Set formats in Device profile.

rusty

2021-02-25 22:57

administrator   ~0062144

Last edited: 2021-02-26 01:21

View 4 revisions

The initial problem seems to be solved, but I'm seeing UI flashing triggered by going multiple levels deep in modal dialogs. e.g.

0 Auto tag a track
1 Click Options (in the auto-tag dialog)
2 Click Layout > Preview > Advanced > [gear] (or any other Options dialog setting that opens a modal dialog)
--> UI starts flashing endlessly (though on occasion this will only occur after repeating steps 1 and 2 again)

https://www.screencast.com/t/juntiGkpnw5

peke

2021-02-26 01:12

developer   ~0062148

Flashing is triggered by background refresh of parent dialog.

petr

2021-02-26 09:53

developer   ~0062155

Fixed

rusty

2021-02-26 20:07

administrator   ~0062166

Verified 2316.