View Issue Details

IDProjectCategoryView StatusLast Update
0016016MediaMonkey 5Main Panel/Toolbars/Menuspublic2019-10-17 23:20
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016016: Multiple Missing Codec Pack dialogs cause loss of focus
DescriptionWhen the user attempts to play multiple tracks that require a codec to be installed, it appears that multiple 'Missing codec' dialogs open and that they don't necessarily display in the order in which they gain focus. So when the user presses 'Cancel' numerous times to exit the dialog(s), eventually a dialog will appear that fails to respond (because the dialog that is in focus is in back of the dialog that's displayed). When this occurs, the only possible course of action is often to force-close MediaMonkey (though sometimes, pressing 'STOP' via the MM icon in the system tray causes the 'Cancel' button to become responsive (presumably it causes the various missing codec dialogs to re-order).

https://www.screencast.com/t/AKlZHBli

Debug log attached.

I would suggest that ideally only a single dialog should appear, containing links to each of the required codecs. If that's not possible, perhaps only one dialog should appear per codec type and the dialogs should appear staggered (rather than directly on top of each other)
TagsNo tags attached.
Fixed in build2204

Relationships

related to 0015020 closedpetr Secondary dialogs are hidden (focus issue) 

Activities

rusty

2019-10-04 19:10

administrator  

codec-pack_focus-issue.7z (90,906 bytes)

michal

2019-10-06 08:49

developer   ~0054952

Fixed in build 2204. Required codecs are generated on server, so we cannot handle it in client properly. I added ignoring subsequent missing codec dialogs in case one is already displayed. I think, it should be enough, as it typically won't request different codecs.

peke

2019-10-17 23:20

developer   ~0055024

Verified 2204/2205

Only single dialog shows.