View Issue Details

IDProjectCategoryView StatusLast Update
0017570MediaMonkey 5Main Panelpublic2021-04-14 20:50
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017570: Sub-dialog appears in back of MM window requiring MM to be force-closed OR causing loss of menu functions
Description1) Dialogs appearing in back of the main MM UI is a problem that occurs intermittently and when it occurs, the user often has no choice but to force-close MM since there's no way to interact with the UI to close the app 'normally'.

This behavior seems to be random, but it does occur often enought that it can be replicated by performing numerous actions related to opening multiple levels of dialogs or triggering MM to open dialogs. I'm often able to replicate it by repeatedly:
1 Initiating volume leveling on tracks that will trigger an error dialog (this always triggers at least 2 dialogs to appear)
2 Navigating multiple levels deep into menus e.g. Options > Media Sharing > Auto-Conversion > Set formats > Video
--> eventually a dialog will appear hidden behind the current dialog, locking the user out of the UI
--> user must force-terminate MM since they're locked out of the UI (they can't even close MM).

2) I think that this is related to another intermittent bug in which the context menu sometimes stops responding for a minute or two and then resumes working. See comment below.

Note:
- sometimes, after waiting a few minutes, clicking MM in the taskbar causes the hidden dialog to re-order and to appear in front
TagsNo tags attached.
Fixed in build2327

Relationships

related to 0016016 closedmichal Multiple Missing Codec Pack dialogs cause loss of focus 
related to 0017591 closedpetr Option panel opens behind the Auto-tag panel (regression) 

Activities

rusty

2021-02-17 19:38

administrator   ~0061978

I'm now fairly sure that there's a relationship between opening multiple levels of dialogs and the MM main menu / context menu becoming non-responsive. In this log, I :
1 Analyzed volume for multiple Music Videos
--> Error dialog appearing
2 Opened the Options > Media Sharing > Library Options >
--> Dialogs did not get hidden
3 Exited out of the Options dialog and then attempted to use menus / context menus
--> MediaMonkey menus failed to open!
4 Double-clicked a file
--> Playback works
5 Clicked on menus/Right-clicked on item again
--> MediaMonkey menus continue to fail to open!
6 Waited about 10 minutes and then re-attempted to click menus / right-click context menu
--> Menus still fail to open.
7 Terminated MM
See: 37507 - end

Log posted to ftp.

drakinite

2021-02-17 20:11

developer   ~0061981

I can also reproduce occasionally when opening multiple dialogs. It took a few attempts, but I could also do it by opening Add/Rescan > Options > Manage Addons > opening a configuration panel. Additional log posted to ftp if it helps.

rusty

2021-02-17 21:51

administrator   ~0061986

Note: for issue 1) pressing ESC has resolved the problem (the one time I've been able to replicate the issue since Peke suggested trying to use ESC). I don't know if this workaround always works.

drakinite

2021-02-18 04:08

developer   ~0061988

Alt-Tab seemed to work at bringing the background modal window to the foreground, at least the one time I tried it.

petr

2021-02-18 16:44

developer   ~0061992

Fixed

peke

2021-02-18 23:21

developer   ~0062001

Verified 2313

Unable to reproduce while trying various known cases for an hour.

rusty

2021-02-19 02:08

administrator   ~0062011

Unable to replicate in 2313.

drakinite

2021-03-19 22:13

developer   ~0062515

The issue seems to once again be present when installing addons. More information here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98660

I can reproduce on non-portable by installing an addon via the "Add" button or by doubleclicking on the MMIP. It seems inconsistent on precisely which dialog decides to be problematic (Sometimes it's the first one in the install process, sometimes the second, etc.)

petr

2021-03-21 18:04

developer   ~0062522

Fixed

drakinite

2021-03-23 00:06

developer   ~0062537

Verified 2327