View Issue Details

IDProjectCategoryView StatusLast Update
0017456MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-12-01 06:42
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017456: Unsaved lyrics should be saveable in the same way as unsaved Artwork
DescriptionCurrently if Artwork is automatically looked up, the user can:
- See that it is 'unsaved' in the Preview and Properties windows
- Save it in both of these Windows

MM should take the same approach with Lyrics.
TagsNo tags attached.
Fixed in build2512

Relationships

related to 0017206 closedmichal Lyrics are saved to the DB even if Lyrics lookup is disabled 
related to 0017635 closedmichal Playing: Album Art and Lyrics Context Menu do not offer save 
related to 0018612 closedmichal Background metadata lookup: lyric lookup on startup often searches endlessly 
related to 0017137 closedmichal Lyrics window doesn't lookup Lyrics / eternal searching Lyrics 
related to 0017451 closedmichal Lyrics lookup isn't working correctly (regression) 
related to 0017436 closedmichal Found lyrics are not saved to tag in properties dialog 
related to 0017890 closedmichal Lyrics Search: Found lyrics with Auto lyrics search is not propagated to track properties 

Activities

michal

2021-01-29 08:38

developer   ~0061626

Fixed in build 2302. It was regression, that the save icon did not show and work.

peke

2021-01-29 21:19

developer   ~0061656

Verified 2302

Lyrics save button function in both Preview and Properties windows

rusty

2021-01-29 21:28

administrator   ~0061660

I'm not seeing a 'Save' button in the Properties dialog. I'm not sure if this was previously implemented or not, but wouldn't it make sense for Lyrics to work the same as artwork?
i.e. If the lyrics exist just in the cache but not in the DB/Tag, they can appear in Properties:
- With a 'Save' icon (so that it's clear that they're just in the cache

This would be for 5.0.1.

peke

2021-01-30 01:54

developer   ~0061663

You are right, It still do not work in some cases.
Here are steps where behavior should be unified:
1. Enable Auto Metadata Lookup for lyrics and artwork without update tags
2. Preview window set to Advanced and add lyrics to be shown
3. Playing track Trigger Auto lyrics and artwork search and Save button is shown 2301 didn't show save button.
4. Right click on lyrics in preview -> Properties -> Lyrics (they are missing even they are already available in preview) -> Artwork (Save icon is shown on searched artwork). NOTE I guess that is what Rusty meant with 0017456:0061660 that both should have same behavior
5. Cancel properties dialog
6. Play next track and wait till lyrics are searched and then return to previous track that was already searched for lyrics and should be cached
7. Lyrics are searched again like they were not cached (sometimes not always)
8. Click tree Playing view and select that playing show lyrics and they are in sync with Preview window while track properties -> lyrics are still empty.

michal

2021-10-21 07:44

developer   ~0065366

Fixed with 0017890.

peke

2021-10-22 15:51

developer   ~0065433

Verified 2511 during testing 0017890

rusty

2021-10-24 19:53

administrator   ~0065478

Last edited: 2021-10-24 20:11

View 2 revisions

This doesn't seem to be fully fixed in 2511--once lyrics are looked up but not saved, the cache (whether it contains lyrics or ""), takes precedence over subsequent lookups even if the user deletes the unsaved data. e.g.

1 Set Options > Metadata Lookup > Sources (for lyrics) to 'Lyrics Mode'
2 Navigate to a track and in 'Preview [Selected]' click 'Lookup lyrics'
--> Lyrics aren't found
3 Set Options > Metadata Lookup > Sources (for lyrics) to all sources
4 Navigate to a track and in 'Preview [Selected]' click 'Lookup lyrics'
--> Lyrics aren't found (because there's a hidden lyrics cache containing "" from Step 2)!
5 Select the track and use auto-tag
--> Lyrics are found!

The opposite also occurs. i.e. if one finds lyrics with a single source, then deletes the unsaved lyrics from Properties > Lyrics, and then switches Lyric source to a source that doesn't contain the lyrics, and then uses 'Lookup lyrics' again --> the lyrics will be 'found' even though they don't exist on the source that's enabled (presumably because they're taken from a 'hidden cache')!

This makes it rather difficult to know which sources are useful and which aren't (this is the bug that was causing user confusion about which sources are useful at https://www.mediamonkey.com/forum/viewtopic.php?p=489186 ).

Summary:
- When lyrics are deleted, the cache should be deleted
- Background metadata lookups that are initiated (automatically when no lyrics exist) should always return looked up metadata (currently they don't if the 'hidden' cache contains "" / or if the 'hidden' cache contains existing lyrics)
- Manually initiated metadata lookup (via Properties) should overwrite unsaved metadata
- Auto-tag: should work the same way as other fields (i.e. lookup data even if it exists but highlight when it conflicts)

michal

2021-10-25 14:32

developer   ~0065489

Fixed in build 2512. Lyrics temporary cache is cleared after any change in lyric sources and not used when lyric search is triggered by user action. This should solve described problems without need of multiple requests for the same track (that is the purpose of the temporary cache).

peke

2021-10-29 19:55

developer   ~0065563

Verified 2513

Test note: as noted 0017456:0065489 it seams it really lower additional queries for same track which makes lookup faster.