View Issue Details

IDProjectCategoryView StatusLast Update
0018612MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-12-02 03:45
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.2 
Target Version5.0.2Fixed in Version5.0.2 
Summary0018612: Background metadata lookup: lyric lookup on startup often searches endlessly
DescriptionIn build 2523, quite often upon launching MM, the Preview Window will show 'Searching for lyrics...' as the hourglass spins endlessly. Upon clicking that same track manually, the lyrics appear immediately (without waiting for a lookup). In other words, it appears as if the lookup works, but the UI fails to reflect that. e.g.

1 Launch MM
--> Waste My Time by Findlay is selected in the Playing list and its lyrics are looked up endlessly!
2 Click People by Kye Kye
--> Lyrics are found
3 Click Waste My Time by Findlay
--> Lyrics appear immediately (i.e. they appear to have been looked up and cached at step 1, even though they never appeared)!

Note: This occurs when 'Background metadata lookup' is enabled for Images/Artwork/Lyrics but 'Update Tags' is disabled

This issue isn't that severe since in this case it's easily worked around by clicking another track. However, if the Preview window is configured to display the Playing track, then the bug occurs for the full duration of the track (though tracks that are subsequently played display the looked up lyrics).
TagsNo tags attached.
Fixed in build2524

Relationships

related to 0017456 closedmichal Unsaved lyrics should be saveable in the same way as unsaved Artwork 

Activities

rusty

2021-12-01 06:40

administrator   ~0066185

This may be a separate bug--I'm not sure, but it's probably related: In this configuration (with background metadata lookup enabled and updated tags disabled), if lyrics are auto-looked-up, and then MM is restarted, then the lyrics are looked up again--i.e. they're not cached in the same way that Album Art images are.

michal

2021-12-01 06:49

developer   ~0066186

Last edited: 2021-12-01 06:50

View 2 revisions

Caching lyrics only in RAM during app run is by design. I do not see any sense in saving lyrics separately somewhere, if user wants to save them, than he/she should save them at least to DB.
Images are cached, because they are not saved to DB, but lyrics easily can.

michal

2021-12-01 12:12

developer   ~0066202

Fixed in build 2524. Caching not saved lyrics left as it was, temporary in RAM. Saving lyrics to track can be easily done by pressing save button, this saves lyrics to DB (and if updating tag is set, also to tag) and they will not be searched any more for this track.

michal

2021-12-01 18:27

developer   ~0066210

Last edited: 2021-12-01 18:28

View 2 revisions

Added also additional caching of lyrics servers' responses to eliminate unnecessary lookups during next app sessions.

rusty

2021-12-02 03:45

administrator   ~0066217

Verified 2524
- no endless hourglass
- unsaved lyrics --> saved lyrics workflow (both in Preview and Properties dialogs)
- persistence of unsaved lyrics after restart