View Issue Details

IDProjectCategoryView StatusLast Update
0017451MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-01-28 23:12
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017451: Lyrics lookup isn't working correctly (regression)
DescriptionWhen Lyrics lookup is enabled in 2999, the lyrics never display in the Preview or Lyrics windows or even in Properties!
1 Enable Options > Metadata Lookup > Lyrics (without 'Update tags')
2 Set the Preview window to a view that displays lyrics and/or enable the Lyrics window
3 Add a bunch of tracks that are missing lyrics to the Playing list, and Play them
--> Even when lyrics appear to be found they don't display (even in the Properties dialog)!
4 Switch to Playing [Lyrics] or Playing [Album Art] view
--> Lyrics that are looked up do display (but still not in the Preview/Lyrics windows)

Note: I haven't tested whether the same issue occurs with other looked-up fields.
TagsNo tags attached.
Fixed in build2300

Relationships

related to 0017137 closedmichal Lyrics window doesn't lookup Lyrics / eternal searching Lyrics 
related to 0017206 closedmichal Lyrics are saved to the DB even if Lyrics lookup is disabled 
related to 0017456 closedmichal Unsaved lyrics should be saveable in the same way as unsaved Artwork 

Activities

michal

2021-01-28 17:45

developer   ~0061591

Fixed in build 2300. Note, that found lyrics will be still not shown in properties dialog in this case, it is expected, because of 0017206.

rusty

2021-01-28 23:12

administrator   ~0061603

Verified 2300.