View Issue Details

IDProjectCategoryView StatusLast Update
0016885MediaMonkey 5Now Playingpublic2021-04-08 02:53
Reporterlowlander Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status feedbackResolutionreopened 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0016885: Allow users to define fields in Playing
DescriptionAllow users to define Columns in Playing of what tags should be displayed like the Now Playing window in MediaMonkey 4. The current Playing window has no customization options for the user.

-- Edit by Rusty--
The user complaint can be broken down into 2 issues:
1) Customizability of the summary field
2) Customizability of the header fields

I would suggest that the initial focus should be on allowing the summary field to be customized on a per-type basis (issue 1). e.g.
Display format for individual tracks:
Player Summary: _$if(<Artist>,<Artist> - ,)<Title>_ [>>]
Playing Summary: _<order>. <title> | <rating> || $if(<Artist>,<Artist> - ,)<Album> | <time>_ [>>]

Note: the format used for the mask is just an example. We may decide e.g.
- Track order shouldn't be optional
- Right/Left justification-separation should be symbolized by something other than |
- Line splits should be symbolized by something other than ||

Note2: The Preview Window contains very similar Per-Type formatting. It would make sense to have all 3 of the per-Type display configuration items in the same location (or at least be accessible from the same location). TBD.

EDIT 2 by Rusty:
Should some users prefer using columns as in MM4, in order to keep the Playing list aligned with the tracklist, the following approach could be used:
# . . . Playing . . . Length
## . Metadata . . mm:ss
## . Metadata . . mm:ss
<Playing status bar>
However, this approach is problematic as well because there's no obvious spot for the Playing ⋮ menu. For this reason, I think that we would first try to tweak the current approach.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97126

Other complaints about the lack of metadata configurability of the NP list:
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=98389
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=98464
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98094&p=476593&hilit=playing+columns#p476593
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97736&p=474654&hilit=playing+columns#p474654
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97695&p=474515&hilit=playing+columns#p474515
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97126&p=471302&hilit=playing+columns#p471302
TagsNo tags attached.
Fixed in build2316

Relationships

related to 0016999 closedmichal Playback rules' 'Display Format' doesn't apply to the Playing list 
related to 0017611 new Improved customization of the Playing 'Simplified list' 
related to 0017612 closedmichal Playing 'List' Columns can become unadjustable 
related to 0017615 closedmichal Playing not focused on active file on MediaMonkey start (regression 2316) 

Activities

Ludek

2021-02-22 20:04

developer   ~0062096

Last edited: 2021-02-22 20:10

View 4 revisions

OK, I agree that some degree of configurability would be useful (like for the player in Options > Player > Playback Rules) like:

Playing List: [<title>] [<Album Artist>] [<Album>] Rating Length

i.e. at least the first three left most columns out of currently five hardcoded columns/values: https://www.dropbox.com/s/r4yeq529qs062n7/screenshot%202021-02-22%2021.01.38.png?dl=0 could be configurable.
The config would be just a little bit confusing -- as the information is shown based on the width of the window, i.e. it can be from five columns (single row) in the most wider variant down to two columns (and two rows) in the most narrow variant.

jiri

2021-02-23 09:18

administrator   ~0062104

I'm ok with adding a customization here, but I'm afraid that if we start anything here, it'll be rather complex, because a simple implementation won't satisfy most requests. I think that we could satisfy users by creating an addon that'll initially add some kind of customization and might easily evolve in time, later possibly even be joined to the main MM codebase.

It could start by letting user to add individual columns like:
Field: <Artist> - <Title> Align: Left Width: 80%
Field: <Length> Align: Right Width: 20%

Later improvements could include things like:
a) More fined column config (min-width?)
b) Per-type configuration (probably should be even be in the initial implementation).
c) Option to show content in >1 row.
d) Configuration per width (like we currently have hardcoded, smaller widths resulting in 2 rows, ...)

jiri

2021-02-23 09:19

administrator   ~0062105

Assigning to Jordan to review whether he could create a small addon quickly.

jiri

2021-02-23 18:00

administrator   ~0062119

Per IM with the devs, we'll really try to support two modes for Playing list, the current and a column based. Michal is going to look into it.

michal

2021-02-26 14:00

developer   ~0062157

Fixed in build 2316. Added possibility to insert different controls to Playing list and select them in Options - Layout (Layout... in Playing list menu).

rusty

2021-02-26 20:02

administrator   ~0062165

Tested 2316. Looks good. Some minor suggestions:
1) In Options > Playing list > (o) List add a [gear icon] button so that the user can directly configure columns
2) This is a minor issue, but when the user enables '#' as the first column and narrows the width to the width of the numbers, it subsequently becomes impossible to resize the column because the ⋮ menu button blocks this. Workaround is to use the 'Choose columns dialog to move it to the right, resize it, and then move it back to the left.
3) Ability to disable the status bar
4) In the future we can switch 'Simplified list' to 'Display by Type' and add a [Gear icon] to link to 'Playback rules' (where the user would be able to configure the display format.

The only one that probably makes sense for 5.0 is 1). Please triage.

michal

2021-02-28 13:33

developer   ~0062171

1) gear button fixed in build 2317.

michal

2021-02-28 13:34

developer   ~0062172

The rest postponed to 5.0.1, it is not too straightforward how to implement.

rusty

2021-02-28 18:24

administrator   ~0062173

Last edited: 2021-02-28 19:03

View 2 revisions

Resolved:Fixed for verification.

New bugs to track the remaining issues have been opened at 0017611, 0017612

peke

2021-03-03 19:11

developer   ~0062224

0016885:0062171 Verified 2317

@Rusty, Please close if that is only thing that needs to be tested in 2317.

rusty

2021-04-08 02:52

administrator   ~0062756

Last edited: 2021-04-08 02:53

View 2 revisions

Verified issue 1. Re-opened so that the remaining issues (3 and 4) can be looked at in 5.0.1.